Kunena 6.0.8 Released (17 Jan 2023)

The Kunena team has announce the arrival of Kunena 6.0.8 [K 6.0.8] which is now available for download as a native Joomla extension for J! 4.2.x. This version addresses most of the issues that were discovered in K 6.0 and issues discovered during the development stages of K 6.0.

This category contains miscellaneous, uncategorised user contributions, (templates, modules, plugins and hacks) relating to older versions of Kunena that are no longer supported.

This category may also contain a few topics relating to K 1.6 that may have been moved here possibly by mistake.

The topics in this category are for historical interest only. Owing to the structural differences between K 1.6 and K 1.7, these ideas in these topics will not work with later versions and, for that reason, the topics are locked.

Question [Merged topic] KunenaDiscuss plugin for K 1.5.x

More
13 years 6 months ago #21 by chrisdally
Hi I am new to Kunena, and I have to say so far I am with this forum.

I installed the the latest 0.6 but for some reason for non-users it doesn't show the login or create account links like the previous one did.
Is there anything that I have done wrong? I can't see any settings for this in the plugin?

The Discuss link for the forum article is showing but the login/register isn't.

Also when I check my website with the test comment on the page is then not valid html. As it says;
Line 404, Column 24: value of attribute "id" invalid: "3" cannot start a name

When I see the source on line 404 it is;
<a name="30" id="30" > </a>

(It is for the following page if you would like to check www.worldwidehistory.net/index.php/histo...eople/188-doris-hare )

But I can't see what that link is for? It seems to be the same number as the post number if i am correct! :)

Also just one little thing when I show the discuss image the page is not valid as it needs a;
"/>" on the end instead of ">".

I hope this helps everyone, sorry if the list is so long. But you best know I think. I you need to know anything else then please ask.

Please Log in or Create an account to join the conversation.

More
13 years 6 months ago - 13 years 6 months ago #22 by propedeutique
Hi,
first, thanks for this brand new release of this so usefull plugin.
It works perfectly (and without the legacy bot - a big improvement!)but, as for the latest release of the fb_discussbot (h),the "QuickPost Form" doesn't shows opened but collapsed on the front page for blog/categories articles.
Would it be possible to have this new feature on this plugin.
Thanks again. Bye
Last edit: 13 years 6 months ago by propedeutique.

Please Log in or Create an account to join the conversation.

More
13 years 6 months ago #23 by codefighters
Hi there,
Its good to see this for Joomla 1.5. I am very much interested to test this plugin. Actually, I have been just hired by a client and he wants me to make the Kunena discuss plugin Native to Joomla 1.5. In the meantime, you did the same thing as my client targeted to have, I would like to help you to test this and reporting bugs for its success.

regards
CodeFighters

Please Log in or Create an account to join the conversation.

More
13 years 6 months ago #24 by jerry
version 0.7
- fixed xhtml validness

From now, files would be stored on joomlacode.org. Link is in 1st post in this thread.
I am waiting for approve to be listed on extensions.joomla.org

Please Log in or Create an account to join the conversation.

More
13 years 6 months ago #25 by jerry
chrisdally wrote:

Hi I am new to Kunena, and I have to say so far I am with this forum.

I installed the the latest 0.6 but for some reason for non-users it doesn't show the login or create account links like the previous one did.
Is there anything that I have done wrong? I can't see any settings for this in the plugin?

The Discuss link for the forum article is showing but the login/register isn't.

Also when I check my website with the test comment on the page is then not valid html. As it says;
Line 404, Column 24: value of attribute "id" invalid: "3" cannot start a name

When I see the source on line 404 it is;
<a name="30" id="30" > </a>

(It is for the following page if you would like to check www.worldwidehistory.net/index.php/histo...eople/188-doris-hare )

But I can't see what that link is for? It seems to be the same number as the post number if i am correct! :)

Also just one little thing when I show the discuss image the page is not valid as it needs a;
"/>" on the end instead of ">".

I hope this helps everyone, sorry if the list is so long. But you best know I think. I you need to know anything else then please ask.


OK, for the settings: Try to enable "Enable Public QuickPost" setting.
There was bug in older releases, function was reversed. Still it's in alpha stage, therefore I am cleaning things..
Thanx for reporting xhtml in-validness. It's fixed in version 0.7.
Link with post number is not used yet. From the source code looks like idea developers former plugin (discussbot) to link posts in kunena.

Please Log in or Create an account to join the conversation.

More
13 years 6 months ago #26 by jerry
propedeutique wrote:

Hi,
first, thanks for this brand new release of this so usefull plugin.
It works perfectly (and without the legacy bot - a big improvement!)but, as for the latest release of the fb_discussbot (h),the "QuickPost Form" doesn't shows opened but collapsed on the front page for blog/categories articles.
Would it be possible to have this new feature on this plugin.
Thanks again. Bye

What's expected behavior? I think, now on blog pages, there's only link with "Discuss this item on the forums. (x posts)" when enabled "Show on Blog Pages".

Please Log in or Create an account to join the conversation.

More
13 years 6 months ago #27 by jerry
codefighters wrote:

Hi there,
Its good to see this for Joomla 1.5. I am very much interested to test this plugin. Actually, I have been just hired by a client and he wants me to make the Kunena discuss plugin Native to Joomla 1.5. In the meantime, you did the same thing as my client targeted to have, I would like to help you to test this and reporting bugs for its success.

The best would be to check source code. If you are good coder, I think, you find code which should be enhanced. At least you can check code for bugs. Any help will helps make this plugin better and hopefully we will be in beta stage in days.

Please Log in or Create an account to join the conversation.

More
13 years 6 months ago - 13 years 6 months ago #28 by propedeutique
Hi,
it seems that there is some incompatibility between Kunena Discuss (as well the the fb_discussbot) and Mike Reumer's Googlemap(2.12j) plugin.

When both are enabled in the same content (an article), the Googlemap image doesn't show up: the place for the image has the right dimensions but the image itself is not displayed.
So, I don't know which one is "guilty" ;) and I post this message on both forum.
Thanks for your help.
Link to a problematic article: www.ventsnomades.org/index.php/les-nouve...-/85-salam-from-iran
Bye
Last edit: 13 years 6 months ago by propedeutique.

Please Log in or Create an account to join the conversation.

More
13 years 6 months ago #29 by jerry
propedeutique wrote:

Hi,
it seems that there is some incompatibility between Kunena Discuss (as well the the fb_discussbot) and Mike Reumer's Googlemap(2.12j) plugin.

When both are enabled in the same content (an article), the Googlemap image doesn't show up: the place for the image has the right dimensions but the image itself is not displayed.
So, I don't know which one is "guilty" ;) and I post this message on both forum.
Thanks for your help.
Link to a problematic article: www.ventsnomades.org/index.php/les-nouve...-/85-salam-from-iran
Bye

Looks like problem with the other plugin (you can see, that my plugin works correctly). My plugin is truly class based plugin (extend of JPlugin), which should sustain other plugins very well. The other plugin is not class based plugin.

Please Log in or Create an account to join the conversation.

More
13 years 6 months ago #30 by jerry
version 0.8 - fixed notices/warnings

Please Log in or Create an account to join the conversation.

Time to create page: 0.974 seconds