×
Kunena 5.1.13 Released (21 Jul 2019)

The Kunena team has announce the arrival of Kunena 5.1.13 [K 5.1.13] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× This category contains miscellaneous, uncategorised user contributions, (templates, modules, plugins and hacks) relating to older versions of Kunena that are no longer supported.

This category may also contain a few topics relating to K 1.6 that may have been moved here possibly by mistake.

The topics in this category are for historical interest only. Owing to the structural differences between K 1.6 and K 1.7, these ideas in these topics will not work with later versions and, for that reason, the topics are locked.

Question [Merged topic] KunenaDiscuss plugin for K 1.5.x

More
10 years 2 weeks ago #41 by kmilos
Jerry, 1.0 broke the front page display for me:
[KDiscuss debug: Showing the article intro-text. ShowOnFrontPage is False, Manual Override is False. There should be no tags in the content - skip the overhead and return nothing. ]
[KDiscuss debug: onAfterDisplayContent called with article->id=28. ]

Although I have Show on Front Page* set to "Link".

(* There is typo in the en language file, it says "Show _of_ Front Page instead of _on_")

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago - 10 years 2 weeks ago #42 by jerry
kmilos wrote:

Jerry, 1.0 broke the front page display for me:

[KDiscuss debug: Showing the article intro-text. ShowOnFrontPage is False, Manual Override is False. There should be no tags in the content - skip the overhead and return nothing. ]
[KDiscuss debug: onAfterDisplayContent called with article->id=28. ]

Although I have Show on Front Page* set to "Link".

(* There is typo in the en language file, it says "Show _of_ Front Page instead of _on_")

thanx, will be resolved in 1.1. Actually right now I am rewriting this logic.
There's bug in 1.0, change value of AllowManualOverride, than it works :) I found numerous other bugs there...
Last edit: 10 years 2 weeks ago by jerry.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #43 by mumins

will be resolved in 1.1.

W8888ting ;>
Thanks for this job.

MBR
m.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #44 by jerry
version 1.1
- cleanup whole logic when/what should be shown
- fixed some bugs

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #45 by kmilos
jerry wrote:

version 1.1


Thanks Jerry, works great now!

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #46 by jerry
Good news,
we are now listed on extensions.joomla.org - KunenaDiscuss !
Still there is long way to be stable, but from now, I am also testing it. So if we don't find any bugs, which should be sorted in alpha stage, plugin goes to beta.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #47 by TopCop
OK, may be I have a stupid question, I'm new to Kunena and very new to this Plugin.

I have set up the plugin that the discussion starts in a certain Forum. That works so far.
BUT now I have certain articles that only special users can see. So I want that the discussion of these articles is linked to another Forum, a Forum that has also permission only for special users (authors for example).
But somehow I cant manage this. When I click discuss below a article for my secial users, the discussion starts in the same Forum as for all other users.

I have to mention, that my forum is only for registered users, there is no public access.

Any hint would be appreciated very much!


TopCop

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago - 10 years 2 weeks ago #48 by mumins

version 1.1
- cleanup whole logic when/what should be shown
- fixed some bugs


Nothing/Link/Full <- very nice idea, and works too ;>

Anonymous user CAN SEE quick post form YABADABADoo!!, but can't post OOOPPPSSS...

Other things works like a charm.

P.S.
What do you think about idea that discussbot can works with others than com_contents (SOBI2 etc.)?
P.P.S.
I found some mistakes in latvian language translation.

Attachment ru_RU.zip not found


File Attachment:

File Name: lv_LV-20090805.zip
File Size:2 KB
Attachments:
Last edit: 10 years 2 weeks ago by mumins.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago #49 by mumins
As all of us know - language files for disscussbot living into /administrator/language/.
So - if you want to use discussbot with more than one languages - you must install appropriate ADMIN language pack, not only site.
Just making under administrator/language/ folder xx-XX and copy there xx-XX.plg_content_kunenadiscuss.ini - don't work.
Maybe this can save time and hairs on head for someone ;>

MBR
m.

Please Log in or Create an account to join the conversation.

More
10 years 2 weeks ago - 10 years 2 weeks ago #50 by jerry
TopCop wrote:

BUT now I have certain articles that only special users can see. So I want that the discussion of these articles is linked to another Forum, a Forum that has also permission only for special users (authors for example).
But somehow I cant manage this. When I click discuss below a article for my secial users, the discussion starts in the same Forum as for all other users.

There is one condition, articles with special rights must be within own category. Than you can map this article category to kunena category wich special rights. Use setting "Auto J!-Kunena Catg Id pairs" for doing that. "Auto Discuss Link" must be enabled.
Last edit: 10 years 2 weeks ago by jerry.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.153 seconds