×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

Merged If you are having problems with Kunena, please read this first

More
9 years 8 months ago - 9 years 8 months ago #491 by JuggZaPoppiN
Ok. So I created a subdomain with the latest joomla version, and kunena version.
I also uploaded the same theme on that site as well and the save button works on the test site.
So that would pretty much eliminate the theme causing the issue. Correct?

This message contains confidential information
Last edit: 9 years 8 months ago by sozzled. Reason: Hide the site login details

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago - 9 years 8 months ago #492 by sozzled
There is no need for us to visit your test site if you have established that a "vanilla-flavoured" Joomla/Kunena installation works. What this proves is that you have added something since you installed Kunena (or maybe you added something before you installed Kunena) on your live site that has broken Kunena.

What you now have to do is figure out what you've done. The issue you are having could be caused by a lot of things: Common causes of Mootools (Javascript library) issues and Kunena lists some of those things. Your task is to figure out whether it's the Rockettheme template (or something added by the Rockettheme template), a module, plugin or some other extension is responsible for getting in the way of Kunena functioning the way that it should.

Now that you have a test site, you should try re-tracing your steps: add the Rockettheme template and see if, on your test site, you can still update a Kunena user profile. If you can do that then you can eliminate the Rockettheme template. And so on, add the other things you've added on your live site to your test site until you find the cause of the problem.

Useful background reading on this subject: Which came first? The template or the forum?

*** Topic moved from Support category ***
Last edit: 9 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago #493 by JuggZaPoppiN
Well, for the life of me I cant figure it out.
i tried disabling practically everything.
modules, plugins, etc.
nothing fixed the problem.
i know its not the theme, or kunena template as both of those work on the test site.

Dont you think it still could be something with permissions?
Why is it that ONLY myself can edit my profile when logged into the frontend via admin?
if you are a normal user, then it wont work.

Just doesnt make any sense.

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago #494 by omnidk
Replied by omnidk on topic edit profile not working
Hi All,

I've looked around for a bit and found some info about mootools being a possible reason for the tabs on edit profile not working. I installed the system mootools upgrade, enabled it, still no wirky. I have tried switching themes and logging out then back in, still no wirky. When i checked the source and found the mootools it showed version 1.12

using joomla 1.5.25 and kunena 1.7.1

Thanks ahead of time

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago #495 by sozzled
I don't know if it has something to do with "permissions". Is there a difference between the "permissions" on your test site and your production site? What "permissions" are you talking about?

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago - 9 years 8 months ago #496 by sozzled
omnidk: The answer is found by reading the tips given in msg #1 of this topic. You have a Javascript library conflict and it's something you need to fix.
Last edit: 9 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago #497 by JuggZaPoppiN
Honestly Im not sure If there are differenr permissions or not. :S

Was kinda hoping that maybe you or someone else had a different theory or something else I can look at that is causing this issue.

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago #498 by atvsource
Replied by atvsource on topic Unable to Edit Profile
Just installed Kunena and setup several categories and forums. Went through the control panel and set the various options we felt we needed.

Upon doing some checking, we noticed that we are unable to edit a user profile, upload or change an avatar by clicking on Profile tab.

What setting are we overlooking to be able to edit a profile within Kunena forums?

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago - 9 years 8 months ago #499 by sozzled
I have no theories because I did not create your live website. What we know is that you set up your test site differently to your production site. On your test site, Kunena works; on your production site, it doesn't. I believe the problem is caused by another Joomla extension getting in the way of making Kunena work; what that extension is, I don't know.

My suspicion about a Javascript library conflict remains as rock-solid as it always was. I have not yet seen one case where the "Save" button (in the Kunena profile) became deactivated except through Javascript. If, in your case, it's something else then that will be the first time it's happened that way. That's why I keep suggesting that you eliminate Javascript library conflicts as a possible cause. Your test site effectively shows what happens if you don't have other things getting in the way.
Last edit: 9 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago #500 by JuggZaPoppiN
I am not as code savy or website savy as you. So this may sound as a stupid question.
How do I know what modules/extensions/plugins are javascript?

I really want to find out exactly what is causing this.

Thank you.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.241 seconds