Kunena 6.2.5 & module Kunena Latest 6.0.7 released

The Kunena team has announce the arrival of Kunena 6.2.5 [K 6.2.5] which is now available for download as a native Joomla extension for J! 4.3.x/4.4.x/5.0.x. This version addresses most of the issues that were discovered in K 6.1 / K 6.2 and issues discovered during the last development stages of K 6.2

Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved K 2.0.2, K 2.0.3: problems with preview

More
11 years 6 months ago #31 by deltafidesign
Any suggestion about how check it? I have lot of plugins.

Please Log in or Create an account to join the conversation.

More
11 years 6 months ago #32 by xillibit
Replied by xillibit on topic No preview for messages
Disable all plugins and check if it works, then enable the plugins one by one to see which one is causing the issue;

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
11 years 6 months ago #33 by sozzled

Please Log in or Create an account to join the conversation.

More
11 years 6 months ago #34 by JSene
Any solution for it? My preview still not working after upgrade to Kunena 2.0.2. Can I downgrade to Kunena 2.0.1?

_________________________________________________
The Best Brazilian Motorcycle Community
comunidade.motonline.com.br

Please Log in or Create an account to join the conversation.

More
11 years 6 months ago #35 by freedomcoach
I'm curious to know what happens when you type a message, open preview and do not see the message there, then click submit. Do you then see an error message saying "cannot save message, message box empty"?

This is exactly the issue I've been dealing with for months now and despite tons of troubleshooting, the problem is persisting. There could very well be the same issue with your situation and mine. I need to get to the bottom of it!

Please Log in or Create an account to join the conversation.

More
11 years 6 months ago #36 by 810
if you can send me a admin account, then i can check it for you. Installing lasted test version. And then i will disable some plugins to test it.


if you want me do it. Just add me on Skype "jelle810"

regards 810

Please Log in or Create an account to join the conversation.

More
11 years 6 months ago - 11 years 6 months ago #37 by roland_d_alsace
Hi.

In my case with k 2.0.2, it's only a preview problem linked to html receive instead of json atfer clicking on ajax preview button.

...and when i downgrade to 2.0.1 i don't have the problem.

With 2.0.2 I don't have others problems and 2.0.2 is in production since it is released, here is this forum...

I don't think that it's a plugin problem, otherwise why the 2.0.1 preview could be run without any problems ?

I think that i will test by downgrading step by step some php script from 2.0.2 to 2.0.1, ...
...but someone can say me what php script will be called by ajax button preview ?

Regards
Last edit: 11 years 6 months ago by roland_d_alsace.

Please Log in or Create an account to join the conversation.

More
11 years 6 months ago #38 by 810
html here: "\components\com_kunena\template\blue_eagle\html\topic\edit.php"

script here: "components\com_kunena\template\blue_eagle\js\editor.js"

but the script isn't edited last 5 months.

Please Log in or Create an account to join the conversation.

More
11 years 6 months ago #39 by 810
Open k2.0.1 package and extract the blue_eagle template.

then check the preview.

Please Log in or Create an account to join the conversation.

More
11 years 5 months ago #40 by sozzled
We know, for a fact, that a lot of Kunena's functionality is derived through the use of Javascript-driven functions and we know, for a fact, that Kunena does not work properly if the normal Javascript libraries are in conflict with other software on a user's website. These are established facts and, when other software is installed that interferes with the normal operation of Joomla Mootools or the couple of Javascript libraries (developed by the Kunena team) that are needed for Kunena to run properly, then problems occur. In particular, when the problems cannot be reproduced here at this website (and there's nothing strikingly special about this website), we have to ask ourselves, why are we continuing to see these kinds of Javascript-related problems?

The answers may become more apparent if we look at the underlying source code on these problem websites. The following image compares the HTML source of the site run by roland_d_alsace with a "vanilla-flavoured" website (i.e. J! 2.5.7, Beez20 template + K 2.0.2 and nothing else).



In the above image you can see that the pink-shaded items correspond, one to another. This is good. The unshaded items are unimportant. What we do not know anything about is how the grey-shaded items may be interfering. If we eliminate the grey-shaded items, we may find the one (or the ones) that is/are causing the interference.

I doubt that the upgrade to K 2.0.2 itself is the source of these problems particularly if ../components/com_kunena/template/blue_eagle/html/topic/edit.php and ../components/com_kunena/template/blue_eagle/js/editor.js have not changed. I doubt this because, if upgrading from K 2.0.1 to K 2.0.2 was the singular cause of this problem, there would be tens (or hundreds) of thousands of websites around the world - including this one - that would have been affected.
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.505 seconds