×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Solved Preview does not work

More
5 years 2 months ago #1 by paxx
Preview does not work was created by paxx
Hi
I have CB 2.0.9 installed on my site and K 4.0.3.
If I have the plugin "Kunena - Community Builder integration" published then the preview button does not work.

Unpublish the plugin then preview is working fine.

Does anyone have this issue as well?
And is there a workaround for this issue?

If the problem can be solved why worry? If the problem cannot be solved worrying will do you no good.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #2 by sozzled
Replied by sozzled on topic Preview does not work

paxx wrote: I have CB 2.0.9 installed on my site and K 4.0.3.
If I have the plugin "Kunena - Community Builder integration" published then the preview button does not work.

Unpublish the plugin then preview is working fine.

Does anyone have this issue as well?

It seems strange that this issue, that was first reported nearly two years ago , is still kicking around in the latest versions of Kunena and Community Builder — CB 2.0.10 has been released, by the way — and that the Kunena - Community Builder plugin seems to be the root cause of the problem. I do not have any advice for you other than what you have already discovered for yourself, that is, to disable the Kunena - Community Builder plugin if you want the message preview function to work.

There is also other advice in this forum about this kind of problem. Although I have not tested these ideas — I do not use CB myself — it could be that the problem only affects people who use Internet Explorer .

I hope that some of this information helps.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #3 by paxx
Replied by paxx on topic Preview does not work
Hi
Thanks for your reply.
Find it strange if no one else have this issue. I will write a post on this in the CB Forum as well.

I tried several settings in the plugin and narrowed it down to be the "Enable Access Control" parameter, if this is set to Yes then the preview does not work (and yes I have the GJ plugin installed).

Here are the test I made:

All settings in plugin is set to No
Preview works.

Enable Access Control => Yes (GJ is installed)
Enable Community Builder Login => No
Enable Activity Stream => No
Enable Community Builder Avatars => No
Enable Private Messages => No
Preview does not work.

Enable Access Control => No
Enable Community Builder Login => Yes
Enable Activity Stream => No
Enable Community Builder Avatars => No
Enable Private Messages => No
Preview works.

Enable Access Control => No
Enable Community Builder Login => Yes
Enable Activity Stream => Yes
Enable Community Builder Avatars => No
Enable Private Messages => No
Preview works.

Enable Access Control => No
Enable Community Builder Login => Yes
Enable Activity Stream => Yes
Enable Community Builder Avatars => Yes
Enable Private Messages => No
Preview works.

Enable Access Control => No
Enable Community Builder Login => Yes
Enable Activity Stream => Yes
Enable Community Builder Avatars => Yes
Enable Private Messages => Yes
Preview works.

If the problem can be solved why worry? If the problem cannot be solved worrying will do you no good.
The following user(s) said Thank You: sozzled

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #4 by Torsten
Replied by Torsten on topic Preview does not work
I am not sure whether my problem is connected to this one. When I try to preview my post, Kunena simply returns an empty white space.

See attached screenshot.

Can You help me ?

Bye, Torsten...





This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 128M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : opde2 | author: Torsten Löhr | version: 1.0 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 4.0.3 | creationdate: 2015-06-29

Kunena version detailed: Kunena 4.0.3 | 2015-06-29 [ Possagno ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 3.0.1

Attachments:

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago - 5 years 2 months ago #5 by sozzled
Replied by sozzled on topic Preview does not work

paxx wrote: Enable Access Control => Yes (GJ is installed)
Enable Community Builder Login => No
Enable Activity Stream => No
Enable Community Builder Avatars => No
Enable Private Messages => No
Preview does not work.

It looks like the key to unravelling this mystery lies in the Enable Access Control setting.

I would like to make two points:

1) I do not know anything about GroupJive and I do not know if it works or (according to the latest report ) how much is "left" to be rewritten.

2) There are two possible settings in the Kunena Category Manager for Access Control Type:
  • Access Level (i.e Public, Guest, Super Users, Register, Special)
  • User Groups (as defined by Joomla's ACL)

I always set Access Control Type = User Groups.

I understand that some people would like to use other permissions available from Community Builder or JomSocial. I have no knowledge if these other security mechanisms work with Kunena. Kunena is designed to work with Joomla ACL permissions; I have never tested the other types of access control and I do not think they work with Kunena. I could be wrong.

The Commnity Builder integration plugin for Kunena has a setting for "access control"; there is a similar setting for the JomSocial integration plugin, too. I recommend—to be "safe"—to disable this setting; disabling this setting allows Kunena to rely on Joomla's ACL permissions ... and I know those work! ;)

I am sorry that the developers seem to be ignoring this topic.
Last edit: 5 years 2 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #6 by paxx
Replied by paxx on topic Preview does not work
Hi sozzled
Thanks for taking your time to answer in this post.

As I see it, in my case, it must be something within the GJ plugin for Community Builder.
Kyle (CB Team) is now rewriting this plugin and according to him everything will be tested before an realease.
We'll se then what happens.

The Commnity Builder integration plugin for Kunena has a setting for "access control"; there is a similar setting for the JomSocial integration plugin, too. I recommend—to be "safe"—to disable this setting; disabling this setting allows Kunena to rely on Joomla's ACL permissions ... and I know those work! ;)


Yes - for now I have (in the plugin settings) Enable Access Control => No and so far it seems that everything is working ok. I'll just have to skip the feature where GJ members could have their "own" forums depending on groups.

Once again thank you for taking your time to answer.

Greetings

If the problem can be solved why worry? If the problem cannot be solved worrying will do you no good.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #7 by sozzled
Replied by sozzled on topic Preview does not work

paxx wrote: Kyle (CB Team) is now rewriting this plugin and according to him everything will be tested before a release. ... I'll just have to skip the feature where GJ members could have their "own" forums depending on groups.

As I have written before in this forum, I don't know whether GroupJive will ever work satisfactorily with Kunena. It is possible for forum users to have their "own" categories (using standard Joomla ACL) but it's not quite as easy to do, I guess, if you want this done "automagically".

Also, I do not know if the Kunena team have much active involvement with the CB team these days. That's something you might ask Kyle about, too.

Please Log in or Create an account to join the conversation.

More
5 years 4 days ago #8 by phredcg
Replied by phredcg on topic Preview does not work
I am afraid I have the same issue of Preview not working.

I have tried all the suggestions here. I have disabled all the plugins, and still no success. I have also tried different templates, including Joomla and Kunena templates, but that made no difference.

I am including the configuration here hoping for some assistance.

The forum is for registered users, but if someone can be of assistance if they have access please let me know.

Thanks you.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : design_control | author: Shape5.com | version: 1.0 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 4.0.5 | creationdate: 2015-08-17

Kunena version detailed: Kunena 4.0.5 | 2015-08-17 [ Turnau ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 2.0.11

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
5 years 4 days ago #9 by xillibit
Replied by xillibit on topic Preview does not work
If you have firefox, open firebug and select tab console, then open preview and check in the in firebug console if you have javascript issue ? If you have some errors, copy them here

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
5 years 4 days ago #10 by phredcg
Replied by phredcg on topic Preview does not work

xillibit wrote: If you have firefox, open firebug and select tab console, then open preview and check in the in firebug console if you have javascript issue ? If you have some errors, copy them here


Yes, I did that, too. Checked in Firefox with Firebug and in Safari with Safari's debug console. No errors reported with either one.

Oh, and thanks for the prompt reply!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.489 seconds