×
Kunena 5.2.5 and Blue eagle 1.6.5 released (30 May 2021)

The Kunena team has announce the arrival of Kunena 5.2.5 [K 5.2.5] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.5

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with, this template isn't designed to works with Bootstrap 3 and Bootstrap 4.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question [Merged topic] Kunena Notice: Menu item /forum (Itemid=nnn) does not have Kunena Menu

More
10 years 8 months ago - 10 years 8 months ago #1 by marcusfive
Hi,
i have now upgarded my kunena to the stable version.
But now there are this error message in frontend of kunena:
Kunena Notice: Menu item /kunena (Itemid=127) does not have Kunena Menu.

i have also try to unistall component and reinstall but it is the same.

How can i solve?

and congratulation for the stable version!


Thank you.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 32M

Kunena version detailled: Installed version: 1.6.0 | Build: 3620 | Version name: Spika | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Installed (Version : 1.2.3) | Jomsocial: Disabled or not installed | UddeIm: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed

Modules: Kunena Latest: Disabled or not installed | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Last edit: 10 years 8 months ago by sozzled. Reason: Merged topic; changed subject to improve search relevance

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago #2 by Matias
No need to uninstall.

Kunena just detected issue in your Joomla menu, which prevents it from showing Kunena Menu (Index, Recent Messages...). Detection was added to the stable as many people have been complaining of missing menus.

Please check this: Troubleshooting Kunena Menu

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago #3 by marcusfive
in the menulink i have set: index
but the link generated are: index.php?Itemid=151
and this is link to the last article of my site and not to the forum.

how can solve?

Thank you

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago #4 by Matias
Use menu link instead. See sticky topic that I just added.

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago #5 by Kube
Go to Kunena Control Panel, and use "Create Menu" function, this tool will create the correct forum link in the main menu ;)

Regards.

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago - 10 years 8 months ago #6 by marcusfive
i have do, it create the forum link, but the link are:
/index.php?Itemid=160
and is not the corret link.

and if i go: menù joomla->new->alias->menù voice=kunena menù index
it is the same.

if go: joomla->new->Kunena Forum: Category Index
the url are: index.php?option=com_kunena&view=listcat&catid=0
but the broswor said that the server is redirect the application for this page so that can never be completed.

i seen the the topic just added by matias and also the wiki, but i have not succeeded in resolving

thank you
Last edit: 10 years 8 months ago by marcusfive.

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago - 10 years 8 months ago #7 by zaitx
Kunena menu disapper in forums and sometimes i have error like that
Kunena Notice: Menu item /forum (Itemid=132) does not have Kunena Menu.

Kunena menu works only in category page.

check it out www.enas.com.pl
Last edit: 10 years 8 months ago by sozzled. Reason: Merged topic

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago - 10 years 8 months ago #8 by NoMAD
Same problem here, this new router is useless (adding problems to a simple problem). Kunena RC1,2,3 did not have this problem.
No matter what I do, all looks ok for non-registered users but when registered users see:
Mainmenu(joomla) - Forum www.blabla.com/component/kunena/?view=entrypage&defaultmenu=302
with Kunena Kunena Notice: No menu item assigned. Redirected to /forum (Itemid=302)

Ok, but once in forum that "Forum" link from Mainmenu will transform into www.blabla.com/forum/entrypage

And of course we have Kunena Menu Index that will go as i wish in forum main/home page but the link there is www.blabla.com/forum/index

Tried all from that sticky post.. nothing works as expected. Sure, if Kunena routes all via that new internal router.. c'mon!!! more than one year and we face this kinda problems all in the name of what?

We just need a simple, fast and easy way to put a SIMPLE link in our Joomla Mainmenu, link that will take us to our beloved Kunena Forum Main Page. From that.. Kunena Menu can show as many tabs as users want, without messing up with other menu item.

We shall all try to learn joomla and kunena menu systems over and over again?

PS1 - Sorry to all Kunena dev but its frustrating to stumble upon simple things.
PS2 - Keep it simple guys.
Last edit: 10 years 8 months ago by NoMAD.
The following user(s) said Thank You: srisiam2527

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago - 10 years 8 months ago #9 by Matias
@ marcusfive:

First two should work, but only if your menu module supports aliases (Joomla does support, other menus can have bugs, please contact author to fix those).

Last one doesn't work as you cannot have two menu items with the same alias.

Workaround: Create menu item of type: Kunena Forum: Entry Page and point it to Kunena Menu >> Forum. It will work, but it doesn't highlight the menu.

Another way is to copy the whole Kunena Menu into your main menu and use it.
Last edit: 10 years 8 months ago by Matias.

Please Log in or Create an account to join the conversation.

More
10 years 8 months ago #10 by Matias
@ NoMAD:

Something is seriously wrong in your site. You seem to use SEF, but URL from the menu is wrong. Those URLs are generated by menu module and your SEF component. Either of them has a serious bug in it or SEF doesn't support Kunena 1.6. I suspect that it's your SEF component (you're not using Joomla SEF..?).

Upgrade SEF to the latest and if the issue persists, tell us what it is so we can fix it.

PS. only Admin will see that error message. Other users get silently redirected to the right URL.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.182 seconds