×
Kunena 6.0.6 & Kunena 5.2.13 & blue eagle5 1.6.8 released as security release (28 Nov 2022)

The Kunena team has announce the arrival of Kunena 6.0.6 [K 6.0.6] which is now available for download as a native Joomla extension for J! 4.2.x. This is a security release.

Solved Succecfully installed but NO kunena at components

More
4 months 5 days ago #1 by uzbaby
Hello!
I installed joomla 4.1. All worked fine. I installed Admin tools, also successfully. 
Then I installed Kunena. As you see it is in the extensions. But I don't see Kunena dashboard.
What is wrong? During installation I got "Package successfully installed" massage  and "Error 404"
And my Joomla dashboard become strange and as you see the words: undefined constant "Kunena\Forum\Libraries\Factory\KPATH_ADMIN"
You can see the images in the attachment.
 
Attachments:

Please Log in or Create an account to join the conversation.

More
4 months 5 days ago - 4 months 5 days ago #2 by uzbaby
I uninstalled Kunena. How can I install it without problems in my Joomla 4?
 
Last edit: 4 months 5 days ago by uzbaby.

Please Log in or Create an account to join the conversation.

More
4 months 5 days ago #3 by Leen
I don't know if your admin tools specially set it up and if that affected kuena.
And how you removed kunena again normally this has to be done via Kunena Forum: Tools
so if you have removed it via joomla management there may be something more happening in the database.
but normal if your hoster have  the right requirements could it just be installed as described here
www.kunena.org/docs/en/basics/installation/installation-k6-0

L.v.d.A

Please Log in or Create an account to join the conversation.

More
4 months 5 days ago - 4 months 5 days ago #4 by uzbaby
I reinstalled Kunena and now it shows this (screenshot in the attachment  )
 
Attachments:
Last edit: 4 months 5 days ago by uzbaby.

Please Log in or Create an account to join the conversation.

More
4 months 5 days ago #5 by uzbaby
I reinstalled it via Extensions manager and then due to error in my Joomla Dashboard ("Kunena\Forum\Libraries\Factory\KPATH_ADMIN") I deleted all files of kunena in my Core File Manager.

Please Log in or Create an account to join the conversation.

More
4 months 5 days ago #6 by Leen
it looks a bit like this error message
www.kunena.org/forum/installation-issues...-installation#223100
only his solution may not be entirely suitable for your site.
For example, if you have a backup from before you installed kunena I would put it back and try again.
And if you've just started everything do it all over again start with everything (including an empty database)

L.v.d.A

Please Log in or Create an account to join the conversation.

More
4 months 5 days ago #7 by uzbaby
I had active forum with big database. My site is not new. And I have backup only from the time when I had Joomla 3.10 before upgrading to Joomla 4.
So now my joomla works great. I installed several extensions already. But problem with kunena.

Please Log in or Create an account to join the conversation.

More
4 months 4 days ago #8 by rich
Which Kunena version contain the backup of Joomla 3.10? The upgrade works only from K5.1 or K5.2.
Create a test installation with your Joomla 3.10 backup and follow this guide: docs.kunena.org/en/basics/upgrade/upgrade-k6-0

Please Log in or Create an account to join the conversation.

More
4 months 4 days ago #9 by uzbaby
Thank you Rich!
I forgot to see which Kunena version was before upgrade.
I have backup of my Kunena forum. How can I see it version?

Please Log in or Create an account to join the conversation.

More
4 months 4 days ago #10 by Leen
Hello,
if you have an Akeeba backup of the old site maybe running it locally with xampp or wamp on your computer/laptop

L.v.d.A

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.104 seconds