Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

Solved Forum Permissions

More
8 years 10 months ago - 8 years 10 months ago #1 by applehc
Forum Permissions was created by applehc
Hi,

When copying tables joomla and kunena in the database to use 4.0, generate changes in permits?

Users are part of "registered users" and categories are configured for it. When accessing a topic, I receive the next message:

Access Denied

EDIT:

I went to Kunena category mánager to change the categories permissions and when I saved changes for testing I receive this error:

Error

Unknown column 'icon' in 'field list' SQL=UPDATE `ubj25_kunena_categories` SET `parent_id`='7',`name`='Presentate',`alias`='6-Presentate',`icon`='',`icon_id`='0',`locked`='0',`accesstype`='joomla.group',`access`='1',`pub_access`='2',`pub_recurse`='1',`admin_access`='2',`admin_recurse`='1',`ordering`='1',`published`='1',`channels`='THIS',`checked_out`='127',`checked_out_time`='2015-06-21 12:10:50',`review`='0',`allow_anonymous`='0',`post_anonymous`='0',`hits`='0',`description`='¿Eres nuevo usuario? Presentate aquí.',`headerdesc`='',`class_sfx`='',`allow_polls`='0',`topic_ordering`='lastpost',`iconset`='default',`numTopics`='42',`numPosts`='236',`last_topic_id`='8814',`last_post_id`='11392',`last_post_time`='1377859630',`params`='{\"access_post\":[\"1\",\"6\"],\"access_reply\":[\"1\",\"6\"],\"display\":{\"index\":{\"parent\":\"3\",\"children\":\"3\"}}}' WHERE `id`='6'



Thanks
Last edit: 8 years 10 months ago by applehc.

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #2 by 810
Replied by 810 on topic Forum Permissions
Go to the database and open *_kunena_version Remove all 4.0 entries. Then install kunena 4.0.1 again by the joomla installer.
The following user(s) said Thank You: applehc

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #3 by applehc
Replied by applehc on topic Forum Permissions
Hello,

I open *_kunena_version database and I delete the tables. Then I install kunena 4.0.1 by the joomla installer and created me the table.



Permissions problem on the issues continued.
Attachments:

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #4 by 810
Replied by 810 on topic Forum Permissions
you said you did a migrate before, I don't see any other versions?

Is this a new install? Or didn't you copy all the kunena tables?
The following user(s) said Thank You: applehc

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago - 8 years 10 months ago #5 by applehc
Replied by applehc on topic Forum Permissions

810 wrote: you said you did a migrate before, I don't see any other versions?

Is this a new install? Or didn't you copy all the kunena tables?


It has not been an automatic migration.

I installed Joomla 3.4.1 with Kunena 4.1

Then I copy the joomla users tables and kunena all tables of the old database.
Last edit: 8 years 10 months ago by applehc.

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #6 by 810
Replied by 810 on topic Forum Permissions
That's wrong.

First move the data then install k4.1.


so uninstall kunena, remove the kunena tables.

Then copy the all kunena table from the old database. Then install K4.0.1
The following user(s) said Thank You: applehc

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #7 by applehc
Replied by applehc on topic Forum Permissions

810 wrote: That's wrong.

First move the data then install k4.1.


so uninstall kunena, remove the kunena tables.

Then copy the all kunena table from the old database. Then install K4.0.1


Done. I copied all kunena tables of the old database and then I installed Kunena 4.1

And now? I see the default forum, all empty. I need to replace tables?

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #8 by 810
Replied by 810 on topic Forum Permissions
could you make a screenshot from the kunena tables
The following user(s) said Thank You: applehc

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago - 8 years 10 months ago #9 by applehc
Replied by applehc on topic Forum Permissions
Good morning 810,

These are the kunena tables of old database.



These are the kunena tables after add old database tables and then install Kunena 4.1.

It seems that the installation of Kunena 4.1 eating the old kunena database tables.

Attachments:
Last edit: 8 years 10 months ago by applehc.

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago #10 by 810
Replied by 810 on topic Forum Permissions
Ok, backup the old kunena table to be safe.

Then update kunena on the old website. Then copy the data to the new database

Please Log in or Create an account to join the conversation.

Time to create page: 0.534 seconds