×
Kunena 5.2.4 and Blue eagle 1.6.4 released (04 Apr 2021)

The Kunena team has announce the arrival of Kunena 5.2.4 [K 5.2.4] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.4

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with, this template isn't designed to works with Bootstrap 3 and Bootstrap 4.

× Posting guide:

For a quick response, please give us as much information that helps us to understand the problem.
Please read first What information should I include when I ask for help (including how to post my configuration report)?
This category is for:
  • Kunena 1.7 product-related issues only; and
  • when your Kunena forum does not work.
Do not use this category:
  • to request adding to or removing from the standard features of Kunena;
  • if your question is of a commonly asked "how to" nature;
  • if you are not using the latest stable release of Kunena; or
  • ▪ general Joomla or website adminstration matters
General hints: How To Ask Questions The Smart Way .
Please read the guides posted as sticky topics in this category.
Also refer to the FAQs menu tab above for frequently asked questions.

Note: Support for, and all questions relating to, K 1.7 will cease on 31 August 2012. Our advice is, if you are having problems with K 1.7, to upgrade to K 2.x as soon as practicable,

Important Not Receiving Email Notifications

More
8 years 11 months ago - 8 years 11 months ago #31 by freedomcoach

problems always seem to occur when people customise Kunena to suit their unique requirements and, when they don't work, we're left in a bit of a quandary as to how to help people get the best out of the product as they can.

You should not have to change anything (unless Matias is able to identify what, exactly, is the cause of this issue). Email subscriptions have been a continuing challenge for as long as I have been associated with the project.

There have been improvements made in this area (see What has changed in Kunena 2.0 ) but, K 2.0 is not ready for public stable release at this time and so that will be of little comfort to you.

I say, when all else fails, go back to basics (see, in fact, When all else fails, try this ). At the very least, don't make changes to your live website.

What is the best way to set things up? I really don't know. I just use standard Kunena and Joomla and I hardly change anything. So I'm probably not much use to you. Maybe some other people might have a few good ideas? :dry:

I have not done any customizations to Kunena or made any significant changes to it. I'm using it pretty much in a default manner.

The thread When all else fails, try this has no relevance to my situation that I can discern except possibly for a general disclaimer that you simply don't know the source of some problems.

I do not have permission to view your Kunena 2.0 link, so I don't have any idea what is coming down the pike that might have relevance to my situation.

I think it is best to wait for Matias to read the recent posts and offer his suggestions of what to try next.
Last edit: 8 years 11 months ago by sozzled. Reason: Fix broken link

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago - 8 years 11 months ago #32 by sozzled
You're right. I 've never - in the several hundred websites that I've built or helped others with - experienced the issues you're confronted with. "When all else fails ..." was not meant to sound like we've abandoned you. The recommendation, however, to trial the issues on another test site running on the same hosted platform as your live site, is a good one nonetheless. Only you can tell us whether a totally clean, unvarnished, unmodified, Joomle+Kunena website behaves normally/differently.

I fixed the issue that was preventing you from looking at the list of differences you'll discover with K 2.0. You should be able to view the link that I posted earlier.

I hope that your wait for Matias should not last more than a few days. :). Good luck.
Last edit: 8 years 11 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #33 by freedomcoach
Sozzled:

A big part of troubleshooting is eliminating possible culprits to the problem. Then you are free to look at other culprits. Right?

I have still not eliminated issues with the 2 config fields I mentioned earlier:: Forum E-mail Address and Visible Email Recipient. I set both of these to my email address, This email address is being protected from spambots. You need JavaScript enabled to view it.. I want to eliminate this as a possible cause of multiple notification emails.

It would help to learn how Kunena Admins and site owners typically set these fields. I'm also going to check in with my site hosting company, Bluehost, to see if they have any clues.

I will check the page on Kunena 2.0. What is your targeted time frame for the first release?

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #34 by freedomcoach
Sozzled:

Another thought occurred to me just now. Maybe this issue is very simple. Since When I am subscribed to a topic, posts are going to generate one email notification. My email address is also the Forum Email address and this is also going to generate another email notification. Am I right?

If yes, this could be the explanation for this whole thing. Now, since I want to maintain my regular subscriptions to topics, it would make sense to set the Forum Email address to something else and see if this eliminates one notification. Do you agree? Is my logic sound? I will try this and let you know what happens.

Sincerely,
Howard

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #35 by freedomcoach
I just made another (possibly significant) observation. When receiving two email notifications, they each have different header as follows:

A new reply has been posted on the Breakthrough Coaching Forum

A new post has been made to a category to which you have assigned as moderator on the Breakthrough Coaching Forum

This is giving us a clue as to what is generating the email notification. I checked and see that I am not a moderator on the forum but I am an Admin. If Admins are treated like global moderators, it makes sense that I would receive this message.

There must be a way to adjust things so I only get one of these messages. All help appreciated.

Sincerely,
Howard

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago - 8 years 11 months ago #36 by sozzled

A new post has been made to a category to which you have assigned as moderator on the Breakthrough Coaching Forum

:woohoo: This changes the whole dynamic of the situation! Thank you for that vital piece of information. Yes, the reason this has been puzzling to all of us is that we were still working under the presumption that what you wrote a couple of weeks ago ...

The only problem is that now I'm getting two emails for each posting ...

... was that these two emails were identical in all respects.

First: the answer to your supposition about site administrators being forum moderators. Yes, of course, site administrators are forum moderators by definition; it would make no sense if you can do everything else on your site but you had to make additional changes in order to edit, delete or moderate - split/merge/move - topics posted our your forum. As far as how email to forum moderators vs. site administrators is concerned, I addressed this matter in Administrators Emailed with New Posts Despite Configuration Settings .

In your case, Howard, your forum configuration settings are:

mailmod 1
mailadmin 0

This means that all forum moderators receive email of every new message posted on the forum (irrespective of whether they are subscribed to those topics/categories). The side effect, perhaps unfortunately, is that site administrators (who are, by definition, forum moderators) also receive the same emails.

In your case you receive two emails: one, because you are subscribed to certain topics/categories; and two, because you are a forum moderator. Does this now answer the question that you asked a couple of weeks ago? Have we now resolved this matter to your satisfaction? :dry:
Last edit: 8 years 11 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #37 by sozzled

Another thought occurred to me just now. Maybe this issue is very simple. Since When I am subscribed to a topic, posts are going to generate one email notification. My email address is also the Forum Email address and this is also going to generate another email notification. Am I right?

No, that's not right. The Forum Email address setting does not, itself, spontaneously generate email.

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago - 8 years 11 months ago #38 by sozzled

It would help to learn how Kunena Admins and site owners typically set these fields.

These are the settings used at this website:

Forum Configuration » General » Basic Settings » Forum E-mail Address = This email address is being protected from spambots. You need JavaScript enabled to view it.
Forum Configuration » Users » Subscriptions » Visible E-mail Recipient = <null>
Forum Configuration » Security » Security Settings » E-mail Moderators = No
Forum Configuration » Security » Security Settings » E-mail Administrators = No

These (except for the first one, obviously) are also the settings that I use on every website where I have installed Kunena.
Last edit: 8 years 11 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #39 by Matias
Sorry for delay, I was in JAB12 and overly busy on participating as many sessions and meeting as many people as possible.

There is a reason I asked if you have Visible Email Recipient setting turned on. This is because of you are not supposed to use your own email address on it. It's basically "catch all" email address, which means that every email that is sent from Kunena is also automatically sent to that email address. It is also the reason why you're getting 3 emails.

There are 2 use cases for this configuration option. First it allows you to see if subscriptions are working. The second reason is that many email clients and services (Hotmail for example) threat all emails which do not have primary receiver as a spam. So having email address in the field is kind of mandatory (if you use CC or BCC and are sending the same email to more than one person), but you really don't want to have your own email address in there.

Please Log in or Create an account to join the conversation.

More
8 years 10 months ago - 8 years 10 months ago #40 by freedomcoach
Hi Matias and Sozzled:

I changed the Visible Email Recipient to another address (This email address is being protected from spambots. You need JavaScript enabled to view it.) that I normally don't use and then did a test post in a topic I'm subscribed to. I received NO email notification on this post. My other admin settings are the same as Sozzled posted below.

Then in checking the above comcast address, I now see 2 email notifications of my test post. This now confirms my suspicion that the only address receiving email notifications is the one entered into the Visible Email Recipient field. This is clearly showing that email notifications are simply not working properly.

I hope this will shed light on what might be causing the email notification issues. If you have an interest in checking my site, I would be happy to send you super admin login.

I'm going to leave these settings this way for a while but since I won't be receiving notifications of users' posts without logging in, I would appreciate a response to this as soon as possible. Thanks!

Sincerely,
Howard
Last edit: 8 years 10 months ago by freedomcoach.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.156 seconds