×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Merged All users have Administrator privileges

More
6 years 8 months ago #91 by sunny33days
That is odd.. Are you positive they weren't assigned as Moderator to any of the forum categories by mistake? Perhaps in Joomla user level they're also all showing up as Registered status and not anything higher?

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #92 by wildplanet
They are all registered users, but not admins. Still confused as to why everyone is able to moderate and make things sticky. Theres even a DELETE and LOCK button that is visible to all users. This doesn't seem right...

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #93 by wildplanet
In fact, on THIS forum, i see that those buttons don't show. SO thats the way I want my forum to look...

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #94 by sozzled
I do not think this is a Kunena-related problem specifically. This seems to be more likely that all your users have been assigned administrator privileges. Registered users cannot moderate or make sticky forum topics; only moderators or site administrators can use these functions. It's my guess that you have somehow managed to make all your users adminstrator. There are a couple of ways you could have done that.

(1) You have set all new users to be site administrators when they register new accounts. This is controlled with the Joomla Global Congifursation settings.

(2) you have changed the Joomla ACL settings so that people have administrator privileges whe they use the Kunena component.

These questions have been asked before. You should read the topic [Merged topic] Every new user has Administrator rights for ideas about how to correct the mistakes you made in setting up your Joomla website.

I hope this helps you :)
The following user(s) said Thank You: wildplanet

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #95 by wildplanet
Thank you, i finally found it, because of your helpful post. It was number "2" in your post above. I had for some reason gone into the KUNENA - OPTIONS settings and made registered users have access to the administrative interface. I think i must have set that when I was first setting the site up, before I knew how everything worked. Thanks again. That one had me stumped for a solid week.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #96 by sozzled

Please Log in or Create an account to join the conversation.

More
6 years 7 months ago #97 by hagi
Why all the members are administrator? What i do wrong?

Please Log in or Create an account to join the conversation.

More
6 years 7 months ago #98 by sozzled
*** Topics merged ***

The answer to your question is in this topic.

Please Log in or Create an account to join the conversation.

More
6 years 7 months ago - 6 years 7 months ago #99 by mmcdermott1
For some reason EVERYONE can modify topics. Just upgraded to latest and didn't use to be this way. Been through every setting and don't see any reason why moderator privileges are given to everyone.

I have been through every user setting i can find and only 2 people are set to mods but EVERYONE can moderate topics in the forum. Major problem obviously

Help ASAP please
Last edit: 6 years 7 months ago by mmcdermott1.

Please Log in or Create an account to join the conversation.

More
6 years 7 months ago #100 by sozzled
Without seeing your config. report, I am talking a wild guess. It is my guess that you have made everyone an administrator of your website. See the topic: Every new user has Administrator rights .

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.141 seconds