×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Important New post email notification URL broken

More
4 years 11 months ago - 4 years 11 months ago #11 by sozzled

thomasmanca wrote: I have the same problem ... I use joomla 3.3.6. with Kunena 3.0.6
Email notifications of new posts the "&" is transformed into "& amp;" .. the link does not work ..

I have been doing some testing in this area.

Normally I use Joomla's standard SEO features whenever I build my websites. I understand that this may not suit everyone's tastes but, I'm just saying, it makes things easier for me.

I have a [J! 3.3.3] test site and, for the purposes of testing, I used the following settings:

Global Configuration » Site » SEO Settings » Search Engine Friendly URLs = No
Global Configuration » Site » SEO Settings » Use URL rewriting = No
Global Configuration » Site » SEO Settings » Adds Suffix to URL = No
Global Configuration » Site » SEO Settings » Unicode Aliases = No
Global Configuration » Site » SEO Settings » Include Site Name in Page Titles = No

In other words, pretty much a Joomla site with the original settings left unchanged.

I subscribed to a topic and posted a test message using a different account. The image below shows you the email that I received (I have edited the email to remove personal information about myself):



In the image above, I have used arrows to indicate the HTML "ampersand" characters generated by Kunena.

When I clicked this URL from my email program, the URL was correctly translated to

https://<site-name>/index.php?option=com_kunena&view=home&defaultmenu=160&Itemid=159

... and the page opened!

I then tried copying and pasting the URL into Mozilla Firefox, Google Chrome, Internet Explorer and Safari browsers and the URL worked in every case.

I am not saying that my test has been conclusive but I would like to make the following observations:

1) I do not think that the problem has anything to do with any particular version of Joomla that people may be using.

2) I do not think that the problem has anything to do with any particular template—site template or forum template—that people may be using.

3) I do not think that the problem has anything specifically to do with people choosing to not use Joomla SEO. The issue (obviously) seems only to occur when people disable Joomla's SEO but this should not be a reason to force people to employ Joomla's SEO if they do not want those features.

4) The problem may have something to do with "custom menus" that people are using. In all the cases reported in this topic, every configuration report shows that people are using some custom menus. It may be worthwhile trying to use the default Kunena menu items—at least to prove whether the Joomla menu is responsible. Information about how to use the default Kunena menu is given in Kunena Menu issues in the Wiki.
Attachments:
Last edit: 4 years 11 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #12 by mikm27
Thanks for all the testing etc sozzled.

I tried your recommendation and rebuilt the Kunena menu items following the directions in the Wiki but this had no effect - the url in the notifiication are still broken with the amp; concatenated onto &.

I did a search and found this post which may have relevant information - URL in Links converts & to &amp; making the URL invalid This post is about a completely different component but with the same problem. Here's the relevant info from the post. I'm not sure how to implement their solution in my joomla environment.

Encoding ampersands (once) is fine -- and even valid -- for links within an HTML page.

But, if you use CKEditor for building EMAIL MESSAGES, then you do NOT want ampersands to be encoded by the editor. In a common email client like Outlook, if a link contains &amp;, it breaks. This has nothing to do with double-encoding or n00bs.

My solution was to use:
CKEDITOR.config.forceSimpleAmpersand = true;on the page containing my email editor.

Alternately you could put:
config.forceSimpleAmpersand = true;in your main editor config.js file if you want this setting to apply to all of your editor instances.


Please let us know if this is helpful info.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #13 by sozzled
Unless you are using CKEditor on your website, I don't think this information helps.

I think the problem has a simpler solution.

The problem, as you described it it, seems to have something to do with the way that your Joomla router works. This could be caused by something unusual in your .htaccess file.

I would like you to do a test, please. Can you rename your existing .htaccess file to htaccess.old and then try again? Let us know if this changes the way that your website responds when you click the URL in the email and if it then goes to the correct page instead of the "login page".

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #14 by adroussel
Thanks for your help.
I just disabled the htaccess and the result is the same, unfortunately.

Now I just wonder if other people here avec the same issue, also upgrade from a j2.5 and if it has to do with the issue.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #15 by mikm27
I too tried disabling .htaccess but got the same result. For my site, the url in the notification email leads to a 404 page not found.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #16 by adroussel
In my case it is redirecting to
index.php?option=com_kunena&view=category&Itemid=646&layout=list
the 404 could be because of a missing Forum menu item you could add. But it won't help the url ampersand...
Did you upgrade from a j2.5 site ?

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #17 by mikm27
I upgraded from a j1.5 site. I think my Kunena menu items are fine - I just rebuilt them with the Kunena tool.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #18 by sozzled
Thank you for trying and I'm sorry to hear that [renaming your .htaccess file to something else] did not work.

As far as I know this problem seems to be unique to you. I have not been able to reproduce this issue on any of my test site.

As I wrote earlier in this topic,

Normally I use Joomla's standard SEO features whenever I build my websites. I understand that this may not suit everyone's tastes but, I'm just saying, it makes things easier for me.

... I do not think that the problem has anything specifically to do with people choosing to not use Joomla SEO. The issue (obviously) seems only to occur when people disable Joomla's SEO but this should not be a reason to force people to employ Joomla's SEO if they do not want those features.


So, while I am not sure what is specifically causing your problem, I would like to make a suggestion:

Read the article Search enging optimisation (SEO) in the Wiki. Use the "standard" Joomla ".htaccess" file (which is distributed as htaccess.txt in your root directory and make sure that you do not have any other .htaccess files in any other directories on your website. Then enable Joomla's SEO settings as described in the Wiki article.

If this does not work then I am really not sure what is causing the problem. It's possible, however, that there is something wrong or "broken" in your Kunena installation but that is just a wild guess.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #19 by adroussel
Well as far as we are 3 with the same issue in this topic, this is not 'unique', but thanks anyway for helping trying to solve this.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #20 by 810

adroussel wrote: In my case it is redirecting to
index.php?option=com_kunena&view=category&Itemid=646&layout=list
the 404 could be because of a missing Forum menu item you could add. But it won't help the url ampersand...
Did you upgrade from a j2.5 site ?


What do you have on the configuration.php file at "live site" must be :
public $live_site = '';

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.163 seconds