×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Important New post email notification URL broken

More
4 years 11 months ago - 4 years 11 months ago #1 by adroussel
Hello

I saw some other topic about it but closed with no reply.I have that problem after upgrading to Kunena 3.0.4 and Joomla from a 2.5 site.

My email notifications for new posts show url like this

domain.com/index.php?option=com_kunena&view=topic&catid=86&id=14459&mesid=26064&Itemid=108

and these are changed to
index.php?option=com_kunena&view=home&defaultmenu=109&Itemid=108

when clicked, making it impossible to reach the concerned topic.

Any help welcome :) Thanks.
Last edit: 4 years 11 months ago by adroussel.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #2 by 810
update kunena to 3.0.6 and joomla to 2.5.26

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago - 4 years 10 months ago #3 by sozzled
It looks to me that the problem is caused by something involving SEO. I do not think the problem is necessarily caused by using K 3.0.4. Although it is normally a good idea to use the current, supported version of Kunena (K 3.0.6) I have my doubts that upgrading to K 3.0.6 will fix this problem for you; I could be wrong and it may be worth a try.

I suspect that the problem is caused by the way that you have implemented SEO on your website. It may help to read How to implement Search Engine Optimisation - SEO - in Joomla

adroussel wrote: I saw some other topic about it but closed with no reply.

It might help to know more about this "other topic" that you saw.

adroussel wrote: I have that problem after upgrading to Kunena 3.0.4

It might help to know what version of Kunena you were using before you upgraded to K 3.0.4.
Last edit: 4 years 10 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago - 4 years 11 months ago #4 by adroussel
Hi, thank you for your replies.

Actually I updated to 3.0.6 with same issue, also note I'm running Joomla 3. I meant I upgraded from Joomla2.5.

I'm not using SEF on that site, it is disabled in Joomla config.

The other topic mentioning this issue was useless. Here it is:
www.kunena.org/forum/kunena-3-0-support-...il-link-doesn-t-work

I'll check that other SEO settings are disable too in Joomla. If you have a clue , let me know.
Last edit: 4 years 11 months ago by adroussel.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago - 4 years 11 months ago #5 by adroussel
Here is my configuration report.
Thanks again for your help, this issue is a real pain.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 512M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : yoo_eat | author: YOOtheme | version: 1.0.4 | creationdate: Unknown

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.3 | creationdate: 2011-01-31

Kunena version detailed: Kunena 3.0.6 | 2014-07-28 [ Tala ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 2.0.3

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 3.0.1

Last edit: 4 years 11 months ago by adroussel.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #6 by 810
your running old code,
Blue Eagle (default) | author: Kunena Team | version: 1.6.3 | creationdate: 2011-01-31


Try to uninstall kunena, then check administrator/components/com_kunena , components/com_kunena, libraries/kunena, plugins/kunena, plugins/system/kunena are removed.

Then install kunena again.

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #7 by adroussel
Hello

Thank you , I did as you suggested, but unfortunately it did'nt solve my issue.
Any aother suggestion welcome.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 512M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : yoo_eat | author: YOOtheme | version: 1.0.4 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.6 | creationdate: 2014-07-28

Kunena version detailed: Kunena 3.0.6 | 2014-07-28 [ Tala ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 2.0.3

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago #8 by adroussel

Ggy888 wrote: thank you so much


What for ?
Issue not solved yet.

Please help

Please Log in or Create an account to join the conversation.

More
4 years 11 months ago - 4 years 11 months ago #9 by thomasmanca
I have the same problem ... I use joomla 3.3.6. with Kunena 3.0.6
Email notifications of new posts the "&" is transformed into "& amp;" .. the link does not work ..

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 120 seconds | Max execution memory: 128M | Max file upload: 25M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : EsteticaSardegna2012 | author: | version: 1.0 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.6 | creationdate: 2014-07-28

Kunena version detailed: Kunena 3.0.6 | 2014-07-28 [ Tala ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: Search - Kunena Search 3.0.1

Modules: None

Last edit: 4 years 11 months ago by thomasmanca.

Please Log in or Create an account to join the conversation.

More
4 years 10 months ago - 4 years 10 months ago #10 by mikm27
I too have the same problem on my joomla 3.3.6 site running Kunena 3.0.6. We have SEF disabled and we don't use any SEO plugins. Here is what the url looks like in the notification email.

URL : www.outryders.org/index.php?option=com_k...d=953&Itemid=414

"amp;" is concatenated to the "&"s which breaks the url.


Any idea what could be causing this??? Thanks!

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 40M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : yoo_frequency | author: YOOtheme | version: 1.0.3 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.6 | creationdate: 2014-07-28

Kunena version detailed: Kunena 3.0.6 | 2014-07-28 [ Tala ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 1.9.1

Third-party SEF components: None

Plugins: Content - Kunena Discuss 3.0.1

Modules: Kunena Latest 3.0.1

Last edit: 4 years 10 months ago by mikm27.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.189 seconds