×
Blue Eagle (1.5.0) for K5.1 is released (20 Jul 2018)

Please update the Kunena Blue Eagle to 1.5.0 if you use Kunena 5.1.
We made several bug fixes and improvements. Also Blue Eagle has now all the features from Crypsis.
Download: www.kunena.org/download/templates/category/blue-eagle-5

× This section is for questions directly related to the procedure for installing Kunena for the first time or upgrading from an older version of Kunena.

Use this category:
  • to ask how to install or upgrade; or
  • if you encountered problems during the installation or upgrade procedure.

Use a different category to ask questions about problems that you may be having after you successfully installed or upgraded the currently supported version. If you are unsure what is the current supported version of Kunena, please go to the download page.

Question HELP!!! Error displaying on forum

More
1 year 8 months ago #1 by foluso
Hello everyone,

After installing and linking my kunena forum to a menu on Joomla, I tried visiting the Forum link form the front end, i notice the Forum displays properly but it also shows a weird error message below;

Exception in layout Widget/Announcement!Unknown column 'publish_up' in 'where clause' SQL=SELECT * FROM #__kunena_announcement WHERE (published = 1) AND (publish_up = '0000-00-00 00:00:00' OR publish_up <= '2016-12-16 12:59:32') AND (publish_down = '0000-00-00 00:00:00' OR publish_down >= '2016-12-16 12:59:32') ORDER BY id DESC LIMIT 1

Please how do i rectify this.
Thanks in advance for your kind suggestions.

Regards

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #2 by 810
looks your kunena sql tables aren't correct. if new forum, please uninstall kunena and tables, then try to install it again.

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #3 by foluso
Thank you for the kind suggestion...
I have re-installed the forum, the former error has gone but now i am facing new errors.
I have attached a screenshot of the error, the area i highlighted with yellow displays to user profile icons.
Also i get this error message

"Error Kunena Internal Error: Please contact the site administrator to fix this issue!"

I tried enabling the debug mode which now displays the error below.

Notice: Undefined variable: results in libraries/kunena/forum/announcement/helper.php on line 141
Warning: Invalid argument supplied for foreach() in libraries/kunena/forum/announcement/helper.php on line 141

Thanks in advance for your kind assistance.
Regards.
Attachments:

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #4 by rich

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago - 1 year 4 months ago #5 by Mathyas
Hi my debug message:
jos_kunena_topics' is marked as crashed and should be repaired SQL=SHOW FULL COLUMNS FROM `jos_kunena_topics` in /home/passatkl/passatklub.hu/html/components/com_kunena/template/crypsis/layouts/category/index/default.php on line 192
Layout was rendered in /home/passatkl/passatklub.hu/html/components/com_kunena/template/crypsis/pages/category/list/default.php on line 20

The Forum worked yesterday, and the site has not changed anything.

A long time ago, in a galaxy far far away,
An old wise computer once said...
00010110010001010001010
Last edit: 1 year 4 months ago by Mathyas.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.085 seconds