Kunena 6.3.3 released

The Kunena team has announce the arrival of Kunena 6.3.3 [K 6.3.3] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3
Note: Please go to the Kunena Dashboard after an upgrade so that the Kunena database tables are also updated.

Solved Kunena export php tables to fix 404 error

More
9 months 1 week ago - 9 months 1 week ago #1 by timpennington
Greetings:

After upgrading to J4, I am getting a "404: View not found [name, type, prefix]: topic, html, site" error whenever I try to edit, reply, etc to a message. I have not been able to find a suitable solution, and one advice I was give was to delete and reinstall Kunena 6.1.4; but I do want to save the posts etc that have already been added to my forum.

Q: is there a way to export those posts, messages, and data from my php tables before deleting everything, then reinstalling 6.1.4, and adding the php tables back so it all fits together?

I am not a coder by profession; I have a business I run off my website, so I am learning this as I go, but this 404 error had perplexed me a bit.

Thank you for any advice.

This message contains confidential information

Database collation check: x4lpd_kunena_attachments have wrong collation of type utf8_general_ci on field filename  x4lpd_kunena_attachments have wrong collation of type utf8_general_ci on field filename_real  x4lpd_kunena_attachments have wrong collation of type utf8_general_ci on field caption  x4lpd_kunena_categories have wrong collation of type utf8_general_ci on field name  x4lpd_kunena_categories have wrong collation of type utf8_general_ci on field alias  x4lpd_kunena_categories have wrong collation of type utf8_general_ci on field accesstype  x4lpd_kunena_categories have wrong collation of type utf8_general_ci on field channels  x4lpd_kunena_categories have wrong collation of type utf8_general_ci on field description  x4lpd_kunena_categories have wrong collation of type utf8_general_ci on field headerdesc  x4lpd_kunena_categories have wrong collation of type utf8_general_ci on field topictemplate  x4lpd_kunena_categories have wrong collation of type utf8_general_ci on field class_sfx  x4lpd_kunena_categories have wrong collation of type utf8_general_ci on field iconset  x4lpd_kunena_categories have wrong collation of type utf8_general_ci on field params  x4lpd_kunena_configuration have wrong collation of type utf8_general_ci on field params  x4lpd_kunena_logs have wrong collation of type utf8_general_ci on field ip  x4lpd_kunena_logs have wrong collation of type utf8_general_ci on field operation  x4lpd_kunena_messages have wrong collation of type utf8_general_ci on field name  x4lpd_kunena_messages have wrong collation of type utf8_general_ci on field email  x4lpd_kunena_messages have wrong collation of type utf8_general_ci on field subject  x4lpd_kunena_messages have wrong collation of type utf8_general_ci on field ip  x4lpd_kunena_messages have wrong collation of type utf8_general_ci on field modified_reason  x4lpd_kunena_messages_text have wrong collation of type utf8_general_ci on field message  x4lpd_kunena_polls have wrong collation of type utf8_general_ci on field title  x4lpd_kunena_polls_options have wrong collation of type utf8_general_ci on field text  x4lpd_kunena_sessions have wrong collation of type utf8_general_ci on field allowed  x4lpd_kunena_sessions have wrong collation of type utf8_general_ci on field readtopics  x4lpd_kunena_smileys have wrong collation of type utf8_general_ci on field code  x4lpd_kunena_smileys have wrong collation of type utf8_general_ci on field location  x4lpd_kunena_smileys have wrong collation of type utf8_general_ci on field greylocation  x4lpd_kunena_topics have wrong collation of type utf8_general_ci on field subject  x4lpd_kunena_topics have wrong collation of type utf8_general_ci on field first_post_message  x4lpd_kunena_topics have wrong collation of type utf8_general_ci on field first_post_guest_name  x4lpd_kunena_topics have wrong collation of type utf8_general_ci on field last_post_message  x4lpd_kunena_topics have wrong collation of type utf8_general_ci on field last_post_guest_name  x4lpd_kunena_topics have wrong collation of type utf8_general_ci on field params  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field status_text  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field view  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field signature  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field avatar  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field personalText  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field location  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field friendfeed  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field bebo  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field digg  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field icq  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field telegram  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field vk  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field microsoft  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field skype  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field twitter  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field facebook  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field google  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field myspace  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field linkedin  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field linkedin_company  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field delicious  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field instagram  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field qqsocial  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field blogspot  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field flickr  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field apple  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field qzone  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field weibo  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field wechat  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field yim  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field whatsapp  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field youtube  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field ok  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field websitename  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field websiteurl  x4lpd_kunena_users have wrong collation of type utf8_general_ci on field ip  x4lpd_kunena_users_banned have wrong collation of type utf8_general_ci on field ip  x4lpd_kunena_users_banned have wrong collation of type utf8_general_ci on field reason_private  x4lpd_kunena_users_banned have wrong collation of type utf8_general_ci on field reason_public  x4lpd_kunena_users_banned have wrong collation of type utf8_general_ci on field comments  x4lpd_kunena_users_banned have wrong collation of type utf8_general_ci on field params  x4lpd_kunena_version have wrong collation of type utf8_general_ci on field version  x4lpd_kunena_version have wrong collation of type utf8_general_ci on field build  x4lpd_kunena_version have wrong collation of type utf8_general_ci on field versionname  x4lpd_kunena_version have wrong collation of type utf8_general_ci on field state  
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |
        

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 256M | Max file upload:  

Kunena menu details:

Warning: Spoiler!

Joomla default template details : ja_focus | author: JoomlArt.com | version: 2.0.2 | creationdate: Jun 16th, 2023

Kunena default template details : NTS Kay | author: Nice Theme Store Team | version: 6.1.5 | creationdate: 2023-07-09

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.1.4 | 2023-10-05 [ Git Repository ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 9 months 1 week ago by timpennington.

Please Log in or Create an account to join the conversation.

More
9 months 1 week ago #2 by Leen
you can check whether you are using the correct .htaccess sometimes when upgrading a joomla version it keeps the old one
it is about 3399 bytes in size. (rename it to old )
And names the new htaccess.txt(about 6855 byte)  .htaccess.
And then also put it in Joomla administator > Global Configuration under SEO
the Search Engine Friendly URLs = Yes
Use URL Rewriting = Yes
And also try to clear joomla cache using the button in Home Dashboard

L.v.d.A
Attachments:

Please Log in or Create an account to join the conversation.

More
9 months 6 days ago #3 by rich
The posts are stored in the database. Before you delete anything, see if it helps if you just install Kunena over it again.
If that doesn't help, export all Kunena tables from the database for backup.
Also copy the avatars and attachments folders. The path is media/kunena/
Then uninstall Kunena via the Joomla installer and install Kunena again.
Even if this does not help, remove Kunena completely via Kunena -> Tools -> Uninstall Kunena. This option removes Kunena together with its database tables.
It would be ideal, if you have the Kunena tables from version 5.2. Then you could import them and do the migration again.
Otherwise, reinstall Kunena.
After the installation, remove the Kunena tables from the database and then import the previously saved Kunena tables and check your forum.
Finally, copy back the contents of the two folders "avatars" and "attachments".

Please Log in or Create an account to join the conversation.

More
9 months 6 days ago #4 by timpennington
Thank you!

That is very helpful to both of your suggestions.

I can't thank you enough!

Please Log in or Create an account to join the conversation.

More
9 months 6 days ago #5 by timpennington

Please Log in or Create an account to join the conversation.

More
9 months 3 days ago - 9 months 3 days ago #6 by timpennington
I did as you instructed (exported Kunena tables; uninstalled; installed new; removed new data tables; imported the downloaded tables back in).

My site is down completely with a 1146 Error page with the message: " 'mydatabase.x4lpd_kunena_configuration' doesn't exist"

I can access the back end, but can't do anything because the error message  " 'mydatabase.x4lpd_kunena_configuration' doesn't exist" is showing.

Any guidance?


Addendum: realizing my mistake of working on a "live" site, I kicked myself in the rear and moved the "down" site to a folder and uploaded a backup I had previously made just before my adventure, so my site is back live; I moved the site in which I was working on into a folder at  finishingandcoating.com/Kunena2/ where the error still appears and I can work on that site to try to fix the issue. 1) how do I fix the " 'mydatabase.x4lpd_kunena_configuration' doesn't exist"; and 2) hopefully see if the new install will work. NOTE: none of the tables I uploaded took, so there are no Kunena tables in the php.

Again, thank you for all your guidance.
 
Last edit: 9 months 3 days ago by timpennington.

Please Log in or Create an account to join the conversation.

More
9 months 3 days ago - 9 months 3 days ago #7 by Leen
Hello

I have a question: the test site /Kunena2/ uses a different database, I hope?
And are there no xxxxx_kunena tables in that database?
if  the working website database does label the xxxxx_kunena
and the xxxxx_ prefix is the same as the kunena2 test site
then export the kunena tables and import it into the kunena2 test site.
or if you still have the Kunena tables from version 5.2 and that prefix is the same as that of test kunena 2 then uses it to import
(actually this is the same as what Rich described earlier, I think you deleted just a little too much)

L.v.d.A
Last edit: 9 months 3 days ago by Leen.

Please Log in or Create an account to join the conversation.

More
9 months 3 days ago #8 by timpennington
Thank you for taking a look at this.

I am not sure whether I deleted "too much" bit here is a screenshot of the tables I found when I searched "Kunena" in the tables; I exported them, then deleted them and then reinstalled them when I installed the new Kunena version. 

 

Please Log in or Create an account to join the conversation.

More
9 months 2 days ago #9 by Gindi
In my opinion, table type and collation do not match.
In the tables where the type is wrong, the collation is right and in the tables where the type is right, the collation is wrong.
All tables should be of type InnoDB and collation should be utf8mb4_unicode_ci.

Gindi
 

Please Log in or Create an account to join the conversation.

More
9 months 2 days ago #10 by timpennington
Can you assist me on how to fix this?

Thank you

Please Log in or Create an account to join the conversation.

Time to create page: 0.662 seconds