Kunena 6.2.4 Released

The Kunena team has announce the arrival of Kunena 6.2.4 [K 6.2.4] which is now available for download as a native Joomla extension for J! 4.3.x/4.4.x/5.0.x. This version addresses most of the issues that were discovered in K 6.1 / K 6.2 and issues discovered during the last development stages of K 6.2

Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Forum slow when logged-in

More
2 months 5 days ago #1 by nickza
Hi all. I have searched far and wide, but I could only see performance speed related issues on Kunena from 3+ years ago.

Background. Very old site, running since Joomla 2, recently upgraded from 3 to 4 to have Joomla 5 now with the latest version of Kunena. A glaring issue is that the site is blazing fast when you are accessing it not logged in, but once you login, it slows down every forum page, or page with a forum module (latest topics/posts), by 6 seconds. The difference is nuts, and driving me bonkers.

1. I have tested on another server. Same issue
2. I have tested with another template
3. I have tested other pages (when logged in) and they are fast, besides Kunena related ones
4. I have tested the forum when not logged in, and its fast (less than a second page load)
5. Have run diagnostics - besides 2 Orphaned attachments No issues found!

This message contains confidential information

Database collation check: The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |
        

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 90 seconds | Max execution memory: 5120M | Max file upload:  

Kunena menu details:

Warning: Spoiler!

Joomla default template details : abc-template | author: TSC Media | version: 3 | creationdate: 04/12/2023

Kunena default template details : Aurelia | author: Kunena Team | version: 6.2.2 | creationdate: 2023-12-09

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.2.2 | 2023-12-09 [ Git Repository ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 6.0.5


 

Please Log in or Create an account to join the conversation.

More
2 months 5 days ago - 2 months 5 days ago #2 by nickza
Replied by nickza on topic Forum slow when logged-in
update.
I have turned on cache 1 minute in the Kunena config, and it appears to make a difference, however, I am sceptical about this setting on a forum.
I have asked a few users to test and give me feedback, but any other solution (where I dont have to turn on cache) would be great.

Update: I take that back. not much difference. I was testing logged out by mistake. It seems to be the same.
Last edit: 2 months 5 days ago by nickza.

Please Log in or Create an account to join the conversation.

More
2 months 5 days ago #3 by nickza
Replied by nickza on topic Forum slow when logged-in
I disabled "Show New posts", and its crazy fast....
Still. Pity I have to disable a feature though. Any thoughts still?
I disabled cache too.

Please Log in or Create an account to join the conversation.

More
2 months 5 days ago #4 by rich
Replied by rich on topic Forum slow when logged-in
Maybe it help if you synchronise the users in the backend -> Kunena -> Tools and have the statistics counted.

Please Log in or Create an account to join the conversation.

More
2 months 5 days ago #5 by nickza
Replied by nickza on topic Forum slow when logged-in

Maybe it help if you synchronise the users in the backend -> Kunena -> Tools and have the statistics counted.
Thank you so much for the suggestion, and it was a good one. 
We synchronised the users (much needed).and then turn it back on. Added 5 seconds to page loading time.

Please Log in or Create an account to join the conversation.

More
2 months 4 days ago #6 by nickza
As the subject says...

More details here - I should have posted this here. Please move/merge.

www.kunena.org/forum/general-questions-a...-slow-when-logged-in

Please help

Please Log in or Create an account to join the conversation.

More
2 months 4 days ago #7 by rich
Replied by rich on topic Forum slow when logged-in
Could it be that additional content is loaded for registered users that is not accessible to guests?

Please Log in or Create an account to join the conversation.

More
2 months 4 days ago #8 by nickza
Replied by nickza on topic Forum slow when logged-in

Could it be that additional content is loaded for registered users that is not accessible to guests?
That is most certainly the case. When the feature Show New posts is enabled, it slows down because its loading the users info vs what he last viewed.
So thats why I loaded Redis on the server to handle the sessions, thinking it would be better. But it isnt.

Please Log in or Create an account to join the conversation.

More
2 months 4 days ago #9 by rich
Replied by rich on topic Forum slow when logged-in
Can you please set up an account for me? A normal registered user would be sufficient. You can use the "Private message" tab in the editor for the login details.

Please Log in or Create an account to join the conversation.

More
2 months 4 days ago #10 by nickza
Replied by nickza on topic Forum slow when logged-in
This message contains secure information

Please Log in or Create an account to join the conversation.

Time to create page: 0.406 seconds