Kunena 6.3.3 released

The Kunena team has announce the arrival of Kunena 6.3.3 [K 6.3.3] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3
Note: Please go to the Kunena Dashboard after an upgrade so that the Kunena database tables are also updated.

Please Read This First:


Please read the guides posted as sticky topics in this category. For a quicker response, please give as much information to help us understand the problem (see How To Ask Questions The Smart Way and What information should I include when I ask for help (including how to post my configuration report)? ).

This category is only for reporting defects with K 2.0 Please read, before you post, Before you post your question, read this first .

Do not use this category:
  • if this website ( www.kunena.org ) works but works differently to how you expected
  • for requests to add or remove the standard features of Kunena;
  • for questions commonly asked or "how to" in nature (see the FAQs menu tab above);
  • for help with Kunena versions that are not the latest stable release; or
  • for general Joomla or website administration matters

You must include your K 2.0 configuration report; if you do not include your configuration report, your topic may be closed (locked) or deleted without any further warnings from the moderators.

K 2.0 support will cease on 31 August 2013 and this section of the forum will be closed and archived after that time and no further questions will be answered about this version.

Merged Fatal Error: Cannot pass parameter 2 by reference in components/com_kunena/lib/kunena.file.class.1.6.php on line 60

More
12 years 2 weeks ago - 12 years 2 weeks ago #21 by HelTrooper
I have the same trouble and when i check the file it has already that line in it. See attached report

Thanks for fixing it guys :D

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 48M | Max file upload: 32M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : bad_lernvid.com | author: Juergen Koller | version: 1.0 | creationdate: Mar 2012

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.0 | creationdate: 2012-06-27

Kunena version detailled: Kunena 2.0.0 | 2012-06-27 [ Diplomatia ]
| Kunena detailled configuration:

Warning: Spoiler!
| Joomla! detailled language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 12 years 2 weeks ago by sozzled. Reason: Reveal Kunena configuration report in message

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago - 12 years 2 weeks ago #22 by Alemantico
Dear People,

Just today I downloaded and installed the new Kunena release (com_kunena_v2.0.0_2012-06-27.zip) on my joomla 2.6 version. Everything is working quiet smooth, excepted two things. And the first issue bothers me most, 'cause its the only one which prevents me from launching my site!
1st. issue: by trying out the new forum on my localhost, I submitted a new topic and added a picture, not bigger than 60kb. But it gaves me that error message:
"Fatal Error was detected!
Fatal Error: Cannot pass parameter 2 by reference in components/com_kunena/lib/kunena.file.class.1.6.php on line 60
The error was detected in the Kunena Component.
For support click here: Kunena Support"

But it works fine, as soon as I don't add any attachment to the new topic.

I already took a look on the Kunena Forum control panel to see if I could find any settings, but I didn't! Please, could someone tell me, where I have to change the parameter in order to make it work?

[strike]My 2nd issue I have (but that's not so urgent); Bevor I uploaded and installed the Kenanu extension, I changed the default language of my joomla site to german. Afterwards, when I uploaded, installed and run Kenanu, the language of the forum appears still in english. What I did wrong with that?[/strike]

Thank you for your help :P !
Last edit: 12 years 2 weeks ago by sozzled. Reason: One subject per topic. Second question removed.

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago #23 by sozzled

creonx wrote: where did i find the report?

Please see the FAQs menu tab on the Kunena nenu at the top of this page.

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago #24 by sozzled
G'day, HelTrooper, and welcome to Kunena.

HelTrooper wrote: I have the same trouble and when i check the file it has already that line in it.

:S What do you mean? Which file already has what line in it? What are we talking about?

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago - 12 years 2 weeks ago #25 by sozzled
Do you have any more details about the "fatal error"? See HTTP Error 500 Internal server error which may help you diagnose the cause.
Last edit: 12 years 2 weeks ago by sozzled.

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago - 12 years 2 weeks ago #26 by sozzled
*** Topics merged ***

G'day, Alemantico, and welcome to Kunena.

Alemantico wrote: Fatal Error: Cannot pass parameter 2 by reference in components/com_kunena/lib/kunena.file.class.1.6.php on line 60

Answered in this topic.
Last edit: 12 years 2 weeks ago by sozzled.

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago #27 by HelTrooper
I was talking about this fix. Its already there so it doesnt fix it for me

810 wrote: Fix:

components/com_kunena/lib/kunena.file.class.1.6.php line 118

change to

Code:
static function write($file, $buffer, $use_streams = false)

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago #28 by sozzled
Replied by sozzled on topic Solucion...!
This should be fixed properly in K 2.0.1 which will be released in a few days.
The following user(s) said Thank You: HelTrooper

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago - 12 years 2 weeks ago #29 by MarioMari
OK. I'm sorry, I have not forgotten that I did not give accesses to my site admin.

I turned on debug mode



and now I know that my topic should be moved to this thread:

www.kunena.org/forum/K-2-0-Support/12348...s-1-6-php-on-line-60

Joomla 2.5.8, and 3.0 K.2.0.3, default Chrome
Attachments:
Last edit: 12 years 2 weeks ago by MarioMari.

Please Log in or Create an account to join the conversation.

More
12 years 2 weeks ago #30 by sozzled
If you enabled Kunena "debug mode" (as instructed in the link I gave in my last reply) you may see more information. If you can give us any extra information then it may help us to understand what caused the HTTP 500 Internal Server Error.

Please Log in or Create an account to join the conversation.

Time to create page: 0.566 seconds