×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Visitors can see forum and topics but cannot read contents of the topics.

More
9 years 5 months ago #1 by ZarDAn
Guests are able to see the forum and the names of the topics, but they cannot browse the contents of the topics with out getting a screen informing them that it is a private area and that they need to log in to go further. They are able to create an account, but it is not my intent to force them to sign up to view. Initially I did have it locked down so that only people who already had accounts could see any thing so I'm concerned that I may have missed something. My intent is to allow Guests to browse, but not comment and only allow registered users to post. There are no problems when a user is logged in.

I started with version 1.6.1, but just upgraded to 1.6.3. That did not make it better, or worse.

My Kunena Security Settings are …

Allow Guests to post/write NO
Registered Users Only NO

I checked www.kunena.org/forum/133-k-15-common-que...he-forums-help#40872 , www.kunena.org/forum/139-k-15-support-ar...-as-qeveryoneq#40794 and docs.kunena.org/index.php/How_to_create_...Forums_and_Subforums .

The link to the forum is available to everyone, the sections and categories involved are the default ones, and I even tried turning off the Search Enging Friendly URLs and nothing helps. I read that Kunena doesnot always work well with K2. I did have it installed on this site last Summer, but I have long since uninstalled it. Well before installing Kunena. In other words, I never had them both installed at the same time. I had noted that K2 left some tables in my database. They did not seem likely to cause any problems, other than wasting space, but since it did not seem like it would do any harm, after making a fresh backup, I just now removed them. It did not help.

I do have other 3rd party add-ons, but I did not note any of them in my search results causing problems with Kunena.


This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 32M | Max file upload: 8M

This message contains confidential information

Joomla default template details : hornytoadtemplate08 | author: | version: 1.0 | creationdate: 2010-08-09

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.3 | creationdate: 2011-01-31

Kunena version detailled: Installed version: 1.6.3 | Build: 4344 | Version name: Parlare | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Disabled or not installed | Jomsocial: Disabled or not installed | UddeIm: Disabled or not installed

Third-party SEF components: sh404sef: Disabled or not installed | ARTIO JoomSEF: Disabled or not installed | AceSEF: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Disabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Disabled or not installed | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #2 by ZarDAn
I read more about the Joomla SEO settings and turned "Search Engine Friendly URLs" back on and renamed the "httpaccess.txt" to ".httpaccess" as recommended and turned on "USE Apache mod_rewrite". Now I get 404 errors, but only for the Kunena topics. It does this rather on not I'm logged in. I experimented with turning off "Search Engine Friendly URLs" and "USE Apache mod_rewrite". Only turning off "Search Engine Friendly URLs" made the 404 errors go away. That seemed odd, because I thought that before I had started changing it that my instance of Kunena had been working this "Search Engine Friendly URLs".

Confused...:(

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago - 9 years 5 months ago #3 by sozzled

ZarDAn wrote: I read more about the Joomla SEO settings and turned "Search Engine Friendly URLs" back on and renamed the "httpaccess.txt" to ".httpaccess" as recommended

No. What was recommended is to rename the file htaccess.txt to .htaccess

Your K 1.6 configuration report shows that you do not have a file called .htaccess

There several possible combinations of the Joomla the SEO options. In the Wiki, I've tried to keep things simple and I've only shown one way ; this is the way that things work for me.

I think the reason that you have this message "you need to login" is because you have two menu items pointing to Kunena. It might be worth looking at Non-Registered Users Cannot See Forum . I could be wrong.
Last edit: 9 years 5 months ago by sozzled.
The following user(s) said Thank You: ZarDAn

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #4 by ZarDAn
Yeah, I typed it wrong in the post. I did it after the report. It is correct on the site, but I did not give you a updated configuration settings report.

As far as the menus are concerned, I only had the one menu link and I don't recall explicitly creating any, but I installed it last year.:whistle: I just had the one that it came with. I just now tried out the "Create Menu" option from the "Kunena Control Panel" and that seems to have replaces my old link. Using this new link everything works properly. I was even able to set up the SEO options per your recommendations.

Thank you.

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #5 by ZarDAn
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 32M | Max file upload: 8M

This message contains confidential information

Joomla default template details : hornytoadtemplate08 | author: | version: 1.0 | creationdate: 2010-08-09

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.3 | creationdate: 2011-01-31

Kunena version detailled: Installed version: 1.6.3 | Build: 4344 | Version name: Parlare | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Disabled or not installed | Jomsocial: Disabled or not installed | UddeIm: Disabled or not installed

Third-party SEF components: sh404sef: Disabled or not installed | ARTIO JoomSEF: Disabled or not installed | AceSEF: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Disabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Disabled or not installed | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.132 seconds