×
Kunena 5.1.5 Released - Security Release (14 Oct 2018)

The Kunena team has announce the arrival of Kunena 5.1.5 [K 5.1.5] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Solved Registered Member/User Online Status

More
4 years 5 months ago - 4 years 5 months ago #1 by bada
Hello,

I'm new to Kunena but have been using Joomla for about ten years. Normally I would install phpbb but wanted something a little easier to intergrade. The issue that I'm having is with the Kunena's member login status.

When I log in with my admin account it shows me down at the bottom, "who is online" just fine. Red with my admin name.

Then I log out and log back in with my normal registered member account and it doesn't show me as a logged in member. Without logging out, if I go to Joomla acp and clear "com_kunena.template" cache. Then hit refresh I pop up in blue which is what it should be. I looked into the cache option in both Joomla and Kunena, all seems okay.

Any help with this would be greatly appreciated.

Joomla 3.3.0
Kunena 3.0.5

Doesn't matter if I try to login with the registered member account first it doesn't show up. I even tried from another computer thinking it was maybe saving a cookie from the admin account. Does the same thing.


This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : sj_tech | author: YouTech Company | version: 1.0.2 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.5 | creationdate: 2014-03-09

Kunena version detailed: Kunena 3.0.5 | 2014-03-09 [ Invecchiato ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: UddeIM 3.4

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 4 years 5 months ago by bada.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
4 years 5 months ago #2 by sozzled
Replied by sozzled on topic Registered Member/User Online Status
Am I correct in you saying that you use ACP?

I realise that you are using J! 3.3.0 - I haven't had time to fully explore this new version (and it's possible that J! 3.3.0 performs caching differently to J! 2.5 or earlier versions in the J! 3.x series) but ACP may be a relevant factor. I am not sure that this matter can be classified as a defect of Kunena - only time and other reports that confirm your situation will tell - but I will leave this topic in the "defect" category for the present.

I would like to see other people contribute to this topic to share their experience.

Although this website ( www.kunena.org ) does not use J! 3.3.0, are you able to reproduce here the same conditions that you experience on your own site?

If I remember correctly, Joomla login state is held as a record in the table _session.

Has there been any discussion on the Joomla forum about problems with J! 3.3.0 and login state?

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #3 by bada
Am I correct in you saying that you use ACP?

Yes, Joomla Admin Control Panel - This has nothing to do with the issue, it's just what I found would work to display registered users in the Who is Online section.

Just to clarify, I login under a normal registered user name. Both Joomla and Kunena recognize me as logged in member and all function work as they should.

The problem is down at the Who is Online section. It does not display me as a logged in user.

Thanks for your help in this matter.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
4 years 5 months ago - 4 years 5 months ago #4 by sozzled
Replied by sozzled on topic Registered Member/User Online Status

bada wrote: Am I correct in you saying that you use ACP?

Thank you for the clarification. I am not familiar with the term ACP = Joomla Admin Control Panel. I was confusing it with APC = Advanced PHP Cache.

I should have asked you, are you using APC.

Joomla maintains details about who is online in the _sessions table. This table is periodically cleared according to the Joomla session length setting.

We have discussed your problem before in this forum; see User offline but he's online

Kunena uses the informaiton in the "Who's Online" area from the Joomla table. If the information is wrong in Kunena it is because the information is "wrong" in the Joomla table. Kunena is not the culprit here; the cause of your problem lies in Joomla on your website.

I recommend that you read Login / Logout problem . I hope this helps.
Last edit: 4 years 5 months ago by sozzled.

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
4 years 5 months ago #5 by sozzled
Replied by sozzled on topic Registered Member/User Online Status
No-one else has contributed to this topic. The reported "defect" is unconfirmed.

*** Topic moved to Miscellaneous, off-topic and general Joomla category ***

Please Log in or Create an account to join the conversation.

  • sozzled
  • Visitor
4 years 4 months ago #6 by sozzled
Replied by sozzled on topic Registered Member/User Online Status
*** Topic closed - assumed esolved satisfactorily - as a result of lack of community interest in the subject ***

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.098 seconds