×
Kunena 5.1.3 Released (19 Aug 2018)

The Kunena team has announce the arrival of Kunena 5.1.3 [K 5.1.3] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a maintenance release.

× This is not a support forum for sh404SEF or its related products. For sh404SEF support you should visit sh404SEF .

The information given in this category is intended to guide users who want to use sh404SEF with Kunena and, mostly, was written by Kunena users. The information here is not necessarily accurate, up-to-date nor is it intended to replace the support given by the developers of sh404SEF.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Important Pagination not working

More
4 years 1 month ago #11 by 810

Please Log in or Create an account to join the conversation.

More
4 years 1 month ago #12 by Matias
Replied by Matias on topic Pagination not working
Kunena remembers the page on the menu items, which means that if you get back to the recent list (for example) it will not get into the first page, but the page you visited the last time. This allows users to navigate more quickly in Kunena as if you were on page 3, that's probably the page you want to get back.

But in order to do that we have had to add limitstart=0 to the pagination, which is usually not in there. Looks like sh404SEF is finding it redundant and removing it as something that's not needed.

You may want to talk about this with sh404SEF developer and explain what is happening. It also looks that I need to find another way to do this, but it's not going to happen for Kunena 3.0 for sure as it breaks backwards compatibility.

Please Log in or Create an account to join the conversation.

More
4 years 1 month ago #13 by 810
Replied by 810 on topic Pagination not working
Ok, found the problem.

There is a bug in sh404sef:
Fatal error: Access to undeclared static property: KunenaRoute::$current in \administrator\components\com_sh404sef\classes\router.php on line 253

So comment out the line. then its working again.

Regards 810

Please Log in or Create an account to join the conversation.

More
4 years 1 month ago - 4 years 1 month ago #14 by slomuscio
Replied by slomuscio on topic Pagination not working
After several hour of testing I've found a simple solution for this problem:
1. deactivate joomla sef
2. activate sh404sef and set the default for kunena component in the sh404sef / configuration / sh404sef configuration / components ->> set kunena as Normal , overright sef (as other components configuration)
3. create a new url in sh404sef url menu as follows:

sef_url: first-forum-page.html

non Sef url: index.php?option=com_kunena&view=category&catid=2&Itemid=104&limitstart=0

Save the configuration, clear all urls and your browser cache. Now the pagination problem to the first page is solved by means of a new link to first-forum-page.html

Sebastiano
Last edit: 4 years 1 month ago by slomuscio.

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #15 by orussier
Replied by orussier on topic Pagination not working
Hello,

i've the same problem : KUNENA pagination is not working because the limitstart=0 is not present into the url.
And then, it's always the last page that is selected and I would to start with the first page.

Do you have resolved this issue ?

It seems that the "?limistart=0" is missing inside url. How to add it on the different Kuena links ?

I use Joomla 3.7.2 and Kunena 5.0.10-DEV. I've desactivad SEA on Joomla and Kunena. I don't use SH404SEF.

In advance, thanks a lot
Olivier

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.082 seconds