×
Kunena 5.1.5 Released - Security Release (14 Oct 2018)

The Kunena team has announce the arrival of Kunena 5.1.5 [K 5.1.5] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This is not a support forum for sh404SEF or its related products. For sh404SEF support you should visit sh404SEF .

The information given in this category is intended to guide users who want to use sh404SEF with Kunena and, mostly, was written by Kunena users. The information here is not necessarily accurate, up-to-date nor is it intended to replace the support given by the developers of sh404SEF.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Important Pagination not working

More
4 years 2 months ago - 4 years 2 months ago #1 by buxshots
Hi,

first, I am using Kunena 3.06 and Joomla latest. Joomla & Kunena SEO SEF is activated.

Well, I have a problem with the pagination when I want to browse a category that displays topics on more than one page. So, let´s say we have a category with 25 topcis in it and we display 20 topics each page.

If I visit the forum category, the page navigation SEO urls are rewritten in category.html (page1) and category.html?start=20 for (page2). The category.html is the same URL that is shown on the forum frontpage to enter the category. And I am wondering why the url does not contain "?limitstart=0" at the end?


The problem appears if I visit the second page and want to go back to the first page, nothing happens and I stay on the second page. If I manually add "?limitstart=0" to the first page URL it works. But not if I click the shown [1] link to page 1.


Everything else works so great and I love Kunena. Anybody with an idea what can cause this issue?

I also tried with sh404sef where I can see the rewritten urls and I did not find any url with "limitstart=0"....

btw. when SEO urls are deactivated, everything works fine. So it seems that there is an issue with rewriting this url, that the "?limitstart=0" in the page 1 link is missing or what else could cause this error?

Link to website: deleted

Thanks so much in advance,
buxi

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 128M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : rt_voxel_responsive | author: RocketTheme, LLC | version: 1.3 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.6 | creationdate: 2014-07-28

Kunena version detailed: Kunena 3.0.6 | 2014-07-28 [ Tala ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: sh404sef 4.4.4.1791

Plugins: None

Modules: None

Last edit: 4 years 2 months ago by buxshots.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #2 by 810
Replied by 810 on topic Pagination not working
Please change kunena sef to joomla router. On sh404sef config.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago - 4 years 2 months ago #3 by buxshots
Replied by buxshots on topic Pagination not working
Hi,
ok, done. Unfortunately it is still not working.

Here is the link to homepage as the forum link above is no longer working. link deleted
Pls find the forum url in main menu on top

regards
Last edit: 4 years 2 months ago by buxshots.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #4 by 810
Replied by 810 on topic Pagination not working
try clean cache.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #5 by buxshots
Replied by buxshots on topic Pagination not working
Cleaned the cache. Also both joomla and the kunena cache is deactivated.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #6 by 810
Replied by 810 on topic Pagination not working
try to find:
forum/recent
in the sh404sef sef manager. and remove it.

Or find all kunena links and remove them.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #7 by buxshots
Replied by buxshots on topic Pagination not working
Hi,
all kunena links removed. Still the same :(

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #8 by 810
Replied by 810 on topic Pagination not working
then try disable sh404sef. and clean cache again

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #9 by 810
Replied by 810 on topic Pagination not working
maybe its the forum menu.

Go to backend- kunena - tools - menu - fix menu.

Then move the forum item to your menu (top ?)

because I see: wf-menu-profiles/forum that's incorrect sef

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago - 4 years 2 months ago #10 by buxshots
Replied by buxshots on topic Pagination not working
Fixed the menu and completely deactivated sh404sef. This did the trick!!!

Then it works until I activate sh404sef again. Mysterious, because kunena is deactivated in sh404sef so this should not affect kunena... unfortunately I cannot deactivate sh404sef so I will need to ask their support to fix this issue...

Thanks so much for your apprediated effort
Last edit: 4 years 2 months ago by buxshots.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.107 seconds