×
Kunena 5.1.4 Released and Blue Eagle 1.5.1 (23 Sep 2018)

The Kunena team has announce the arrival of Kunena 5.1.4 [K 5.1.4] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a maintenance release.

× This is for users to help other users, to discuss topics that relate to migrating from other web-based forums and converting the data into a form that will operate with Kunena.

It is important to note that the Kunena team does not have a standard, recommended or supported protocol for these ideas and that posting questions in this category may not receive advice from team members.

Solved "Kunena Forum Importer" / migration tool

More
3 years 3 weeks ago #1 by TerraceMedia
Hello,

I have a Joomla! 2.5 site which has a Codingfish Discussions forum installed. I would like to migrate that to Kunena 4.05/Joomla! 3.4.

I have found old forum posts and pages in the wiki which mention Kunena extensions called Kunena Installer or Kunena Forum Importer that has support for Codingfish Discussions migration, but I cannot find that extension on the Kunena.org download page.

Can someone point me to it, and/or suggest the proper steps to follow to accomplish my task?

Please Log in or Create an account to join the conversation.

More
3 years 3 weeks ago #2 by xillibit
Hello,

This extension is available from here : github.com/Kunena/com_kunenaimporter/releases , this works on Joomla! 2.5

But there isn't support of codingfish discussions support on it

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: TerraceMedia

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #3 by TerraceMedia
That archive is missing the installer xml. Is it available elsewhere?

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #4 by xillibit
It's available only on this place, on which Joomla! version did-you have tried ?

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: TerraceMedia

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #5 by TerraceMedia
Joomla! 2.5.28 and I've also installed Kunena 2.0. The install fails because in the zip linked above there is no xml to run the install.

Interestingly, com_kunenaimporter seems to have support for Discussions by Codingfish; i found a file export_discussions.php in it that looks like it deals with this schema.

Thank for your help, I appreciate it.

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #6 by xillibit
Sorry i thought that it was a package wit ha xml file at the root in it, so you can donwload from here : joomlacode.org/gf/project/kunena/frs/?ac...&frs_package_id=6065 untill that joomlacode.org si still alive

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: TerraceMedia

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #7 by TerraceMedia
Thanks a lot for the quick reply and the link with the component XML. I'll come back here and let you know how our conversion goes. I know it's a crap shoot and the migration isn't supported any longer, but it might be worth documenting in this way for the next person.

Please Log in or Create an account to join the conversation.

More
2 years 10 months ago - 2 years 10 months ago #8 by TerraceMedia
I'm sorry it took me a while to return to this thread. Once we had the Kunena Importer component with the XML, it was very easy. We updated Joomla! 2.5 to the final version, 2.5.28. Then we installed Kunena 2.0 and com_kunenaimporter, and followed the documented process to convert. It was successful on the first attempt. We then updated Kunena as far as 4.03, tested that it was working on the front end, and updated Joomla! to 3.4.5. The board is working perfectly and all data has migrated as expected. We have since applied updates to Joomla! and to Kunena.

Thanks. This tool saved a lot of tedious and expensive time in phpMyAdmin.
Last edit: 2 years 10 months ago by TerraceMedia.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #9 by Shinju
Hello, there

I want to bring this topic back.

Currently, my J2.5 website has the Codingfish Discussions Forum v.1.6.1 and I want to migrate to Kunena. I downloaded the "Kunena Forum Importer" component v1.7.2 , and I installed both Kunena plugin and the migration tool, it says the installation was succesfull in the two cases, also activated both, but whenever I clicked on the migration tool it says the following message:

Kunena is not installed or the installed Kunena version is not supported. The Kunena Importer has been disabled. Please install/upgrade Kunena to version 1.7 for the Kunena Importer to function properly.


I also tried installing kunena 2.0.4 but nothing. It says it was installed succesfully but it seems not to work.

Any suggestions? I appreacite all kind of help. Thanks!
Attachments:

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #10 by xillibit
Hello,

Like the error message say, you need to have Kunena 1.7.2 and not the 2.0.4 because only Kunena 1.7.2 is supported by this importer.

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: Shinju

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.102 seconds