×
K5.1.1 is released (10 Jun 2018)

The Kunena team is pleased to announce Kunena 5.1.1 [K 5.1.1].
Please read the blog post for information:

× This is for users to help other users, to discuss topics that relate to migrating from other web-based forums and converting the data into a form that will operate with Kunena.

It is important to note that the Kunena team does not have a standard, recommended or supported protocol for these ideas and that posting questions in this category may not receive advice from team members.

Solved "Kunena Forum Importer" / migration tool

More
2 years 2 months ago #11 by Shinju
@Xillibit, Thank you for your fast response!

It seems I was installing the wrong kunena file. I downloaded the correct file from here and now the message it's not showing up anymore. I'll now continue with the backup of my site and hope to don't have any other problems with the migration. I'll come back to update my process!

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #12 by Shinju
Hi, again

Before doing the real migration in my website, I tested the forum importer in my webserver. Everything seemed alright for a moment, it was migrating the database, but after a few minutes an error message was shown.

As you can see in the screenshots, the tool was already migrating user profiles. The message error it's the following one

ERROR: KunenaImporterTableUserProfile::store failed - Duplicate entry '3043' for key 1 SQL=INSERT INTO `t7yrw_kunena_users` (`userid`,`view`,`moderator`,`ordering`,`posts`,`avatar`,`karma`,`karma_time`,`uhits`,`personalText`,`gender`,`TWITTER`,`FACEBOOK`,`FLICKR`,`websiteurl`,`hideEmail`,`showOnline`) VALUES ('3043','flat','0','0','0','','0','0','0','','0','','','','','0','1')


Since the website in my localhost it's still working, I tried skipping the user profiles importe, and selected just to import categories, and another message was shown:

ERROR: KunenaImporterTableCategories::store failed - Duplicate entry '1' for key 1 SQL=INSERT INTO `t7yrw_kunena_categories` (`id`,`parent`,`name`,`cat_emoticon`,`locked`,`moderated`,`pub_access`,`pub_recurse`,`admin_access`,`admin_recurse`,`ordering`,`published`,`review`,`allow_anonymous`,`post_anonymous`,`hits`,`description`,`headerdesc`,`class_sfx`,`allow_polls`,`id_last_msg`,`numTopics`,`numPosts`,`time_last_msg`,`access`) VALUES ('1','0','El Proyecto - Foro','0','0','0','0','1','0','1','1','1','0','0','0','0','Bienvenido al foro de discusiĆ³n. ','','','0','0','0','0','0000-00-00 00:00:00','1')


Does anyone has an idea of what must be wrong here? Any suggestions in what can I do to solve it? Thanks in advance!
Attachments:

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #13 by 810
you have already a user with the same id.

So try to change the id from the admin. Then delete the old users. and run the migration again
The following user(s) said Thank You: Shinju

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago - 2 years 2 months ago #14 by Shinju
It seems I made too many mistakes.

The error I was getting was because I didn't truncate before beggining the importation.
Once I did, it was really quick!

Thank you so much for the support.
Attachments:
Last edit: 2 years 2 months ago by Shinju.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.099 seconds