Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

Solved Error: Field 'params' doesn't have a default value

More
1 year 9 months ago #1 by remco123
When a user creates a new forum post he/she gets error Field 'params' doesn't have a default value when selecting the submit button. The New Tipic page does not reload and it looks like the post is not created. But when you hit the back button or select the "new topics" you will see that the post is created.
When you check the My topics item no posts are shown.

How can we fix this?

Joomla! version: 4.1.5
PHP version: 8.0.22
Kunena version: 6.0.2

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #2 by rich
Do you have access to your database?
Make a backup of your database and enter the following SQL command in phpMyAdmin. (Instead of #__ you have to enter your prefix).
.
Code:
ALTER TABLE `#__kunena_user_topics` CHANGE `params` `params` TEXT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci NULL DEFAULT NULL;

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #3 by remco123
Hi thank you and sorry for the late reply. I made the above change into the database. Now this error is gone.
But I do get a new error > Error 500: Could not instantiate mail function.
Which means the email can not be sent to the user/moderator. When I check the forum the new post (or reply) is visible, thus added to the database.
Whether I enable or disable the subscription in config, still this error comes up.
In diagnostics check everything is green (test passed)

What can be the reason for not sending the email? All our other email functionality on the site (registration, etc) is working fine.



oomla! version: 4.1.5 and 4.2.2
PHP version: 8.0.22
Kunena version: 6.0.2

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #4 by rich

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #5 by remco123
Yes same problem and I tried the options in that post but it does not make a difference. Error is still there. Any other ideas how to solve this? There must be a reason why this happens.

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #6 by Leen
hello Remco, Is this error in joomla 4 ?
And if so what if you are in adminstrator > kunena> Kunena Forum: Tools and then Synchronize Users does that work or is there sometimes an error?
or take a look at the tools at Diagnostics to see if there are any messages there?

L.v.d.A
Attachments:

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #7 by remco123
I synchronized the users, that worked fine. Then did a new test and same 500 error comes.  

I also clean cache all the time. No idea if this is necessary but I do it anyway.
The diagnostic are all in green with test passed.

Joomla! version: 4.2.2
PHP version: 8.0.22
Kunena version: 6.0.2

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #8 by remco123
I just made a Akeeba backup and installed this on a different server with different hosting company and everything works fine. So this is due to some email/spam setting (?) in my siteground hosting plan. If I get any detailed info from siteground why this is happening I will share the info.

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #9 by Leen
ha yes I had just read something like that somewhere that could possibly be stopped by a hoster's spam filter.
I assume you have also tested with any other joomla
Global Configuration mailer settings eg php mailer or sendmail or smtp

L.v.d.A
The following user(s) said Thank You: remco123

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #10 by remco123
I did test with SMTP option on a while ago when Acymailing was not working and that did not fixed the problem then but now I test again with SMTP enabled and everything works fine.

So for me the final solution is to set the Joomla mail setting to SMTP if on siteground hosting.
If on hostgator hosting the Joomla mail setting PHP mailer works fine.

Thanks for your help!

Please Log in or Create an account to join the conversation.

Time to create page: 0.589 seconds