×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Question Unable to change avatar in profile

More
2 months 3 days ago - 2 months 3 days ago #1 by DeeEmm
I have a vanilla installation of Joomla and Kunena. I am unable to upload a new avatar despite the folder permissions being okay and the avatar dimensions not exceeding the appropriate sizes. When I try to upload an avatar, the process appears to have succeeded, but then when I check my profile, the avatar is the same. Additionally caching is turned off.

Any ideas?

Here's the configuration report...

This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 16M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : protostar | author: Kyle Ledbetter | version: 1.0 | creationdate: 4/30/2012

Kunena default template details : Crypsis | author: Kunena Team | version: 5.1.18 | creationdate: 2020-06-30

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.1.18 | 2020-06-30 [ Rhea ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 2 months 3 days ago by DeeEmm. Reason: Bad spelling :D

Please Log in or Create an account to join the conversation.

More
2 months 2 days ago #2 by xillibit
Hello,

Do-you see the avatar just after that you have uploaded it ? Like here :


I don't provide support by PM, because this can be useful for someone else.
Attachments:

Please Log in or Create an account to join the conversation.

More
2 months 2 days ago #3 by DeeEmm
Yes, when I browse to the file, or drag and drop it, the image appears in place of the default image...



Then when I click submit I get a message that says 'Your Profile has been saved'



But the image is not changed.

I initially thought it must be a permissions or ownership issue, but these appear to be okay and also checkout in the Joomla folder permissions test...



There's no error message within the server logs either, whatever is causing it to fail, is doing so quietly with no errors.

I did a search here thinking that it might be a rookie error or common problem, but could find nothing. It's been a few years since I've used Kunena and assumed it's something I've missed on the setup / install.

I'm sure it'll be something simple, but I cannot figure it out.

/DM
Attachments:

Please Log in or Create an account to join the conversation.

More
2 months 1 day ago #4 by rich
I see on your image, the profile has been saved before the avatar upload was finish. If the upload is success, the avatar name get the link colour (in this case it should be blue). Afterwards you can save the profile. If does not work, then open the browser console, maybe it shows a hint during the upload process.

Try also to switch the Default avatar type in the configuration.

Please Log in or Create an account to join the conversation.

More
2 months 1 day ago #5 by DeeEmm
Thanks rich.
When submitting the console is reporting a 404...
POST https://my...web...site.com/forum/profile/edit/index.php?option=com_kunena&view=user&task=upload&format=json 404 (Not Found)
Which is originating from jquery...
jquery.min.js?5d924186c7b2f3be1645c9388a24f08d:2

Please Log in or Create an account to join the conversation.

More
2 months 16 hours ago - 2 months 16 hours ago #6 by rich
Maybe similar problem: www.kunena.org/forum/k5-1-support/154646...e-since-k-5-1#204910
Try in the configuration (tab General) the option Direct Component Access = Yes
Last edit: 2 months 16 hours ago by rich.
The following user(s) said Thank You: DeeEmm

Please Log in or Create an account to join the conversation.

More
2 months 15 hours ago #7 by DeeEmm
Thanks rich, however that setting made no difference, nor did the other SEO settings.

I also tried changing the path within /components/com_kunena/template/crypsis/assets/js/upload.avatar.js at line 40 as suggested in the linked article, but this too made no difference.

There was another suggestion mentioned that it could be related to a .htaccess file, however I am running nginx and so .htaccess are redundant.

I did however have some success. I turned 'Search Engine Friendly URLs' off in Joomla and it worked. So your suggestion was somewhat close. It seems that it does not want to play nicely with Joomla SEO.

Any further thoughts or ideas?

/DM

Please Log in or Create an account to join the conversation.

More
2 months 11 hours ago #8 by ssh
If you are using cloudflare, make sure you purge the cache there.
Also try Ctrl+F5
Also try Ctrl+Shift+Delete
Also try to install the .htacces file that comes with Joomla by default
Also try to see in your server directory if the image is uploaded, even when you can't see it in the frontend

Please Log in or Create an account to join the conversation.

More
2 months 8 hours ago #9 by DeeEmm
CMD+R / CMD+Shift+R (hard refresh) make no difference (I'm on a mac). Definitely not a browser problem as the 404 is the status sent from the server in response to the upload. So either the URL is incorrect or it does not actually exist. The 404 is a soft 404 as https://my...web...site.com/forum/profile/edit/index.php is a valid url. So it's only getting rejected on the basis that the query string is incorrect or missing (or any other reason that the component decides)

I'm not using clouflare and have all caching disabled.

.htaccess is an apache thing, it does not work on an Nginx server. Nginx uses a modified version of mod-rewrite within the server directives. However, the only rule there is passing the query strings, which is working fine, otherwise basic navigation would not work.

One thing to note, I cannot see where the userdata is generated / passed. Obviously with Joomla SEO turned off it is passed as 'GET' vars within the URL query strings, however with SEO turned on, no vars are present in the URL and no POST vars are created within the page that I can see. However I will be the first to admit that javascript is not really my thing.

I've looked to see if I can grab the URL of the file upload when SEO is turned off but not sure how to do that (I'm using chrome).

Any further advice warmly welcomed.

Please Log in or Create an account to join the conversation.

More
2 months 7 hours ago #10 by DeeEmm
There is also another possibility...

maybe the URL and #GET data is well formed but the server is rejecting the request.!?

I find this one hard to believe as the site is working fine otherwise.

Also; normal forum attachment upload works fine. Does this use the same script?

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 1.047 seconds