×
Kunena 5.1.5 Released - Security Release (14 Oct 2018)

The Kunena team has announce the arrival of Kunena 5.1.5 [K 5.1.5] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

Question Avatar size exceed limit allowed by configuration

More
4 months 2 weeks ago #1 by Kallehak
Getting "Avatar size exceed limit allowed by configuration" regardless of image size. Have tried all 3 resize methods. Upload sizes are set to 8.5 MB and PHP upload limit is set to 64 MB.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 96M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : protostar | author: Kyle Ledbetter | version: 1.0 | creationdate: 4/30/2012

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.5.0-RC3-DEV | creationdate: 2017-08-30

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.0 | 2018-05-13 [ Ariel ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 5.1.0

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago - 4 months 2 weeks ago #2 by infermieriattivi
Hi
confirm a problem.
"La dimensione Avatar supera il limite consentito dalla configurazione"
Non si modifica più l'avatar.
Questo è un problema.
Last edit: 4 months 2 weeks ago by infermieriattivi.

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago - 4 months 2 weeks ago #3 by EfEm
Same here. Both with avatars and with file attachments. I tried uploading a file with only 64 bytes as well as setting the size limits to ridiculously high values. Nothing worked.

My config:
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 256M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : rt_fluent | author: RocketTheme, LLC | version: 1.0.3 | creationdate: December 26, 2017

Kunena default template details : Crypsis | author: Kunena Team | version: 5.1.0 | creationdate: 2018-05-13

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.0 | 2018-05-13 [ Ariel ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: UddeIM 4.0

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 4 months 2 weeks ago by EfEm.

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #4 by xillibit
Hello,

Did-you had checked that the width and height settings are more high that the resolution of images ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #5 by Kallehak

xillibit wrote: Hello,

Did-you had checked that the width and height settings are more high that the resolution of images ?


Avatar settings are 800x800 pixels. Tried upload pictures from 1500x1500 down to 32x32 pixels. Nothing worked.

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago - 4 months 1 week ago #6 by Kallehak
I checked libraries/kuena/upload/upload.php and found that the functions:

checkFileSizeAvatar
checkFileSizeFileAttachment
checkFileSizeImageAttachment

did return 0 when a file/image were not bigger than allowed. So I changed:

return (int) max(
0,
min(
$this->toBytes(ini_get('upload_max_filesize')) - 1024,
$this->toBytes(ini_get('post_max_size')) - 1024,
$this->toBytes(ini_get('memory_limit')) - 1024 * 1024
)
);

to:

return true;

in the functions and now it works :-)
Last edit: 4 months 1 week ago by Kallehak.

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #7 by unker
Hi,

indeed, I have the same issue and followed Kallehak's steps and it seems to be OK, so far.

However, I do not understand why this worked in 5.0.14, where the code in this respect is identical....:dry:

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #8 by EfEm

unker wrote: However, I do not understand why this worked in 5.0.14, where the code in this respect is identical....:dry:

I don't know, that sounds to me like the actual problem is somewhere else.

With the update to 5.1.1, nothing changed for me sadly :(

Please Log in or Create an account to join the conversation.

More
4 months 3 days ago #9 by xillibit

Kallehak wrote: I checked libraries/kuena/upload/upload.php and found that the functions:

checkFileSizeAvatar
checkFileSizeFileAttachment
checkFileSizeImageAttachment

did return 0 when a file/image were not bigger than allowed. So I changed:

return (int) max(
0,
min(
$this->toBytes(ini_get('upload_max_filesize')) - 1024,
$this->toBytes(ini_get('post_max_size')) - 1024,
$this->toBytes(ini_get('memory_limit')) - 1024 * 1024
)
);

to:

return true;

in the functions and now it works :-)

With that you can never check if the avatar size exceed the limits set in configuration

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
4 months 2 days ago #10 by unker
Yes, xillibit,

you are absolutely right.

So we have the choice:
no avatars, attachments and images
or
no size control...

...as long as nothing will be corrected ;)

Best Regards
Hartmut

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.194 seconds