×
Blue Eagle (1.5.0) for K5.1 is released (Yesterday)

Please update the Kunena Blue Eagle to 1.5.0 if you use Kunena 5.1.
We made several bug fixes and improvements. Also Blue Eagle has now all the features from Crypsis.
Download: www.kunena.org/download/templates/category/blue-eagle-5

Solved Blue Eagle 5 Error HTTP 500 with Social parameters

More
4 weeks 1 day ago - 4 weeks 1 day ago #1 by PieceOfCake
Hello everyone,

I did not notice it previously, but I get an HTTP 500 error when users try to edit their profile. I currently use Kunena 5.1.1 with my test server and Kunena 5.1.0 on production server : both have the same problem.

Setting debug mode on in Kunena configuration give the following :




the error doesn't exist when using other template (neither Crypsis, nor Crypsisb produce HTTP 500 while editing profile).
Line 110 (and following) in default.php for blue eagle5 layout edit mode show :
<?php foreach ($this->social as $social) : ?>
					<tr>
						<td>
							<label for="social-<?php echo $social; ?>">
								<?php echo JText::_('COM_KUNENA_MYPROFILE_' . $social); ?>
							</label>
						</td>
						<td>
							<span class="hasTip" title="<?php echo JText::_("COM_KUNENA_MYPROFILE_{$social}")
								. '::' . JText::_("COM_KUNENA_MYPROFILE_{$social}_DESC"); ?>" >
								<input id="social-<?php echo $social; ?>" type="text" name="<?php echo $social ?>"
								       value="<?php echo $this->escape($this->profile->$social); ?>" />
							</span>
						</td>
					</tr>
					<?php endforeach; ?>

Setting configuration mode for Kunena : user > Social option to 'No' doesn't produce HTTP 500, but I would like to show these Social button !!


Do you have any idea what I can do ?

thanks in advance (following are my current 5.1.0 settings)


This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 768M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : jsn_epic_pro | author: JoomlaShine.com | version: 6.2.1 | creationdate: 08/11/2016

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.0.4 | creationdate: 2017-09-02

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.0 | 2018-05-13 [ Ariel ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Attachments:
Last edit: 4 weeks 1 day ago by PieceOfCake.

Please Log in or Create an account to join the conversation.

More
3 weeks 5 days ago #2 by rich
Please update your Blue Eagle, this bug is already fixed.

Please Log in or Create an account to join the conversation.

More
2 weeks 5 days ago - 2 weeks 5 days ago #3 by PieceOfCake
Sorry, was on vacation :)
I updated it just after posting previous message :
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 768M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : jsn_epic_pro | author: JoomlaShine.com | version: 6.2.1 | creationdate: 08/11/2016

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.0.4 | creationdate: 2017-09-02

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.1 | 2018-06-10 [ Belinda ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None



The problem is always there. If you need it, I can give you credits for trying by yourself
Last edit: 2 weeks 5 days ago by PieceOfCake.

Please Log in or Create an account to join the conversation.

More
2 weeks 5 days ago #4 by PieceOfCake

PieceOfCake wrote: Sorry, was on vacation :)
I updated it just after posting previous message :

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 768M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : jsn_epic_pro | author: JoomlaShine.com | version: 6.2.1 | creationdate: 08/11/2016

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.0.4 | creationdate: 2017-09-02

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.1 | 2018-06-10 [ Belinda ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None



The problem is always there. If you need it, I can give you credits for trying by yourself


PS : I see that Blue Eagle 5 is reported as 1.0.4 I downloaded last version (as far as I can see it), what did I wrong ?

Please Log in or Create an account to join the conversation.

More
2 weeks 5 days ago #5 by PieceOfCake
OK I found why I remained in 1.0.4, it's now right (1.0.5)

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 768M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : jsn_epic_pro | author: JoomlaShine.com | version: 6.2.1 | creationdate: 08/11/2016

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.0.5 | creationdate: 2018-02-11

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.1 | 2018-06-10 [ Belinda ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None



but alas still the HTTP 500 error

Please Log in or Create an account to join the conversation.

More
2 weeks 4 days ago - 2 weeks 4 days ago #6 by 810
First download the latest version on www.kunena.org/download/templates/category/blue-eagle-5

should be 1.5.0-rc3
Last edit: 2 weeks 4 days ago by 810.

Please Log in or Create an account to join the conversation.

More
2 weeks 4 days ago #7 by PieceOfCake
OK tested on my mirror site, seems to be OK (remains a problem with Lazy Load Images, emoticons and JCHOptimize, but that's JCHOptimize problem, currently investigating)

I did not see there were a RC version currently on the Blue Eagle 5 template (must I change something in my parameters to see these new RC versions ?)

Many thanks

Please Log in or Create an account to join the conversation.

More
2 weeks 4 days ago #8 by 810
Lazy Load has been removed on K5.1

Try to enable "Load bootstrap option" on the template settings

Please Log in or Create an account to join the conversation.

More
2 weeks 4 days ago #9 by 810
No, you need to check some times, if there are updates. We are still looking for a good solution.

Please Log in or Create an account to join the conversation.

More
2 weeks 3 days ago #10 by PieceOfCake
Done on production site, everything's work fine now ;)

Lazy load Images : I meant the way JCHOptimize use it (I could finally with Samuel's help done it : work nicely now)

Found a slight bug in displya for rc3 showed on the joined

screenshot

Seems this is due to the html statement :
<span class="hidden-phone topic-starter topic-starter-circle">Auteur du sujet</span>

replacing <span> by <div> works fine (tested in chrome) same result with inserting a <br/> before <span> item
Attachments:

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.317 seconds