×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

Solved [Solved] Error 500 on selecting user profile

More
3 years 6 months ago - 3 years 6 months ago #1 by titchagcreation
Hello,

New problem after updating to Kunena 5.0.6.1.

When clicking on a user profile, I have a Error 500. It was working perfectly before the update from K5.0.4. I didn't change anything on the server nor on the htaccess.

My config:
Joomla 3.6.5
SEF urls = Yes
Use URL Rewriting = Yes
Adds Suffix to URL = Yes
Unicode Aliases =No

As on my other problem , I think it is a problem with management of urls management (surely url rewriting problem) by Kunena.

I tested by disabling the SEF mode and accessing directly the list of users (index.php?option=com_kunena&view=user&Itemid=164) => Error 500.
Last edit: 3 years 6 months ago by titchagcreation. Reason: More information after analyzing the problem

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #2 by rich
Please enable debug mode on Joomla! and Kunena to see more details on the error.

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #3 by titchagcreation
OK. I will try it. I have to make a copy of the website first because it's on an online website so I can't put it on debug mode.
As soon as I have more information I post here.

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #4 by terminator
I'm having the same problem

500 Internal Server Error
Fatal Error was detected!

The error was detected in the Kunena Component.

Fatal Error: Can't use method return value in write context in components/com_kunena/controller/message/list/recent/display.php on line 264

For support click here: Kunena Support

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #5 by rich
It seems, you use php 5.4. This topic should help you: www.kunena.org/forum/k5-0-support-archiv...ick-on-username-link
The following user(s) said Thank You: terminator, titchagcreation

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #6 by titchagcreation
It helped but Kunena should support PHP 5.4 as it is indicated in the requirements :whistle:

Thanks for your help.

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #7 by rich

It helped but Kunena should support PHP 5.4 as it is indicated in the requirements

I think, it's fixed in the next version.

Please Log in or Create an account to join the conversation.

More
3 years 6 months ago #8 by titchagcreation
Great! B)
Anyway I updated the PHP version to 5.6.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.120 seconds