×
Kunena 5.1.7 Released - Security Release (20 Nov 2018)

The Kunena team has announce the arrival of Kunena 5.1.7 [K 5.1.7] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This section is for questions directly related to the procedure for installing Kunena for the first time or upgrading from an older version of Kunena.

Use this category:
  • to ask how to install or upgrade; or
  • if you encountered problems during the installation or upgrade procedure.

Use a different category to ask questions about problems that you may be having after you successfully installed or upgraded the currently supported version. If you are unsure what is the current supported version of Kunena, please go to the download page.

Question Preview is not working after update to K5.0.6.1

More
1 year 9 months ago #1 by titchagcreation
Hello,

I updated Kunena from 5.0.4 to 5.0.6.1 but now Preview is not working anymore.
I am using the crypsisb3 template.

When I click on Preview tab it switches to the tab but the content preview is empty.

I noticed that the ajax call done on kPreviewHelper(previewActive) in the edit.js file was not returning success. Actually, I think the #preview_url is wrong . Actually this is its value "/forum/topic/edit.raw". For information, in my Joomla settings SEF urls, Use URL Rewriting and Adds Suffix to URL are set to Yes (Unicode Aliases is set to No).
As I kept a backup of my installation, I noticed that the url parameter for the ajax call was 'index.php?option=com_kunena&view=topic&layout=edit&format=raw' (instead of jQuery('#kpreview_url').val())
I put back this parameter to its old value and now it works so I think there is a problem with this new code maybe because of url rewriting?
I noticed in your forum that the value for #preview_url is /forum/topic/edit?format=raw.

Please could you fix it? or maybe do i need to do something to make it work correctly?

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.098 seconds