×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Solved Kunena 5.0.1 language strings problem (COM_KUNENA_X_TOPICS etc)

More
3 years 10 months ago #1 by kunenauser40
Hi,
I have Joomla 3.6.2, Kunena 5.0.1 and all plugins / language pack etc updated to the latest version.

I use wamp 3.0.0 as test enviroment with php 5.6.16.

The problem is that a lot of specific strings in forum are shown as COM_KUNENA_TOPIC_STARTED_ON, COM_KUNENA_X_TOPICS_MORE etc instead of the correct words or numbers they should write.

In configuration the option "Use English On Missing Strings" is set to Yes but it still appears the COM_KUNENA etc instead of the correct words.

I use Greek language in the forum, and even if I disable the Greek language from extensions / manage/ manage / Kunena Language - Greek (Greece) the problem is still the same.
Only if I uninstall completely the Greek language then the forum use in these strings the English language correctly. If I try to install again the language pack then the problem appears again with the wrong strings (COM_KUNENA_X_TOPICS_MORE etc)

I had the same problem when I updated in Wamp the kunena forum from 4 to 5.0 but I had read somewhere here in forum that this bug would be fixed in 5.0.1 but the problem is still exist after I updated to 5.0.1..

I tried a lot of things like to clear cache / expired cache, I uninstalled / reinstalled the language pack 5.0.1 and kunena itself, clear cookies in browser, changed PHP version in wamp from 5.6.16 to 7.0.0 but still the same.

Is there a fix for this "bug" because I cannot update to 5.0.1 in the live site if I have this problem and I have still the version 4 of kunena...

Thank you very much for your time.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago - 3 years 10 months ago #2 by Smirnov
Hello. My solution..

remove
COM_KUNENA_X_TOPICS_0 = "No topics"
COM_KUNENA_X_TOPICS_1 = "%s tppics"

write
COM_KUNENA_X_TOPICS = "%s topics"

It works.
Last edit: 3 years 10 months ago by Smirnov.
The following user(s) said Thank You: kunenauser40

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #3 by 810
Do you guys have installed the kunena language pack? because for me its works: I can see the English strings

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #4 by Smirnov
Of course, it is installed.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #5 by 810
ok, see the issue.

please copy all the content from components\com_kunena\language\en-GB to language\en-GB

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #6 by 810
Ok, fixed, check updater
The following user(s) said Thank You: kunenauser40

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago - 3 years 10 months ago #7 by Smirnov

810 wrote: Ok, fixed, check updater


Strange ... I again received after update "COM_KUNENA_X_TOPICS".

Language by default on the site: Russian,
Forum Options -> "Use English in the missing lines" -> Yes.
Last edit: 3 years 10 months ago by Smirnov.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #8 by 810
Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago - 3 years 10 months ago #9 by Smirnov
Last edit: 3 years 10 months ago by Smirnov.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #10 by rich
Confirmed. It seems Russian language has loading problems. At the image you see a already existed installation (some days old). The original categories do not loads the language.
But a copied category loads the strings correct. On a new installations it also works (I've tested it on 2 different pages). Maybe there is this problem also with other languages.
Attachments:

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.678 seconds