×
Blue Eagle 1.5.2 Released (Yesterday)

The Kunena team has announce the arrival of Kunena Blue Eagle 1.5.2 which is now available for download as a native Joomla extension for Kunena 5.1. This version addresses most of the issues that were discovered in K 1.5.1 and issues discovered during the development stages of K 1.5.2.

Question Kunena not attaching uploaded attachment file

More
2 years 6 months ago - 2 years 6 months ago #1 by kankaanp
Hi!

I'm having trouble with attachments in Kunena (4). The last time some one managed to upload an attachment to a forum message and have it correctly displayed in the message was on May 4th this year. Now every time any one tries to attach a file to a message in Kunena gets the message correctly posted, the file added to /media/kunena/attachments/[user-id] but NOT displayed on the forum message. Instead they get Notice: Cannot save attachment: File '/' doesn't exist! This happens with firmly small enough and allowed file types like jpg, png and pdf. Joomla debug function or raising php error reporting level gives nothing, absolutely nothing. cPanel Access log seems normal but in Error log there are several PHP Warnings:
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagecopyresized() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 143, referer: https://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagefill() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 130, referer: https://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagecolortransparent() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 129, referer: https://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagecolorallocatealpha() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 125, referer: https://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagesavealpha() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 106, referer: https://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagealphablending() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 105, referer: https://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagecreatetruecolor(): Invalid image dimensions in /home/fortisf/public_html/libraries/kunena/image/image.php on line 72, referer: https://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  Division by zero in /home/fortisf/public_html/libraries/joomla/image/image.php on line 1079, referer: https://fortis.fi/foorumi/testaus/topic/create
[Sat May 28 08:59:52 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  Division by zero in /home/fortisf/public_html/libraries/joomla/image/image.php on line 1078, referer: https://fortis.fi/foorumi/testaus/topic/create

I've made sure the directory permissions are 755 (with Admin tools) and checked that they are with cPanel File Manager.

I've checked that the DB is up to date with Joomla and run Repair and Optimize tables with Admin tools.

Found this rather similar problem thread in archieve:https://www.kunena.org/forum/k-4-0-support-archive/134609-error-adding-and-viewing-attachments#168366 No help there.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 32M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : t3_bs3_blank | author: JoomlArt.com | version: 2.2.1 | creationdate: 30 July 2015

Kunena default template details : Blue Eagle | author: Kunena Team | version: 4.0.10 | creationdate: 2016-02-18

Kunena version detailed: Kunena 4.0.10 | 2016-02-18 [ Villavicencio ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: Search - Kunena Search 3.1.2 | Content - Kunena Discuss 3.1.2

Modules: Kunena Latest 3.1.2.1 | Kunena Stats 3.1.2 | Kunena Search 3.1.2

Last edit: 2 years 6 months ago by kankaanp. Reason: added link to the archieved similar problem

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #2 by kankaanp
Ok, I've gone through Kunena config with a thick comb and have found nothing.

I tried to play with the templates a bit. The current site layout was intended to use Crypsis but it turned out HORRIBLE. It was displaying both desktop and mobile Kunena menus at the same time and was totally unusable. So we switched back to Blue Eagle (4). What I did:
I set Protostar for all Kunena related menu items and switched Kunena template back to Crypsis. This produced a more palatable layout for the forum but did not solve the problem. It did produce a different error message though:

No valid image was loaded.

The image I tried to load was 2,7 megabyte jpg photo and the upload limit is 5 megabytes and jpg is allowed. No change in logged errors.

HELP! :( This is a very active forum.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #3 by 810
ok try with the php finfo module

just edit php.ini and uncomment this line:

extension=php_fileinfo.dll

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #4 by kankaanp
Can I use the same format when I insert that into my .user.ini -file in the public_html -folder of the webhotel?

And THANKS a lot for taking the time help me!

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #5 by 810
yes, try it, if its works for you

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #6 by kankaanp
Well, did that and tried again. There seems to be fileinfo support now in System info / PHP info now. No change in frontend behaviour when posting a message with attachment. No new errors in error_log:
[Mon May 30 15:22:49 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagecopyresampled() expects parameter 1 to be resource, boolean given in /home/fortisf/public_html/libraries/kunena/image/image.php on line 147, referer: https://fortis.fi/foorumi/testaus/topic/create
[Mon May 30 15:22:49 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  imagecreatetruecolor(): Invalid image dimensions in /home/fortisf/public_html/libraries/kunena/image/image.php on line 72, referer: https://fortis.fi/foorumi/testaus/topic/create
[Mon May 30 15:22:49 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  Division by zero in /home/fortisf/public_html/libraries/joomla/image/image.php on line 1079, referer: https://fortis.fi/foorumi/testaus/topic/create
[Mon May 30 15:22:49 2016] [warn] [client 87.100.161.30] mod_fcgid: stderr: PHP Warning:  Division by zero in /home/fortisf/public_html/libraries/joomla/image/image.php on line 1078, referer: https://fortis.fi/foorumi/testaus/topic/create

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7 by kankaanp
Well, some progress: at some point of this process non-image allowed filetypes have started working. Don't know when since I've been using jpg and png to debug mostly. But now atleast PDF and PPT files get attached. (PDFs didn't in the begining of this debug.) GIFs, JPGs and PNGs don't work. SVGs don't work either but with earlier in the process and with error:

Error
Unable to get properties for the image.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #8 by 810
on the kunena config, disable the mime check, maybe then it will work for you.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #9 by kankaanp
Nope, sorry, not that either. :(

I'm begining to think more and more that the hosting has something horribly wrong with it's php image handling extensions.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #10 by 810
ok then try to enable allow_url_fopen

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.249 seconds