×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Solved Internal Server when creating new Topics - no problems (when deleting topics)

More
4 years 3 months ago #1 by mbruell
Hi,

We're running Kunena 4.0.3, and Joomla 3.5.1 on ubuntu 14.04.4 with 4 gb of ram and 4 cpu cores. The system uptime almost always shows less than 1 gb of memory use, and very low load averages (.03 at the moment).

Creating a new topic on Kunena is timing out, and displaying Internal Error. Apache logs indicate:

FastCGI: comm with server "/usr/lib/cgi-bin/php5-fcgi" aborted: idle timeout (30 sec), referer: https://(site)/forum/newtopic.html

and

FastCGI: incomplete headers (0 bytes) received from server "/usr/lib/cgi-bin/php5-fcgi", referer: https://(site)/forum/newtopic.html

If I go back to the forum, I can see that the topic actually got created - but the bottom of the webpage says, "Waiting for hostname....)

We recently switched from Apache2 handler to fastCGI, and I'm wondering/suspecting that I haven't set it up properly. It always has taken a while to create a new topic (definitely more than 10 seconds), but it didn't used to time out.

Thanks in advance for any help you can provide.

Here's our configuration:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 2M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : jsn_decor_pro | author: JoomlaShine.com | version: 3.0.1 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 4.0.3 | creationdate: 2015-06-29

Kunena version detailed: Kunena 4.0.3 | 2015-06-29 [ Possagno ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #2 by xillibit
Hello,

Can-you please update Kunena to 4.0.10 version ?

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: mbruell

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago - 4 years 3 months ago #3 by mbruell
Sure - though I wasn't notified that that was available.

I just tried to get Joomla to find the update to 4.0.10, but it wasn't available. I'll hunt around for documentation on how to install it manually.
Last edit: 4 years 3 months ago by mbruell. Reason: Couldn't follow up with the instructions provided

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #4 by rich
You can install it like any other extension. www.kunena.org/download
Please create a backup before.
The following user(s) said Thank You: mbruell

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #5 by mbruell
Thanks - went along that route, but got the notice that the upload file was too large. I'm going to edit php.ini and try again.

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #6 by mbruell
I keep getting this error:

Error

There was an error uploading this file to the server.
Maximum PHP file upload size is too small: This is set in php.ini in both upload_max_filesize and post_max_size settings of your PHP settings (located in php.ini and/or .htaccess file).
Unable to find install package.

I edited /etc/php5/apache2/php.ini and set the upload_max_filesize = 3M. The max post size is already set to 8M, and this package looks to be about 2.1M, so that shouldn't be causing an issue.

BTW - I haven't installed components before (someone else on the team has done that in the past). I didn't unzip the .zip pkg file. Is that the correct way to do it? Should I move it to docroot/tmp/ and install from there?

Thanks,
M

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #7 by xillibit
Do-you have restarted apache after that you have edited the php.ini ?

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: mbruell

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #8 by mbruell
I had two issues that kept me from installing it. I failed to edit the correct php.ini file (I needed to us /etc/php5/fpm/php.ini, and I had failed to restart apache2 and php).

It installed correctly now, but I'm still getting the same error:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [no address given] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

and in apache2/error.log

[Thu May 05 09:07:52.541479 2016] [fastcgi:error] [pid 8044] [client 192.168.250.3:54776] FastCGI: comm with server "/usr/lib/cgi-bin/php5-fcgi" aborted: idle timeout (30 sec), referer: https://(host)/forum/newtopic.html
[Thu May 05 09:07:52.541684 2016] [fastcgi:error] [pid 8044] [client 192.168.250.3:54776] FastCGI: incomplete headers (0 bytes) received from server "/usr/lib/cgi-bin/php5-fcgi", referer: https://(host)/forum/newtopic.html

As I said earlier, it's always taken a while to create a new post (many times longer than deleting one), but it didn't used to time out. We have moved to fastcgi recently, and that's when the timeout error cropped up. We've been advised to run joomla with fastCGI, so I'd like to be able to get Kunena to work with FastCGI.

Thanks - I've got to go offline for about 45 minutes, but I'll be back then.

M

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #9 by xillibit
Try to enable debug mode in Joomla! and Kunena to see a better error message

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: mbruell

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #10 by mbruell
I'm tailing the /var/log/apache2/error.log while I create a new topic. I don't see anything happen when I first press the submit button. However, the page just hangs there, saying, "waiting for host." Then, the 500 error occurs at the same time as the following lines are written to the log:

[Thu May 05 11:32:56.135087 2016] [:error] [pid 8987] [client 192.168.250.2:55524] FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: PHP Warning: mysqli::stat(): Couldn't fetch mysqli in document root /libraries/joomla/database/driver/mysqli.php on line 219
[Thu May 05 11:32:56.152993 2016] [:error] [pid 8987] [client 192.168.250.2:55524] FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: PHP Warning: mysqli_close(): Couldn't fetch mysqli in document root /libraries/joomla/database/driver/mysqli.php on line 226


I'm seeing errors all over the page, but they appear before I actually get the error that led me to the forum. They appear as the page to create a new topic loads (but not as it gets submitted):


Strict Standards: Non-static method SimplePie_IRI::absolutize() should not be called statically, assuming $this from incompatible context in ///documentroot/libraries/simplepie/simplepie.php on line 9107

Strict Standards: Non-static method SimplePie_Misc::parse_url() should not be called statically, assuming $this from incompatible context in ///documentroot/libraries/simplepie/simplepie.php on line 6627

Strict Standards: Non-static method SimplePie_Misc::array_unique() should not be called statically, assuming $this from incompatible context in ///documentroot/libraries/simplepie/simplepie.php on line 5568

Strict Standards: Only variables should be assigned by reference in ///documentroot/modules/mod_light_rss/tmpl/default.php on line 16

Notice: Undefined index: error in ///documentroot/modules/mod_light_rss/tmpl/default.php on line 17
Alerts:
Notice: Undefined variable: tooltips in ///documentroot/modules/mod_light_rss/tmpl/default.php on line 52

Notice: Undefined index: description in ///documentroot/modules/mod_light_rss/tmpl/default.php on line 55

Notice: Undefined index: nofollow in ///documentroot/modules/mod_light_rss/tmpl/default.php on line 62

Notice: Undefined variable: desc in ///documentroot/modules/mod_light_rss/tmpl/default.php

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.177 seconds