×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Solved Internal Server when creating new Topics - no problems (when deleting topics)

More
4 years 2 months ago #11 by 810
looks there is a bug on module mod_light_rss, please disable it and try again.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #12 by mbruell
I've disabled mod_light_rss so the errors referencing that module have vanished.

However, I'm still getting the same 500 Server error, after a delay of about 30 seconds to process my posting/submitting of a new topic, or replying to an existing topic.

The file /var/log/apache2/errors.log contains:

[Thu May 05 14:39:03.800474 2016] [:error] [pid 7257] [client 192.168.250.2:58245] FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: PHP Warning: mysqli::stat(): Couldn't fetch mysqli in ///documentroot/libraries/joomla/database/driver/mysqli.php on line 219, referer: https://host/forum/for-sale-wanted.html
[Thu May 05 14:39:03.800579 2016] [:error] [pid 7257] [client 192.168.250.2:58245] FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: PHP Warning: mysqli_close(): Couldn't fetch mysqli in ///documentroot/libraries/joomla/database/driver/mysqli.php on line 226, referer: https://host/forum/for-sale-wanted.html
[Thu May 05 14:39:21.547898 2016] [:error] [pid 7523] [client 192.168.250.2:58277] FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: PHP Strict Standards: Non-static method modGTranslateHelper::getParams() should not be called statically in ///documentroot/modules/mod_gtranslate/mod_gtranslate.php on line 13, referer: https://host/forum/for-sale-wanted/997-any-errors-now.html
[Thu May 05 14:39:21.547967 2016] [:error] [pid 7523] [client 192.168.250.2:58277] FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: PHP Strict Standards: Only variables should be assigned by reference in ///documentroot/modules/mod_gtranslate/tmpl/default.php on line 115, referer: https://host/forum/for-sale-wanted/997-any-errors-now.html
[Thu May 05 14:39:21.547975 2016] [:error] [pid 7523] [client 192.168.250.2:58277] FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: PHP Strict Standards: Only variables should be assigned by reference in ///documentroot/modules/mod_gtranslate/tmpl/default.php on line 130, referer: https://host/forum/for-sale-wanted/997-any-errors-now.html
[Thu May 05 14:39:21.571632 2016] [:error] [pid 7523] [client 192.168.250.2:58277] FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: PHP Warning: mysqli::stat(): Couldn't fetch mysqli in ///documentroot/libraries/joomla/database/driver/mysqli.php on line 219, referer: https://host/forum/for-sale-wanted/997-any-errors-now.html
[Thu May 05 14:39:21.571696 2016] [:error] [pid 7523] [client 192.168.250.2:58277] FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: PHP message: PHP Warning: mysqli_close(): Couldn't fetch mysqli in ///documentroot/libraries/joomla/database/driver/mysqli.php on line 226, referer: https://host/forum/for-sale-wanted/997-any-errors-now.html
[Thu May 05 14:40:48.172547 2016] [fastcgi:error] [pid 6563] [client 192.168.250.2:58313] FastCGI: comm with server "/usr/lib/cgi-bin/php5-fcgi" aborted: idle timeout (30 sec), referer: https://host/forum/for-sale-wanted/997-any-errors-now/reply/1137.html

Thanks,
Marc

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #13 by 810

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #14 by mbruell
I assume you meant "now try disable mod_gtranslate" so I disabled it and rebooted the server (just to be sure I restarted all necessary processes). I got the same error in the web interface, and in the logs. Here are the relevant log entries:

[Fri May 06 07:36:45.937479 2016] [fastcgi:error] [pid 7262] [client 192.168.250.3:59683] FastCGI: comm with server "/usr/lib/cgi-bin/php5-fcgi" aborted: idle timeout (30 sec), referer: https://(host)/forum/newtopic.html
[Fri May 06 07:36:45.937567 2016] [fastcgi:error] [pid 7262] [client 192.168.250.3:59683] FastCGI: incomplete headers (0 bytes) received from server "/usr/lib/cgi-bin/php5-fcgi", referer: https:/(host)/forum/newtopic.html

Though both gtranslate and mod_light_rss were throwing errors of their own before I disabled them, they don't seem to be interacting with kunena, as the errors surrounding the creation of a new post, or replying to an existing one are still present in their same form regardless of whether those mods are enabled. This is actually good news, as we need gtranslate, and would like to offer rss feeds.

It's interesting that the errors we see occur 30 seconds or so *after* I press submit, but the posts are making it up to the forum.

As a further test of this, I submitted a reply to the previous post in one tab, and looked for it to show up in another tab. It showed up as quickly as I was able to switch tabs, and refresh the window. So, clearly the problem occurs when kunena is trying to retrieve the status *after* the post.

I'm not sure what it's doing in this phase - but this is where the problem occurs.

Please Log in or Create an account to join the conversation.

More
More
4 years 2 months ago - 4 years 2 months ago #16 by mbruell
Moving htaccess.txt to .htaccess seems to have had no effect on the problem, nor did any of the other suggestions in that thread.

Does the fact that the timeout error I'm receiving takes place *after* the post (or reply) makes it to the forum, help narrow the problem?

I discovered this by submitting a reply to a previous post in one tab, and looking for it to show up in another tab. It showed up as quickly as I was able to switch tabs, and refresh the window. So, clearly the problem occurs when kunena is trying to retrieve the status or refresh the page *after* the post.

What could be causing this kind of problem?
Last edit: 4 years 2 months ago by mbruell.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #17 by mbruell
Just an update - deleting posts takes place quickly: both the quick delete, and the delete permanently. Replying to a post still times out.

Thanks,

Marc

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #18 by mbruell
Searching the web for this error led me to this edit to php5-fpm.conf:

<IfModule mod_fastcgi.c>
AddHandler php5-fcgi .php
Action php5-fcgi /php5-fcgi
Alias /php5-fcgi /usr/lib/cgi-bin/php5-fcgi
FastCgiExternalServer /usr/lib/cgi-bin/php5-fcgi -socket /var/run/php5-fpm.sock -pass-header Authorization -idle-timeout 3600

<Directory /usr/lib/cgi-bin>
Require all granted
</Directory>

</IfModule>

I tried it, and the server no longer errors out, but still takes about 36 or 37 seconds to show the status of the post.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #19 by mbruell
Hi,

I notice that I don't have the delay when I post topics here. Can you detail your configuration (OS, version, etc), and the relevant configs in /etc/ so I can look more closely at mine?

Or, if you have any other ideas for things to look at - I'm open to that as well. Even though we no longer have the internal server error, the page takes too long to respond.

Thanks - good luck with the new release!

M

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #20 by mbruell
I think I figured it out. The server I've been working on is a clone of the live VM (with a few small changes - pointed to a local database, different IP, etc). A user complained of getting notified of my test posts on the cloned server. I looked at the users tab in kunena dashboard, and noticed that she was subscribed to the category to which I was posting. I selected all users and removed them from subscribing to the category as well as removed them from subscribing to all the individual posts. I sent another test post - really just to confirm that my users wouldn't get notified about my test posts. This test post was put up quickly, and the status page refreshed quickly.

I like having the functionality that users can subscribe to a category, and get notified of posts to it. Is there a limit to how many users can do this? Is there some way to continue to allow category based subscriptions, but not have the delays when posting?

Thanks,
Marc

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.102 seconds