Kunena 6.2.4 Released

The Kunena team has announce the arrival of Kunena 6.2.4 [K 6.2.4] which is now available for download as a native Joomla extension for J! 4.3.x/4.4.x/5.0.x. This version addresses most of the issues that were discovered in K 6.1 / K 6.2 and issues discovered during the last development stages of K 6.2

Question Issues accessing Joomla API under Joomla 5.0.2 and Kunena

More
3 weeks 1 day ago - 3 weeks 1 day ago #1 by GJSchaller
I recently upgraded an older site to Joomla 5.0.2, and Kunena 6.2.3.  After doing this, I tried to add the site to Akeeba Panopticon, which access the Joomla API.
Adding the site gave an error, and after working with Akeeba support, I narrowed it down to the "System - Kunena" plugin (v6.2.3) - when it's enabled, browsing to  testsite.aiskon.net/api/ gives an error, when it's disabled, the API responds as expected.
Oddly, this didn't happen on another site I upgraded a while back, but I think that one went from 5.2 to 6.1 to 6.2... it's been a while since I've done it, so I can't be sure.
(Edit: the other site didn't use Community Builder)
Any idea what may be causing this, and how to fix it?

Geoffrey Schaller
Technical Officer
Knight Realms
Last edit: 3 weeks 1 day ago by GJSchaller. Reason: Adding additional clues

Please Log in or Create an account to join the conversation.

More
3 weeks 1 day ago #2 by GJSchaller
After doing some more digging, it's specifically the "Kunena - Community Builder Integration" plugin for Kunena.

Geoffrey Schaller
Technical Officer
Knight Realms

Please Log in or Create an account to join the conversation.

More
3 weeks 15 hours ago #3 by xillibit

I recently upgraded an older site to Joomla 5.0.2, and Kunena 6.2.3.  After doing this, I tried to add the site to Akeeba Panopticon, which access the Joomla API.
Adding the site gave an error, and after working with Akeeba support, I narrowed it down to the "System - Kunena" plugin (v6.2.3) - when it's enabled, browsing to  testsite.aiskon.net/api/ gives an error, when it's disabled, the API responds as expected.
 
Hello,

Which is the error given in this case ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
3 weeks 12 hours ago - 3 weeks 12 hours ago #4 by GJSchaller
The URL is: testsite.aiskon.net/api/

When the plugin is disabled, the URL gives:

{"errors":[{"title":"Resource not found","code":404}]}

(This is the expected result)

When the plugin is enabled, the URL gives:

Unable to handle request for route ``.


Geoffrey Schaller
Technical Officer
Knight Realms
Last edit: 3 weeks 12 hours ago by GJSchaller. Reason: Updating error message & formatting

Please Log in or Create an account to join the conversation.

More
3 weeks 12 hours ago #5 by GJSchaller
xillibit, this is a test site, I can give you access if needed.

Geoffrey Schaller
Technical Officer
Knight Realms

Please Log in or Create an account to join the conversation.

More
1 week 3 days ago #6 by GJSchaller
This issue is persisting in 6.2.4 - can I do anything to help resolve it?

Geoffrey Schaller
Technical Officer
Knight Realms

Please Log in or Create an account to join the conversation.

More
1 week 3 days ago #7 by xillibit
Hello,

Please send me the credentials for your test site on my mail like that i check by myself

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
1 week 3 days ago #8 by GJSchaller
Xillibit, what is the best way to reach you to send credentials?  You can email me at [email protected] if you want, and I will reply.

Geoffrey Schaller
Technical Officer
Knight Realms

Please Log in or Create an account to join the conversation.

More
1 week 3 days ago #9 by GJSchaller
This message contains secure information

Geoffrey Schaller
Technical Officer
Knight Realms

Please Log in or Create an account to join the conversation.

More
1 week 2 days ago #10 by xillibit
It can't login here with the credentials when i open the page :

 

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

Time to create page: 0.345 seconds