Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

Question Kunena throwing "Call to undefined method stdClass::get()" error on fresh instal

More
1 year 4 months ago - 1 year 4 months ago #1 by toddjharrison
Hello!
I'm having some trouble with a fresh install of Kunena on a JoomlArt template.

Site: (currently offline for development)

I have successfully installed the forum from the download link on the Kunena site, so am running the most current version. My Joomla is version 4 and is running the most updated version as well as the most current version of the template.

Joomla! Version:    Joomla! 4.2.7 Stable [ Uaminifu ] 31-January-2023 15:00 GMT
Kunena Version: 6.0.8
PHP Version:    8.2.1

The exact error I'm receiving is: 
Code:
Call to undefined method stdClass::get()

I have run the Kunena diagnostics and there are no reported errors. I have rebuilt the menu and have received successful messages each time. I have searched Google and while there's quite a few 'stdClass' errors listed, none of them seem to have an empty 'get'.

The site is currently offline as its in development, but that has never been a problem in the past (I've deployed Kunena a ton of times in the last decade or so, and have never encountered this problem).

The template I'm using is Comics by JoomlArt if that info is beneficial to helping troubleshoot this.

Thank you in advance for any help you might be able to give to get this resolved and our project back on track.

Thank you!!

Todd

EDIT: Moderators, please move this to the appropriate category if appropriate, and apologies if I've mis-posted.

--
Todd Harrison
Founder: MyUAP Report
Last edit: 1 year 4 months ago by toddjharrison. Reason: Requested moderators move the post to the correct category.

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #2 by rich

I have rebuilt the menu and have received successful messages each time.

Have you moved Kunena menu items to other menus? Please create a configuration report.
The following user(s) said Thank You: toddjharrison

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #3 by toddjharrison

I have rebuilt the menu and have received successful messages each time.

Have you moved Kunena menu items to other menus? Please create a

 
I haven't moved the forums to a different menu or menu item. I have just used the menu item alias that is generated on install. And please find configuration report below:

This message contains confidential information

Database collation check: The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |
        

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 300 seconds | Max execution memory: 128M | Max file upload:  

Kunena menu details:

Warning: Spoiler!

Joomla default template details : ja_comics | author: JoomlArt | version: 1.0.0 | creationdate: September 16, 2022

Kunena default template details : Aurelia | author: Kunena Team | version: 6.0.8 | creationdate: 2023-01-17

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.0.8 | 2023-01-17 [ Git Repository ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None


--
Todd Harrison
Founder: MyUAP Report

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #4 by Leen
maybe your php version is too high
kunena and joomla don't work for me with php version 8.2.0 and higher
with php version 8.1.13 everything is ok

L.v.d.A
The following user(s) said Thank You: toddjharrison

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #5 by xillibit
There are plenty of fixes for php 8.2 in Joomla! 4.2.7 but with Kunena 6.0.x you will have plenty of deprecated messages not tested the install of Kunena with php 8.2

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #6 by toddjharrison
Thank you for the reply. I've swapped PHP down to 8.1 but it's still throwing the

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 300 seconds | Max execution memory: 128M | Max file upload:

Kunena menu details:

Warning: Spoiler!

Joomla default template details : ja_comics | author: JoomlArt | version: 1.0.0 | creationdate: September 16, 2022

Kunena default template details : Aurelia | author: Kunena Team | version: 6.0.8 | creationdate: 2023-01-17

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.0.8 | 2023-01-17 [ Git Repository ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None


--
Todd Harrison
Founder: MyUAP Report

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #7 by Leen
Hello,
Are you sure it's Kunena?
set your joomla at Global Configuration tab Server Error Reporting to maxium.
Maybe there will be more rules about error reporting.
And also test it with the original joomla template
Cassiopeia site template

L.v.d.A

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #8 by toddjharrison

Hello,
<p>Hello! Thank you for your response.</p>
Are you sure it's Kunena?[/quote]
<p>No, I'm not, but since this is a fresh install on a new domain and Kunena is the only extension throwing errors, it seemed an expedient place to start.</p>

set your joomla at Global Configuration tab Server Error Reporting to maxium.
Maybe there will be more rules about error reporting.
Already tried that. There's a few warnings about depreciated values on the article pages, but nothing that even hints at anything else. Trying to load the kunena on the front-end still just throws the stdClass error with no other errors present on the page.</p>

And also test it with the original joomla template
Cassiopeia site template
Now we're on to something. The forum loads with Cassiopia. I'm somewhat embarrassed that I didn't try that earlier. Sometimes it's hard to see the wood for the trees. :) I'll go ahead and contact JoomlArt and see what they have to say. Not sure what needs to happen with this thread, but mark it closed or whatever needs to happen. Thank you again for helping me troubleshoot this.
Todd

--
Todd Harrison
Founder: MyUAP Report

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #9 by Leen
quite possibly that with the JoomlArt template
\ Templates: Customize in the html folder
maybe disable there some overrides to test

L.v.d.A

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #10 by xillibit
Hello,

Enable debug mode into Joomla! report configuration panel and set error reporting on maximum if you re try you should get the backtrace with the error. Can-you give please the error with the backtrace ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

Time to create page: 0.588 seconds