×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved how to attach an mp3 in a post

More
6 years 1 month ago - 6 years 1 month ago #1 by DarKMaSk
Can anyone help about attaching an mp3 in a post from frontend and would be played on click ? The users are able to access the front-end only. Btw, allvideos plugin is not working.

Configuaration:
Joomla: 3.1.4
PHP: 5.3.24
mysql: 5.1.61
kunena: 3.0.1
Last edit: 6 years 1 month ago by DarKMaSk.
The topic has been locked.
More
6 years 1 month ago - 5 years 8 months ago #2 by Jiminimonka
AllVideos should work if you follow these instruction.

1. Make sure you have the latest version installed.
2. Go to Kunena Configuration > BBCode and set Auto-Link URLs to No.
3. Go to Joomla Plug-in Manager > System - Kunena Forum setting so that Joomla Content Plugin Support is set to Yes.

EDIT: You no longer need to turn off Auto-Link URLs in the latest version of Kunena


AllVideo can then be used, but you will most likely have to use the short version, ie no URL, so for youtube you would just put the number after the = sign e.g. {youtube}123456{/youtube}.

Example:
{soundcloud}https://soundcloud.com/zone0/sayonara-days-gone-bump{/soundcloud}

For future reference, the information in your signature is not your configuration report and would not help debugging most issues that arise.

Please read the FAQ.
Only one question per topic.
Search before you ask a question.
Last edit: 5 years 8 months ago by Jiminimonka. Reason: No longer need to turn of URL Auto-Link
The following user(s) said Thank You: DarKMaSk
The topic has been locked.
More
6 years 1 month ago - 6 years 1 month ago #3 by DarKMaSk

Jiminimonka wrote: AllVideos should work if you follow these instruction.

1. Make sure you have the latest version installed.
2. Go to Kunena Configuration > BBCode and set Auto-Link URLs to No.
3. Go to Joomla Plug-in Manager > System - Kunena Forum setting so that Joomla Content Plugin Support is set to Yes.

AllVideo can then be used, but you will most likely have to use the short version, ie no URL, so for youtube you would just put the number after the = sign e.g. {youtube}123456{/youtube}.

Example:

{soundcloud}https://soundcloud.com/zone0/sayonara-days-gone-bump{/soundcloud}

For future reference, the information in your signature is not your configuration report and would not help debugging most issues that arise.


Thank you for a quick reply. I did the exact things as you told but when I hit the submit button this error showed up:
"Error:Cannot save message: Message body is empty!"

And btw, I have no signature. I Just put a dotted line before starting the configuration list. I think the dotted line made the confusion. Next time I will not use that.
Last edit: 6 years 1 month ago by DarKMaSk.
The topic has been locked.
More
6 years 1 month ago #4 by sozzled

DarKMaSk wrote: I ... put a dotted line before starting the configuration list. I think the dotted line made the confusion. Next time I will not use that.

What you showed in msg #1 is not what we describe as a configuration report. Information that will help you to produce a more useful Kunena configuration report is given at the top of this page, in the FAQs page and in K 3.0 Configuration Report . I hope that helps you in future.
The following user(s) said Thank You: DarKMaSk
The topic has been locked.
More
6 years 1 month ago #5 by coder4life
Out of curiosity, is this the only text you are submitting to the form. Is there no alternate text being inserted outside the brackets? We have an issue with submitting things in a TAG based scenario {tag}{/tag}. The reason it has not been fixed is because it requires a bit of work.
The following user(s) said Thank You: DarKMaSk
The topic has been locked.
More
6 years 1 month ago - 6 years 1 month ago #6 by Jiminimonka

coder4life wrote: Out of curiosity, is this the only text you are submitting to the form. Is there no alternate text being inserted outside the brackets? We have an issue with submitting things in a TAG based scenario {tag}{/tag}. The reason it has not been fixed is because it requires a bit of work.


@coder4life - I have found this to happen sometimes. You can't have just the tags and no text, there has to be something else in the post or it won't allow you to save it.

@DarKMaSk - Make sure you have some text in the post you make and see if it works then.

Please read the FAQ.
Only one question per topic.
Search before you ask a question.
Last edit: 6 years 1 month ago by Jiminimonka.
The following user(s) said Thank You: DarKMaSk
The topic has been locked.
More
6 years 1 month ago #7 by DarKMaSk

coder4life wrote: Out of curiosity, is this the only text you are submitting to the form. Is there no alternate text being inserted outside the brackets? We have an issue with submitting things in a TAG based scenario {tag}{/tag}. The reason it has not been fixed is because it requires a bit of work.


The problem is solved but I think if there be a soundcoloud widget button in the bbcode, that would be much helpful, because it is very difficult for a normal user to place a code inside a post. And moreover to let them know we have to make a big tutorial with screenshots. :(

Please think over it.
The topic has been locked.
More
6 years 1 month ago #8 by DarKMaSk

Jiminimonka wrote:

coder4life wrote: Out of curiosity, is this the only text you are submitting to the form. Is there no alternate text being inserted outside the brackets? We have an issue with submitting things in a TAG based scenario {tag}{/tag}. The reason it has not been fixed is because it requires a bit of work.


@coder4life - I have found this to happen sometimes. You can't have just the tags and no text, there has to be something else in the post or it won't allow you to save it.

@DarKMaSk - Make sure you have some text in the post you make and see if it works then.


Thank you Jiminimonka, thanks a lot. It worked and the widget is running with its full glory. All the feature of the widget are present and working flawlessly. But, one small thing is there. Is there any way to reduce the height of the widget ?

I love Kunena, Kenena forum and I love you guys and gals. I love you all. I never experienced such a help, such a response on a free product. The 'FREE PRODUCT' can beat commercial products in every aspect, Kunena is the best example on that.

My regards to all of you.
The following user(s) said Thank You: Jiminimonka
The topic has been locked.
More
6 years 1 month ago #9 by Jiminimonka
Glad to help.

The widget height is controlled in AllVideos, you will have to play around with the settings in the admin panel for that, not sure if it will work but let us know.

While a BBCode button would be nice, its not too complicated to just put a post on your forums showing the users how you did it.

Please read the FAQ.
Only one question per topic.
Search before you ask a question.
The following user(s) said Thank You: DarKMaSk
The topic has been locked.
More
6 years 1 month ago #10 by DarKMaSk
Friends, I don't know whether I should post this because it may seems as an announcement but it is not. I humbly want to share some info regarding which I tried to solve but couldn't. Now it has been solved with the help of the friends in support and in the administration here. The entire credit goes to them, specially to the moderator Jiminimonka regarding this one.

Here is the link where you find the solution:
how to embed soundcloud widget inside a Kunena post

I hope it will be helpful.
The following user(s) said Thank You: Jiminimonka, welluforcedme
The topic has been locked.
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.090 seconds