×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× The error code HTTP 500 Internal Server Error is a general-purpose message this indicates a general error in a web application. Please note that there is no general solution for this general error. You should first read HTTP 500 Internal Server Error before posting in this category.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question 500 Error Following Post to Forum

More
4 years 7 months ago - 4 years 7 months ago #1 by robtudor
In the last 24 hours, Kunena users are receiving the following message when posting a message on our forum.

500 Internal Server Error
Fatal Error was detected!

Fatal Error: Call to a member function get() on a non-object in plugins/kunena/community/activity.php on line 94

The error was detected in the Kunena - Community Plugin.

For support click here: Kunena Support

Go back
No changes have been done to our site for the last few days.

The post is actually accepted before the error message appears.

I've subsequently disabled the Kunena-JomSocial Integration Plugin and the error no longer occurs but the integration with JomSocial is now gone. No avatars etc.

Site report follows

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 300 seconds | Max execution memory: 256M | Max file upload: 10M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : js_impacto | author: Joomlashack | version: 3.1.9 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.7 | creationdate: 2015-02-01

Kunena version detailed: Kunena 3.0.7 | 2015-02-01 [ Galah ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: Jomsocial 3.2.1.5

Third-party SEF components: None

Plugins: None

Modules: Kunena Login 3.0.1

Last edit: 4 years 7 months ago by robtudor. Reason: Add check box for replies

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #2 by robtudor
I've unset the "activity Stream Parameter" in the Kunena - JomSocial Integration plug-in and all seems to be OK now at the cost of the forum posts no longer appearing in the activity stream.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #3 by 810
You need 2 things to fix it:

1) Copy this code to plugins/kunena/plg_kunena_community/activity.php
raw.githubusercontent.com/Kunena/Kunena-...mmunity/activity.php

2) www.kunena.org/forum/11-JomSocial/132510...ream-language#162754

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #4 by usdjohnclark
I'm experiencing this issue right now.. how to solve this?

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #5 by 810
update to the lasted version

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #6 by usdjohnclark
downloading now.. thank you..

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.101 seconds