Kunena 6.1.3.2 Released

The Kunena team has announce the arrival of Kunena 6.1.3.2 [K 6.1.3] which is now available for download as a native Joomla extension for J! 4.2.x/4.3.x. This version addresses most of the issues that were discovered in K 6.1.0 and issues discovered during the last development stages of K 6.1

This section is for questions directly related to the procedure for installing Kunena for the first time or upgrading from an older version of Kunena.

Use this category:
  • to ask how to install or upgrade; or
  • if you encountered problems during the installation or upgrade procedure.

Use a different category to ask questions about problems that you may be having after you successfully installed or upgraded the currently supported version. If you are unsure what is the current supported version of Kunena, please go to the download page.

Solved new install fails, Missing class

More
9 months 1 week ago #1 by davidpoole
Am new to Kunena,

Downloaded the latest release - 6.0.7  4.2.x\4.1.x and am running the latest version of Joomla.

It installed without errors but when going to any part of the kunena component, it throws up this error and i am unable to do nothing at all with any option within the component

Class "Kunena\Forum\Libraries\Factory\KunenaFactory" not found


Can someone give me some directions of why a new install, of the latest version doesnt work????

Please Log in or Create an account to join the conversation.

More
9 months 1 week ago #2 by Leen
did a clean local install in wamp server. with joomla version 4.2.6
I noticed that kunena was having trouble installing the kunena menu. only after 2 clicks again in Kunena Forum: Dashboard installation of menu continued.
So maybe you can try again.

L.v.d.A
Attachments:

Please Log in or Create an account to join the conversation.

More
9 months 1 week ago #3 by davidpoole
Nope, did another install, clicked the dashboard of kunena several times before and

Anyone else advise please? Would like to attempt to use it, but if its this flaky on installation, then I might have to look elsewhere.

Please Log in or Create an account to join the conversation.

More
9 months 1 week ago #4 by Leen
did you get the download from this forum?
www.kunena.org/download

L.v.d.A

Please Log in or Create an account to join the conversation.

More
9 months 1 week ago - 9 months 1 week ago #5 by davidpoole
Yes of course. I got it from this link - (link doesnt show for some annoying reason, but its the SAME link you posted)
Last edit: 9 months 1 week ago by davidpoole.

Please Log in or Create an account to join the conversation.

More
9 months 1 week ago #6 by Leen
strange I have updated many site also to latest kunena version nowhere that message.
What kind of server does joomla use? and Which php version
And I don't know if it is possible, but can you go to the Kunena Forum in the administrator area: Dashboard ?
and also to Kunena Forum: Tools / Diagnostics
or you can find a Kunena Forum: Tools /Report Configuration
create and post here?

L.v.d.A

Please Log in or Create an account to join the conversation.

More
9 months 1 week ago #7 by Leen
I can only explain that somehow that folder is not accessible to kunena.
If I rename the folder here as a test, I do indeed see that error

L.v.d.A
Attachments:

Please Log in or Create an account to join the conversation.

More
9 months 1 week ago #8 by davidpoole
I have no access to any part of the Kunena installation, Every link in the admin panel for Kunena, provides the same failed message.
I am running php8.2 on a standard linux server hosting through a datacentre.

Any suggestions on how to get this working at all??

Please Log in or Create an account to join the conversation.

More
9 months 1 week ago #9 by Leen
ai
I don't have that php version 8.2 yet
you could check if these In addition we recommend the following PHP settings: are present
github.com/Kunena/Kunena-Forum/blob/6.0.7/README.md

L.v.d.A

Please Log in or Create an account to join the conversation.

More
9 months 1 week ago - 9 months 1 week ago #10 by davidpoole
It does say the following: PHP: version 7.4.1 or greater (>= 7.4.1 recommended)

I assumed php 8.2 would be good enough. Can anyone confirm this??

I wont be rolling back to an earlier version of php,  so can anyone confirm that php 8.2 should work and if not, when is kunena going to be php 8.2 ready??
Last edit: 9 months 1 week ago by davidpoole.

Please Log in or Create an account to join the conversation.

Time to create page: 0.405 seconds