×
Kunena 5.1.12.1 Released - Security release (22 Apr 2019)

The Kunena team has announce the arrival of Kunena 5.1.12.1 [K 5.1.12.1] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a security release.

× This section is for questions directly related to the procedure for installing Kunena for the first time or upgrading from an older version of Kunena.

Use this category:
  • to ask how to install or upgrade; or
  • if you encountered problems during the installation or upgrade procedure.

Use a different category to ask questions about problems that you may be having after you successfully installed or upgraded the currently supported version. If you are unsure what is the current supported version of Kunena, please go to the download page.

Question Upgrade from Kunena 1.7.2

More
2 months 2 weeks ago #1 by civano
I am planning to upgrade my site from Joomla 2.5 to Joomla 3.9
My Kunena is at rev 1.7.2
Can this be upgraded to Kunena 5.1.10?
The upgrade documentation page says
"The upgrade process can be done with any Kunena versions (K 1.0, K 1.5, K 1.6, K 2.0 or K 3.0)"

Any help with this would be greatly appreciated

- Charles Young

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #2 by rich
Replied by rich on topic Upgrade from Kunena 1.7.2
In principle it's easy (see here)

When the Joomla user IDs remain the same after the migration, probably you don't need step 1 and 2.
Nevertheless it's important: Backup additional to the main backup the Joomla user tables and also all Kunena tables extra!

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #3 by civano
Replied by civano on topic Upgrade from Kunena 1.7.2
I still feel very lost. Is there documentation that covers the way to handle Kunena in the process of upgrading Joomla from 2.5 to 3.X and preserve the existing forum data?
The recent versions of Kunena are not compatible with Joomla 2.5.
Further help would be much appreciated - thanks
- Charles

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #4 by rich
Replied by rich on topic Upgrade from Kunena 1.7.2
What is the problem? Have you not read this post? www.kunena.org/forum/general-questions-a...on-joomla-3-9#205996 This post contains a link to an older Kunena version which you can install as interim stage on Joomla 2.5. It contains also a link to a doc, where you can see, which database tables and folders you should have as backup.
I don't know which tool you use for the migration, but when the Joomla user IDs after the migration are the same as previously, you need only to install the new Kunena version over the old version.

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #5 by civano
Replied by civano on topic Upgrade from Kunena 1.7.2
Thank you very much for your reply. However, I could not find a reference in any of the links to which Kunena release I should as the interim step in going from Joomla 2.5.28 to Joomla 3.5.1 as the recommended Joomla process. In fact, I could not find where to download any pre Kunena 5.x revisions. (I assume there are many revisions between my 1.7.2 and 5.1.7)

Also, you mentioned migration tools. Is there one that you would strongly recommend?

I appreciate your help and patience.

- Charles

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #6 by rich
Replied by rich on topic Upgrade from Kunena 1.7.2

In fact, I could not find where to download any pre Kunena 5.x revisions. (I assume there are many revisions between my 1.7.2 and 5.1.7)

I've linked to the version which you can use. But when you nevertheless can't find the file, I give you the link directly to the zip.file github.com/Kunena/Kunena-Forum/releases/....0.14_2018-03-14.zip

Also, you mentioned migration tools. Is there one that you would strongly recommend?

I'm sorry, but I don't know migration tools which one I can recommend. I think, it is a better way, to migrate it manually. From Joomla 2.5 to 3.5 and afterwards upgrades the steps are not so hard.

Joomla 2.5 to 3.x Step by Step Migration

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #7 by civano
Replied by civano on topic Upgrade from Kunena 1.7.2
Thank you, Rich, for your timely reply. I did see the link you referenced earlier.

My specific question is this: Can I upgrade from Kunena 1.7.2 directly to the 5.0.14 version you referenced in my Joomla 2.5 website before I upgrade Joomla to 3.5.1? I did not think that Kunena 5.X was compatible with Joomla 2.5.28. If it is, that would be great.

I really appreciate your help - this is quite new to me.

Charles

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #8 by rich
Replied by rich on topic Upgrade from Kunena 1.7.2

My specific question is this: Can I upgrade from Kunena 1.7.2 directly to the 5.0.14 version you referenced in my Joomla 2.5 website before I upgrade Joomla to 3.5.1? I did not think that Kunena 5.X was compatible with Joomla 2.5.28. If it is, that would be great.

Yes, you can install Kunena 5.0.14 on Joomla 2.5 before you upgrade to Joomla 3.5.1. Afterwards, when Joomla is up to date then install also the current Kunena version. Thats in principle all.
The following user(s) said Thank You: civano

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #9 by civano
Replied by civano on topic Upgrade from Kunena 1.7.2
Hi Rich,

Thank you again for staying with me. I had a failure installing the 5.0.14 package. So I tried a more step-by-step approach and installed first 3.0.8 and then 4.0.11 successfully. Then I tried 5.0.14 again, but got the same error:

"Joomla! 2.5.28 is not supported. Minimum required version is Joomla! 3.5.1, but it is highly recommended to use Joomla! 3.6.2 or later.
Package Install: Custom install routine failure"

To me, this implies that 5.0.14 is not compatible with Joomla 2.5.28. Maybe you have a suggestion.

Is it possible to do another method: export the Kunena database table and then import that to the Joomla 3 site with a fresh install of Kunena 5.1.10

Appreciate your help
-Charles

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #10 by Sebi
Replied by Sebi on topic Upgrade from Kunena 1.7.2
Hi Charles,

why don't you update Joomla after updatig to Kunena 4.0.11 successfully? Joomla 2.5.x is outdated. The current Version is 3.9.5.

Sebi
The following user(s) said Thank You: civano

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.092 seconds