×
Kunena 5.1.5 Released - Security Release (Yesterday)

The Kunena team has announce the arrival of Kunena 5.1.5 [K 5.1.5] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This section is for questions directly related to the procedure for installing Kunena for the first time or upgrading from an older version of Kunena.

Use this category:
  • to ask how to install or upgrade; or
  • if you encountered problems during the installation or upgrade procedure.

Use a different category to ask questions about problems that you may be having after you successfully installed or upgraded the currently supported version. If you are unsure what is the current supported version of Kunena, please go to the download page.

Question error: "Kunena Installation Failed!"

More
1 year 6 months ago - 1 year 6 months ago #1 by carsten888
Update failed.



I tried to unpack the zip and install the system plugin first as suggested in this thread www.kunena.org/forum/k5-0-support-archiv...t-installation-error . Then I installed succesfully all the other extensions from the 'packages' folder. But when I go to the kunena backend I get this screen:



I set error_reporting to minimum in php.ini and in the Joomla global config set error reporting to 'none'. Still same thing when installing the zippackage and same screen when going to the backend.

Browser cache is disabled, so that won't mess things up.

How to get this working again?
Last edit: 1 year 6 months ago by carsten888.

Please Log in or Create an account to join the conversation.

More
More
1 year 6 months ago #3 by Hutchy68
There is definitely a bug in the installer. This is the 2nd update I have installed by having to drop from php 7 to 5.6. Update installs and moving back up to php 7 the forum works without issue. The only error I can find in error logs after searching php and Joomla logs is:

[11-Apr-2017 08:29:32 America/New_York] PHP Warning: Creating default object from empty value in /home/username/public_html/libraries/joomla/updater/update.php on line 267

Which is time stamped at the exact time of the update failure. So the question is, Joomla error or Kunena error?

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #4 by rich
Can you create a copy from your page and these upgrade to Joomla 3.7.0-rc? It seems, a file is missing (or 1 file isn't updated on Joomla).

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #5 by Hutchy68
Production site so I'm not upgrading to a RC. I will take a snapshot, create a git repo locally, branch it, then unzip the current vanilla cms release files over branch, delete install directory, then look at the diffs picked up. If there is a file missing or changed in core from site git will pick it up.

Please Log in or Create an account to join the conversation.

More
1 year 6 months ago #6 by Hutchy68
Try again. The production site is a match for 3.6.5, only new files picked up from unzip over current files -> image files of Joomla specific images in the image directory, 31 one of them to be exact. Plus, 7 minor file changes to .ini files, all weblinks related strings.

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #7 by Olivier @ Octopoos
Hi everyone,

We've encountered this error on a MySql database with a utf8mb4_unicode_ci collation.

The issue comes from the query that tries to create the #__kunena_attachments table because the index for this table is too long. To fix this, we've previously created the table through this query where we've reduced the size of the 'filename' and 'filename_real' columns from 255 to 190:

CREATE TABLE `#__kunena_attachments` (`id` int(11) NOT NULL auto_increment,`mesid` int(11) NOT NULL default '0',`userid` int(11) NOT NULL default '0',`protected` tinyint(4) NOT NULL default '0',`hash` char(32) NULL,`size` int(11) NULL,`folder` varchar(255) NOT NULL,`filetype` varchar(20) NOT NULL,`filename` varchar(190) NOT NULL,`filename_real` varchar(190) NOT NULL default '',`caption` varchar(255) NOT NULL default '',PRIMARY KEY (id),KEY `mesid` (mesid),KEY `userid` (userid),KEY `hash` (hash),KEY `filename` (filename),KEY `filename_real` (filename_real) ) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci;

After this, we've been able to install Kunena 5.0.7 without any other issue. There may be some other checks to do with posts attachments but at least, Kunena is installed!
The following user(s) said Thank You: xillibit

Please Log in or Create an account to join the conversation.

More
1 year 5 months ago #8 by xillibit
@Olivier @ Octopoos : thanks for your feedback, i have made the change it should be integrated into Kunena 5.0.8

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago - 1 year 4 months ago #9 by Hutchy68
Updating from 5.0.7 to 5.0.8 failed on PHP 7. Manually set back PHP to 5.6.x and updated by uploading package. 5.0.8 to 5.0.9, failed again on PHP 7, setting PHP to 5.6.x and updated by uploading package. So IMO it is not fixed. Do users have to do the database fix manually?
Last edit: 1 year 4 months ago by Hutchy68.

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #10 by xillibit
The fix is only for clean installation of Kunena, so in your case by just doing an update of Kunena you aren't concerned by this fix.

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.091 seconds