×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This section is for questions directly related to the procedure for installing Kunena for the first time or upgrading from an older version of Kunena.

Use this category:
  • to ask how to install or upgrade; or
  • if you encountered problems during the installation or upgrade procedure.

Use a different category to ask questions about problems that you may be having after you successfully installed or upgraded the currently supported version. If you are unsure what is the current supported version of Kunena, please go to the download page.

Question Template issues ?

More
3 years 10 months ago #1 by Alan-M
Template issues ? was created by Alan-M
Hi All

I'm having a small issue with the forum template on my site, just wondered if anyone has any suggestions how I might fix this :-

zantetravelguide.net/forum

Thanks in Advance

Regards

Alan.

Report Configuration

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 256M | Max file upload: 50M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : RSJuno! | author: RSJoomla! | version: 2.0.26 | creationdate: June 2015

Kunena default template details : Crypsisb3 | author: Kunena Team | version: 5.0.3 | creationdate: 2016-10-23

Kunena version detailed: Kunena 5.0.3 | 2016-10-23 [ Dibatag ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None


"Mistakes are always forgivable, If one has the Courage to admit them"

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #2 by rich
Replied by rich on topic Template issues ?
Your Joomla template not uses bootstrap 3 framework. Please switch to Crypsis. If it is not correctly displayed, then select in Backend -> Kunena -> Templates -> Crypsis -> Basic Settings -> Load Bootstrap css = Yes
The following user(s) said Thank You: Alan-M

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #3 by Alan-M
Replied by Alan-M on topic Template issues ?
Hello Rich

Thank you for your reply,, I tried what you said but still the same, I tried " Load Bootstrap css = Yes / Load Bootstrap css = No "

I also tried to load a different forum template but then I got could not locate the "XML" file ??

Thanks again

Alan

"Mistakes are always forgivable, If one has the Courage to admit them"

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #4 by rich
Replied by rich on topic Template issues ?

I tried what you said but still the same

It's not the same. Icons are missing and your menu items are not correct now. The menu items in the configuration report and on your page are different.

I also tried to load a different forum template but then I got could not locate the "XML" file ??

You must install it via "Kunena -> Templates -> New Template". But it works only with K5 templates.

First go to "Kunena -> Templates -> Crypsis -> Basic Settings" and enter in the field "Default category icon" icon-folder
Then click the next tab "Features" and select "Load External CDN Fontawesome = Yes"

Then repair the Kunena menus ( please see here ).

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #5 by rich
Replied by rich on topic Template issues ?
It seems, that no symbols to be loaded. Try this code in your custom.css

[class^="icon-"]::before, [class*=" icon-"]::before {
    font-family: FontAwesome;
}
The following user(s) said Thank You: Alan-M

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #6 by Alan-M
Replied by Alan-M on topic Template issues ?
Hello Rich

What location is that is that file please as I cant locate it

Sorry

"Mistakes are always forgivable, If one has the Courage to admit them"

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago - 3 years 10 months ago #7 by rich
Replied by rich on topic Template issues ?
Is the same way as with less ( see here ). You can add it also at the end in your Joomla template.css
Last edit: 3 years 10 months ago by rich.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #8 by Alan-M
Replied by Alan-M on topic Template issues ?
Thank you Rich

Was going a little white blind the other night, could not focus properly.

I added the code as directed but as you can see it stayed the same :(

I thought I would add an up to date "Report Configuration" in case anything has changed.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 256M | Max file upload: 50M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : RSJuno! | author: RSJoomla! | version: 2.0.26 | creationdate: June 2015

Kunena default template details : Crypsis | author: Kunena Team | version: 5.0.3 | creationdate: 2016-10-23

Kunena version detailed: Kunena 5.0.3 | 2016-10-23 [ Dibatag ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None



Don't know what else to try ...

Thanks again

Alan

"Mistakes are always forgivable, If one has the Courage to admit them"

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #9 by rich
Replied by rich on topic Template issues ?
Ok, then use this code with the value !important.
[class^="icon-"]::before, [class*=" icon-"]::before {
    font-family: FontAwesome !important;
}

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #10 by Alan-M
Replied by Alan-M on topic Template issues ?
Sorry Rich
Same as before ,

Thank you for your assistance

Regards

Alan

"Mistakes are always forgivable, If one has the Courage to admit them"

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.176 seconds