×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× Themen, die in diesen Bereich verschoben wurden, gelten allgemein als beendet. Falls es dazu noch zusätzliche Fragen gibt, können diese zwar noch gestellt werden, aber diese alten Themen sollten auf keinen Fall wieder auferstehen, um neue Probleme zu erörtern.
Eröffnet dazu bitte ein eigenes neues Thema.

Question Schlechter Titel bei der Kunena Startseite

More
6 years 4 months ago #1 by kepe
Seitdem ich auf die Kunena Version 2.0.4 upgedated habe, wird auf der Forum Startseite automatisch ":: Index" hinter den Namen des Forums hinzugefügt.

Ich nutze Joomla 1.5 und habe bereits versucht es über den Seitentiel beim Erstellen des Menüpunkts "Forum" zu ändern, doch Kunena überschreibt diesen Joomla Seitentitel.

Ich bekomme das ":: Index" einfach nicht weg. Und das hat ziemlich negative Auswirkungen auf die Besucher die über Google unser Forum suchen. Es sieht nämlich einfach merkwürdig aus wenn hinter dem schönen Titel "ThemaXY - Forum" noch ein ":: Index" steht. Die Folge ist das obwohl wir bei Google auf Platz 1 nicht Mal jeder 10. Besucher in unsere Forum kommt. Man klickt lieber auf eines unserer Konkurrenz-Foren, bei denen ein klarer Titel ohne ein ":: Index" steht.

Kann man das ::Index irgendwie entfernen? Es war bei der vorherigen Kunena-Version auch nicht vorhanden, und ich sehe den Sinn nicht weshalb es eingebaut wurde.

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago #2 by rich
Das ist kein schlechter Titel, sondern es ist der korrekte Pfad, welcher in der Adresse zu sehen ist. Es wurde nichts „eingebaut“.
Kontrolliere bitte mal im Hauptmenü, mit welchen Menüpunkt der Link zum Forum verknüpft ist. Es sollte der Menütyp „Alias“ sein und auf „Forum“ verlinken.

Ich nutze Joomla 1.5

Da hier genauere Angaben fehlen, Kunena 2.0.4 benötigt als Minimum Joomla 1.5.26 (siehe technische Voraussetzungen ).

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago #3 by kepe
Der Menüpunkt ist als "Kunena Startseite" "index.php?option=com_kunena&view=home" im Menü angegeben.

Als ich noch Kunena 1.X.X installiert hatte war der Titel korrekt, also einfach "Seitenname - Forum". Das einzigste was ich nun gemacht habe war Kunena 2.0.4 zu installieren. Sonst gab es keine Änderungen.
Doch jetzt lautet der Seitentitel "Seitenname - Forum ::Index" und es gibt keine mir ersichtliche Möglichkeit das "::Index" zu entfernen.

Und wenn es der korrekte Pfad ist, wofür soll er da sein? Ein "::Index" bietet für den Nutzer ja überhaupt keinen Mehrwert. Wenn es noch "::Übersicht" oder "::Startseite" heißen würde wäre es ja noch verständlicher, aber so?

Die notwendige Joomla-Version 1.5.26 ist übrigens vorhanden.

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago #4 by rich

Der Menüpunkt ist als "Kunena Startseite" "index.php?option=com_kunena&view=home" im Menü angegeben.

Und genau hier wird der Fehler zu suchen sein. Du verwendest einen Kunena Menüeintrag in deinem Hauptmenü ( siehe hier ). Gehe in dein Hauptmenü, öffne den Link zum Forum und klicke danach bei „Menütyp“ auf „Type ändern“. Danach wählst du ganz unten den Menütyp „Alias“ und als Ziel gibst du auf der rechten Seite den Menüpunkt „Forum“ an.

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago #5 by kepe

rich wrote:

Der Menüpunkt ist als "Kunena Startseite" "index.php?option=com_kunena&view=home" im Menü angegeben.

Und genau hier wird der Fehler zu suchen sein. Du verwendest einen Kunena Menüeintrag in deinem Hauptmenü ( siehe hier ). Gehe in dein Hauptmenü, öffne den Link zum Forum und klicke danach bei „Menütyp“ auf „Type ändern“. Danach wählst du ganz unten den Menütyp „Alias“ und als Ziel gibst du auf der rechten Seite den Menüpunkt „Forum“ an.


Ich habe jetzt im Standard Kunena Menu den Eintrag Forum (der vorher deaktiviert war) aktiviert und den anderen Menüpunkt im Hauptmenu mit "Alias" auf diesen Menüpunkt Forum im Kunena-Menü weitergeleitet.
Es lässt sich allerdings keine Veränderung feststellen, des "::Index" ist immer noch da.

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago #6 by rich
Erstelle bitte einen Konfigurationsbericht, damit ich die Menüs sehen kann. Vielleicht kann ich dann mehr ekennen.
Konfigurationsbericht erstellen

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago #7 by kepe
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 90 seconds | Max execution memory: 100M | Max file upload: 8M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : standard | author: Kevin Philipp | version: 1.5.23 | creationdate: 10 December 2011

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.1 | creationdate: 2011-11-16

Kunena version detailed: Kunena 2.0.4 | 2013-01-18 [ Pharmacopoeia ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 1.7.1 | UddeIM 2.5

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago #8 by rich
hm.. ich kann dieses Problem nicht erkennen. Bei mir wird auf der Startseite deines Forum kein „index“ hinten angezeigt, wenn ich es besuche. Wo sollte das zu finden sein?

Du verwendest das Kunena Template für Kunena 1.7. Das kann schon mal Fehler verursachen, hat aber mit deiner Frage nicht direkt etwas zu tun. Hast du das Template selbst angepasst, oder verwendest du die Funktion „Mischen mit Joomla!-Template“? Ist besser wenn du Blue Eagle 2.0 verwendest.

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago #9 by kepe
Der Titel wird üblicherweise in den Tabs oben im Browser angezeigt.
Wenn du schon auf der Seite bist ist er nicht so wichtig, aber wenn du mit dem passenden Keyword "[Name der Webseite] + Forum" bei Google suchst ist er eben direkt sichtbar und sehr wichtig.

Das Template steht auf mischen und einige Kleinigkeiten habe ich noch manuell (nur mit CSS) angepasst.

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago - 6 years 4 months ago #10 by rich
Ah.. jetzt ist mir klar, was du meinst. Mir ist es bis jetzt nicht aufgerfallen, aber du hast recht, es sieht etwas ungewöhnlich aus, auch deshalb, da in unserer Sprache ein zweifacher Doppelpunkt nicht üblich ist.
Du könntest den Doppelpunkt durch einen Bindestrich ersetzen, du findest diesen Eintrag in „administrator/components/com_kunena/libraries/view.php“ in der Zeile 448. es würde dann etwa so wie hier aussehen:
www.joomla-downloads.de/forum/index.html

Du könntest den Doppelpunkt aber auch durch ein Leerzeichen ersetzen, aber dann sollte auch das nachfolgende „Index“ nicht angezeigt werden. Das lässt sich verhindern, indem du in „components/com_kunena/views/category/view.html.php“ in Zeile 474 den Text „COM_KUNENA_VIEW_CATEGORIES_DEFAULT“ durch ein Leerzeichen ersetzt.
(Für diese Tipps übernehme ich keine Garantie.)
Last edit: 6 years 4 months ago by rich.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.122 seconds