Kunena 7.0.9 & Kunena 6.4.14 – Security Updates Released

The Kunena team has announce the arrival of Kunena 7.0.9 [K 7.0.9] in stable which is now available for download as a native Joomla extension for J! 5.4.x/6.0.x./6.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 / K 6.4 and issues discovered during the last development stages of K 7.0

Themen, die in diesen Bereich verschoben wurden, gelten allgemein als beendet. Falls es dazu noch zusätzliche Fragen gibt, können diese zwar noch gestellt werden, aber diese alten Themen sollten auf keinen Fall wieder auferstehen, um neue Probleme zu erörtern.
Eröffnet dazu bitte ein eigenes neues Thema.

Solved Moderator Fehler

  • Golf9000
  • Golf9000's Avatar Topic Author
  • New Member
  • New Member
More
14 years 2 months ago - 14 years 2 months ago #128374 by Golf9000
Replied by Golf9000 on topic Moderator Fehler
Vielen Dank ralle632 :laugh:

Werde es dawei nicht anzeigen lassen, bis es eine Lösung gibt.

Danke !!!

Gruß
Florian
Last edit: 14 years 2 months ago by Golf9000.

Please Log in or Create an account to join the conversation.

More
14 years 2 months ago #128377 by rich
Replied by rich on topic Moderator Fehler
Die Funktion „Benutzertyp anzeigen“ ist nur mehr für Joomla 1.5 vorhanden. Benutzertypen gibt es in Joomla 2.5 nicht mehr, es sei denn, dass du diesen Typ für jeden Benutzer einzeln in die Tabelle „users > usertype“ eintragen würdest.
Kunena hat immer nur den Benutzertyp aus der Joomla Tabelle angezeigt.

Es ist kein Bug, aber es wird auch keine Lösung mehr dazu geben.

Important! Always create a backup before you make any changes to your website!
The following user(s) said Thank You: Golf9000

Please Log in or Create an account to join the conversation.

More
14 years 2 months ago #128397 by ralle632
Replied by ralle632 on topic Moderator Fehler
Hallo Rich,

du hattest Recht, dies war Joomla 1.5 eigene Integration (usertype). :silly:
Aber der Supermoderator und Adminstrator wird angezeigt.

Sollte es doch Jemanden geben der unter Joomla 2.5 noch den Moderator angezeigt haben will, da er ja eventuell nicht weiß das dies unter Joomla 2.5 nicht mehr eingesetzt wird (genutzt wird), der kann ein kleines Override machen.
Code:
\administrator\language\de-DE\de-DE.com_kunena.libraries.ini

Dort kann man bei Bedarf den fehlenden language String erängzen unterhalb Zeile 372 (oder wo anders)
Code:
COM_KUNENA_VIEW_MODERATOR="Moderator"
Dies füllt die fehlende Lücke denke ich mal.

Sie wird natürlich bei einem Update wieder überschrieben. Aber vielleicht können ja die Chefs dies integrieren, wenn Bedarf besteht oder halt einen kleinen Hinweis im Kunena Backend hinterlassen, das diese Funktion nur für Joomla 1.5 Verwendung findet (Konfiguration -> Extras -> Benutzertyp anzeigen).


Please Log in or Create an account to join the conversation.

More
14 years 2 months ago #128402 by ralle632
Replied by ralle632 on topic Moderator Fehler
Ich denke das es doch ein fehlender String in der "de-DE.com_kunena.libraries.ini" war, denn in der user.php in der "public function getType" (Zeile 309) wird der String deklariert. Deswegen werden auch Besucher, Benutzer, Admin und Supermoderator angezeigt.

So nun hab ich genug gesucht. ;)

Nice Evening :)

Please Log in or Create an account to join the conversation.

  • Golf9000
  • Golf9000's Avatar Topic Author
  • New Member
  • New Member
More
14 years 2 months ago #128405 by Golf9000
Replied by Golf9000 on topic Moderator Fehler
Danke an ralle632 und rich für die tollen Antworten !!! :D

Diese haben mir bei meinem Problem sehr weitergeholfen.

Gruß
Florian

PS.: Muss ich des Thema auf gelöst irgendwie setzen.

Please Log in or Create an account to join the conversation.

More
14 years 2 months ago - 14 years 2 months ago #128409 by rich
Replied by rich on topic Moderator Fehler
Ich hab jetzt mit Joomla 1.5 getestet. Auch da wird der Moderator nicht angezeigt. Der String ist zwar vorhanden, aber in der kunena.ini. Von dort aus wird er nicht angezeigt (auch nicht mit Joomla 1.5).

Es wurde unheimlch viele Sprachstrings für Joomla 2.5 angepasst und umsortiert, da kann so etwas schon passieren.

Sie wird natürlich bei einem Update wieder überschrieben. Aber vielleicht können ja die Chefs dies integrieren, wenn Bedarf besteht oder halt einen kleinen Hinweis im Kunena Backend hinterlassen, das diese Funktion nur für Joomla 1.5 Verwendung findet (Konfiguration -> Extras -> Benutzertyp anzeigen).

Nachdem dieser String auch in Joomla 1.5 nicht angezeigt wird, muss es wohl noch ausgebessert werden.

PS.: Muss ich des Thema auf gelöst irgendwie setzen.

Habe es für dich gemacht. :)

Important! Always create a backup before you make any changes to your website!
Last edit: 14 years 2 months ago by rich.

Please Log in or Create an account to join the conversation.

Time to create page: 0.287 seconds