×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Please note: The Kunena project team takes NO responsibility for maintaining nor supporting anything in this category.

Question Index displaying Message - There are no published categories in .

More
4 years 3 months ago - 4 years 3 months ago #1 by webdevtim
Whether I select User Group or Access Level for this category I get this message when logged as user that belongs to User Group selected for the category. If I choose Access Level for the Category Permissions and then choose the access level that is connect to the user groups I want to have access to this category, I get the same message.

If I log in as super user I see full index with all categories listed.

If I look in Recent Topics when logged in as limited user I see posts to the categories to which the limited user is subscribed to. If I go to New Topics, I see that I have the two categories that the user is subscribed to available in the drop down and I can add a post and it displays in Recent Topics. When I go back to the Index tab I see the same message, There are no published categories in ...

What could I be doing wrong. I am going in circles trying to figure this out.
Last edit: 4 years 3 months ago by webdevtim. Reason: Added more info

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #2 by 810
I think you need to check the section permission.

Set section to: Usergroups -> Public

Then Change category permissions: User Groups Allowed To Post to "registered", same for reply

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #3 by webdevtim
But I don't want these to be visible to anyone except those that were given access privileges.

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #4 by sozzled
This topic has been discussed before in K 3.0: "There are no published categories in ." message . Same problem; same recommended solution.

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #5 by webdevtim
The problem was a had the section set to a particular user group. I set the section to registered and the problem was solved. I will create a public forum if I want something the public sees.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.123 seconds