×
Kunena 6.0.6 & Kunena 5.2.13 & blue eagle5 1.6.8 released as security release (28 Nov 2022)

The Kunena team has announce the arrival of Kunena 6.0.6 [K 6.0.6] which is now available for download as a native Joomla extension for J! 4.2.x. This is a security release.

Solved Template Icon Sets

More
1 year 1 month ago #1 by nickza
Template Icon Sets was created by nickza
Hi there

I would like to use the default Icon Categories, and Icon Sets for Crypsis. Can anyone confirm the default settings for the Crypsis template settings for all of the icons.
 

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #2 by rich
Replied by rich on topic Template Icon Sets
Check the Crypsis settings. Crypsis uses Bootstrap 2 symbols as default.

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #3 by nickza
Replied by nickza on topic Template Icon Sets
There are a few things I want to fix.
They are attached.
1st is the quote icon
2nd are the buttons underneath the posts. arent there others? cleaner?


 
Attachments:

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #4 by rich
Replied by rich on topic Template Icon Sets
1. In the text field should not be a symbol. Is your Kunena up to date?
2. Try the setting in Crypsis (tab Advanced) Show default actions = No.

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #5 by nickza
Replied by nickza on topic Template Icon Sets

1. In the text field should not be a symbol. Is your Kunena up to date?
2. Try the setting in Crypsis (tab Advanced) Show default actions = No.
 
Hi. Yes Kunena is 100% up to date.
That Show default actions - no is not what I meant. I like the default actions, I just dont like the button styles.
Thanks.

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #6 by Leen
Replied by Leen on topic Template Icon Sets
take a look at the kunena template Crypsis Features tab to see if Icon Type really does have bootstrap 2 enabled.
And otherwise try as a test by Template : crypsisb4
set as default and then set it there
at Icon Type <> bootstrap 2 on .
is it better then?

L.v.d.A
Attachments:

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #7 by nickza
Replied by nickza on topic Template Icon Sets
Hi
Thank you for the suggestions. Bootstrap 2 is select, and has always been selected.
When I changed to crypsis4, the forum style broke. The menu style was broken, and other things so I reverted back.

Its strange. Is there a way I can "reset" the templates 100%, even if that means breaking the forum for a bit? I just want to format the templates from scratch so I know we have a good base, but not mess up any of the configuration. I feel this is a files issue, not a config issue.

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #8 by Leen
Replied by Leen on topic Template Icon Sets
yes you can restore the kunena templates to the default settings. when you open the template to change settings it should have a button at the top with Restore if you use it it will restore everything. but I don't know if he also puts back any changes made in the custom css of that kunena template. ps or have you sometimes made adjustments in the Website template? custom .css or user.css settings ? and that Crypsisb4 may be corrupting everything it may be arguing with maybe Bootstrap from website template maybe it has a setting on or off somewhere

L.v.d.A

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #9 by nickza
Replied by nickza on topic Template Icon Sets

yes you can restore the kunena templates to the default settings. when you open the template to change settings it should have a button at the top with Restore if you use it it will restore everything. but I don't know if he also puts back any changes made in the custom css of that kunena template. ps or have you sometimes made adjustments in the Website template? custom .css or user.css settings ? and that Crypsisb4 may be corrupting everything it may be arguing with maybe Bootstrap from website template maybe it has a setting on or off somewhere
 
It probably does have something wrong, which is why I suggested deleting the kunena forum files and starting from scratch without deleting the forum data. Seems that might easier than trying to troubleshoot forever.

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #10 by rich
Replied by rich on topic Template Icon Sets
Crypsisb4 works only together with Joomla bootstrap4 templates.
The symbols which you not like, are the default bootstrap2 symbols, which are supported by your Joomla installation.
You can use Fontawesome instead, but there are no many difference (Crypsis setting "Icon Type = Fontawesome" + "Load External CDN Fontawesome = Yes").

Another possibility, if you have CSS know how, you can change the symbols via CSS. The symbols are defined via CSS code content. 
Example:
The code for the Action symbol is
.icon-apply:before,
.icon-edit:before,
.icon-pencil:before {
    content: "\2b";
}

Change the content with a content which you want. In this example the content for Folder+
If you add this code in your custom.less you have changed the symbol.
.icon-apply:before,
.icon-edit:before,
.icon-pencil:before {
    content: "\e234";
}

 

You find all available symbols in the icomoon.css, path /media/jui/css/icomoon.css
Attachments:

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.129 seconds