Kunena 6.2.4 Released

The Kunena team has announce the arrival of Kunena 6.2.4 [K 6.2.4] which is now available for download as a native Joomla extension for J! 4.3.x/4.4.x/5.0.x. This version addresses most of the issues that were discovered in K 6.1 / K 6.2 and issues discovered during the last development stages of K 6.2

Solved 404 error - no redirection to joomla login/register page

More
2 years 6 months ago #1 by Helge4u
Greetings from Frankfurt, Germany. It's two days ago now since my Synology DS218 updated to the DSM7 OS. Afterwards I noticed joomla is now in a folder "web_packages" (instead of "web") and I assume that might be a reason why I'm having problems with the Kunena Login now. When I klick the Kunena homepage link I should be redirected to the login/register page because only registered users are allowed. That worked all the the time and absolutely no configuration changes have been made the last month. Now, when I klick the link, I just get a 404 (page not found). I created a new test-link to Kunena Homepage in Joomla but it didn't help. When I login at Joomla first I get the Kunena menu as expected but when I'm not logged in it doesn't redirect me to the Joomla login as it did before. Any suggestion would be very much appreciated. I believe Kunena doesn't know the location of Joomla changed but I have no idea how I could tell it where to go.
This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |
       

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 240 seconds | Max execution memory: 128M | Max file upload: 32M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : protostar | author: Kyle Ledbetter | version: 1.0 | creationdate: 4/30/2012

Kunena default template details : Crypsis | author: Kunena Team | version: 5.2.6 | creationdate: 2021-07-25

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.2.6 | 2021-07-25 [ Melia ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #2 by rich

joomla is now in a folder "web_packages" (instead of "web") 

In this case, the address is not the same anymore. You must have only to empty the cache, then it should work again.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #3 by Helge4u
Hi Rich,
I already cleared the browser cache (Edge, IE, Firefox) and I also cleared all caches in Joomla. Makes no difference.

 

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #4 by rich
Check the redirect to the login form, this must be a customized option. When the forum is only for Registered, you have not an automatic redirect as default, but you see a text like 
"Please log in
Only community members can participate in this forum. You must register or log in to contribute."

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #5 by Helge4u
Hi rich,
my Kunena homepage menu has an item "Login" and the "Login Redirection Page" item simply has the value "default". Whatever that default is. It's two years ago since I installed Kunena and added it's homepage to my Joomly menu. Still I'm sure I didn't configure anything special. Maybe I'm losing memory in my age but I believe I would remember anything special.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #6 by rich
I've no idea, how your redirect has been created. In your configuration report the menu item Alpha-Okriftel-Forum redirects correct to the Kunena home.
After this link works for registered users, my suggestion:
Make hidden this menu item for guests.
Create a new menu item to the register or login form with name Alpha-Okriftel-Forum (or what ever you want) and makes this menu item only visible for guests.
So each user see the correct menu item, no matter if they are logged in or out.

Please Log in or Create an account to join the conversation.

More
2 years 6 months ago #7 by Helge4u
Hi rich,
thanks for your suggestion for a workaround, I think I will give it a try.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago - 2 years 5 months ago #8 by Helge4u
Rich, i have no idea where to find this menu:
>>Navigate to User Manager→Options→Component and change the Guest User Group from the default value of "Public" to "Guest", as shown below.<<
It's not my favorite solution anyway but I would use it if only I could restrict access to a menu item to "Guest-Only".
Last edit: 2 years 5 months ago by Helge4u.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #9 by rich
You find it at Users then on top right the button Options. But in principle, the user group Guest should already be available.
You need as next step only assign your module register form to Guest. Then it's only for logged-out user available.

Please Log in or Create an account to join the conversation.

More
2 years 5 months ago #10 by rich
It is even easier. Create a menu item in the main menu. Use the menu item type "System Links -> URL".
Enter the relative URL (without slash at the begin) to your login.
Example: The default URL for the Joomla login would be component/users/?view=login
Assign this menu item for Guest

Please Log in or Create an account to join the conversation.

Time to create page: 0.444 seconds