×
K5.1.1 is released (10 Jun 2018)

The Kunena team is pleased to announce Kunena 5.1.1 [K 5.1.1].
Please read the blog post for information:

Question Multiple email copies to the Admnistrator

More
1 year 10 months ago - 1 year 10 months ago #1 by mahmood
Hi,

Before posting I found exactly the same issue faced by another user in Kunena 3.0 forum, but that didn't seem to be resolved. Here is the URL of that post.

The Administrator is receiving 9-10 copies of the posts on the forum. Although Administrator is neither subscribed to any category nor to any topic. Administrator is not the moderator either. I got it checked from the hosting company if this is SMTP issue, they informed me each email is a separate email, so it seems I mis-configured Kunena. Can anyone please advise?

Configuration is give below:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 90 seconds | Max execution memory: 64M | Max file upload: 32M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : protostar | author: Kyle Ledbetter | version: 1.0 | creationdate: 4/30/2012

Kunena default template details : Blue Eagle | author: Kunena Team | version: 4.0.11 | creationdate: 2016-06-05

Kunena version detailed: Kunena 4.0.11 | 2016-06-05 [ Barcelona ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 1 year 10 months ago by mahmood.

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #2 by 810
try to disable the system mails on the joomla user account.

And try again, else try using the smtp mail.

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #3 by mahmood
Hi, thanks for your reply. I am new, kindly elaborate the following line.

"try to disable the system mails on the joomla user account"

Is it through Kunena or Joomla? Where exactly is the configuration?

Regards,

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #4 by 810
backend - users - usermanager - select the admin account - set Receive System emails to NO

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #5 by mahmood
Thanks, I saw the setting in Joomla User Manager "Receive System Emails". If I make it "NO", I 'll stop receiving any emails, that includes even useful emails from Joomla as well. Is there any better way of doing that only from Kunena? I want to figure out why Kunena is sending so many emails.

Regards,

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago - 1 year 10 months ago #6 by mahmood
It looks like I figured out the reason. Here is what I found:

My Settings are as follows:
  • E-mail Recipient Privacy=Hide Other Recipients (BCC)
  • E-mail to Multiple Recipients=5
  • Visible E-mail [email protected]

Because of above settings, Kunena is sending one email to 5 users, but all users are in the BCC and TO recipient is [email protected] The [email protected] was not created as proper email. Since "Catch All" is ON for Admin account, a copy of all emails from Kunena addressed to [email protected] is being received by the Admin account.

I have done these two settings and hope it will resolve now:
  1. E-mail to Multiple Recipients=0. Since I have < 100 users
  2. Visible E-mail [email protected] I created a new email account [email protected]

First of all, setting #1 should stop shooting a copy of all emails to TO "Visible E-mail Recipient" because Kunena will send each email directly to the subscriber. It will not bunch them in a group of 5 and hence need a "Visible E-mail Recipient" as TO while all other 5 are in the BCC.

Even for some reason multiple emails are still going, they will go to valid email address [email protected] and not to non-existing [email protected], which land to Admin account because of "Catch All" settings.

Hopefully it should resolve the issue. I'll report that after few days. What do you think, is above understanding correct?

Regards,
Last edit: 1 year 10 months ago by mahmood.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.097 seconds