- Posts: 7
- Thank you received: 0
Kunena 7.0.9 & Kunena 6.4.14 – Security Updates Released
The Kunena team has announce the arrival of Kunena 7.0.9 [K 7.0.9] in stable which is now available for download as a native Joomla extension for J! 5.4.x/6.0.x./6.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 / K 6.4 and issues discovered during the last development stages of K 7.0
Solved Rsform to Forum post
10 years 4 months ago - 10 years 4 months ago #175640
by CprlRst
Rsform to Forum post was created by CprlRst
HI,
I have both Kunena v4 and rsform and am looking to have rsform to submit an application to the forums using the mapping plugin that comes with rsforms.
No i have got to a stage where i cannot go any further i have gotten the test form to post to the forum how ever when the post is click i
Access Denied
You do not have permissions to access this page. and need help figuring out the rest the mapping is as follows
http://www.clipular.com/c/6734649658703872.png?k=ZfrQRqY_3rtc7_XbPh4wCyVb29U
i need to know how to add posted time and to get it readable inside the forums
Regards
CprlRst
I have both Kunena v4 and rsform and am looking to have rsform to submit an application to the forums using the mapping plugin that comes with rsforms.
No i have got to a stage where i cannot go any further i have gotten the test form to post to the forum how ever when the post is click i
Access Denied
You do not have permissions to access this page. and need help figuring out the rest the mapping is as follows
http://www.clipular.com/c/6734649658703872.png?k=ZfrQRqY_3rtc7_XbPh4wCyVb29U
i need to know how to add posted time and to get it readable inside the forums
Regards
CprlRst
Last edit: 10 years 4 months ago by CprlRst.
Please Log in or Create an account to join the conversation.
10 years 4 months ago #175641
by sozzled
Blue Eagle vs. Crypsis reference guide
Read my blog and
Replied by sozzled on topic Rsform to Forum post
You need to trigger at least three queries: one to update the table _kunena_topics, one for the table _kunena_messages and a third for the table _kunena_messages_text.
Blue Eagle vs. Crypsis reference guide
Read my blog and
The following user(s) said Thank You: CprlRst
Please Log in or Create an account to join the conversation.
10 years 4 months ago - 10 years 4 months ago #175643
by CprlRst
Replied by CprlRst on topic Rsform to Forum post
many thanks would you happen to know the value to add the next thread id into the database
as i have added the following
http://www.clipular.com/c/6742469988843520.png?k=W-yw4VbXDcVqi6wSJvQ0feGGiLI
and get the following error
Duplicate entry '31' for key 'PRIMARY' SQL=INSERT INTO `#__kunena_messages` SET `id` = '31' , `thread` = '31' , `catid` = '6' , `name` = '627' , `userid` = ',627'
as i have added the following
http://www.clipular.com/c/6742469988843520.png?k=W-yw4VbXDcVqi6wSJvQ0feGGiLI
and get the following error
Duplicate entry '31' for key 'PRIMARY' SQL=INSERT INTO `#__kunena_messages` SET `id` = '31' , `thread` = '31' , `catid` = '6' , `name` = '627' , `userid` = ',627'
Last edit: 10 years 4 months ago by CprlRst. Reason: added info
Please Log in or Create an account to join the conversation.
10 years 4 months ago - 10 years 4 months ago #175645
by sozzled
Blue Eagle vs. Crypsis reference guide
Read my blog and
Replied by sozzled on topic Rsform to Forum post
I've never used RSForm.
I've never attempted to update the Kunena message tables other than using the standard interface (... well, that's not entirely true because I know my way around the database).
I haven't looked into the 120,000+ lines of code in Kunena to see where the standard interface updates the table.
As I wrote earlier, there are (at least) three tables that need to be updated. There may also be others (e.g. updating posts in _kunena_users). In effect, we're trying to mimic the way database update is performed by Kunena.
I'm guessing that you have extraneous entries in your database and you need to get the three tables back into synch. Perhaps, if you delete some of your test data, get the ids synched, you won't run into those failed attempts to enter a new record with the same primary key as another record that already exists (?)
I've never attempted to update the Kunena message tables other than using the standard interface (... well, that's not entirely true because I know my way around the database).
I haven't looked into the 120,000+ lines of code in Kunena to see where the standard interface updates the table.
As I wrote earlier, there are (at least) three tables that need to be updated. There may also be others (e.g. updating posts in _kunena_users). In effect, we're trying to mimic the way database update is performed by Kunena.
I'm guessing that you have extraneous entries in your database and you need to get the three tables back into synch. Perhaps, if you delete some of your test data, get the ids synched, you won't run into those failed attempts to enter a new record with the same primary key as another record that already exists (?)
Blue Eagle vs. Crypsis reference guide
Read my blog and
Last edit: 10 years 4 months ago by sozzled.
Please Log in or Create an account to join the conversation.
10 years 4 months ago - 10 years 4 months ago #175693
by CprlRst
Replied by CprlRst on topic Rsform to Forum post
ok things seem to be synced back but still getting
Access Denied
You do not have permissions to access this page.
when trying to view post just wondering what tables need to be adjusted for a post work gotta be missing something simple i believe
Access Denied
You do not have permissions to access this page.
when trying to view post just wondering what tables need to be adjusted for a post work gotta be missing something simple i believe
Last edit: 10 years 4 months ago by CprlRst.
Please Log in or Create an account to join the conversation.
10 years 4 months ago #175713
by sozzled
Blue Eagle vs. Crypsis reference guide
Read my blog and
Replied by sozzled on topic Rsform to Forum post
HTTP 404 Not Found
errors are typically unrelated to the "database" in Joomla; typically, these kinds of problems are caused by something in the menuing/routing. There must be literally thousands of references in this forum on the subject of how to properly setup your Joomla menu so that it properly references Kunena.
Without knowing anything about your website it's almost impossible to help analyse the specific cause of your problem but, in general terms, for a forum post to "work", in MVC terms, there needs to be a view and for the view to work there needs to be a menu item.
Without knowing anything about your website it's almost impossible to help analyse the specific cause of your problem but, in general terms, for a forum post to "work", in MVC terms, there needs to be a view and for the view to work there needs to be a menu item.
Blue Eagle vs. Crypsis reference guide
Read my blog and
Please Log in or Create an account to join the conversation.
Time to create page: 0.217 seconds