×
Blue Eagle (1.5.0) for K5.1 is released (20 Jul 2018)

Please update the Kunena Blue Eagle to 1.5.0 if you use Kunena 5.1.
We made several bug fixes and improvements. Also Blue Eagle has now all the features from Crypsis.
Download: www.kunena.org/download/templates/category/blue-eagle-5

Question Rsform to Forum post

More
2 years 2 months ago - 2 years 2 months ago #1 by CprlRst
Rsform to Forum post was created by CprlRst
HI,

I have both Kunena v4 and rsform and am looking to have rsform to submit an application to the forums using the mapping plugin that comes with rsforms.

No i have got to a stage where i cannot go any further i have gotten the test form to post to the forum how ever when the post is click i
Access Denied
You do not have permissions to access this page. and need help figuring out the rest the mapping is as follows



i need to know how to add posted time and to get it readable inside the forums


Regards

CprlRst
Last edit: 2 years 2 months ago by CprlRst.

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #2 by sozzled
Replied by sozzled on topic Rsform to Forum post
You need to trigger at least three queries: one to update the table _kunena_topics, one for the table _kunena_messages and a third for the table _kunena_messages_text.
The following user(s) said Thank You: CprlRst

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago - 2 years 2 months ago #3 by CprlRst
Replied by CprlRst on topic Rsform to Forum post
many thanks would you happen to know the value to add the next thread id into the database

as i have added the following



and get the following error

Duplicate entry '31' for key 'PRIMARY' SQL=INSERT INTO `#__kunena_messages` SET `id` = '31' , `thread` = '31' , `catid` = '6' , `name` = '627' , `userid` = ',627'
Last edit: 2 years 2 months ago by CprlRst. Reason: added info

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago - 2 years 2 months ago #4 by sozzled
Replied by sozzled on topic Rsform to Forum post
I've never used RSForm.

I've never attempted to update the Kunena message tables other than using the standard interface (... well, that's not entirely true because I know my way around the database).

I haven't looked into the 120,000+ lines of code in Kunena to see where the standard interface updates the table.

As I wrote earlier, there are (at least) three tables that need to be updated. There may also be others (e.g. updating posts in _kunena_users). In effect, we're trying to mimic the way database update is performed by Kunena.

I'm guessing that you have extraneous entries in your database and you need to get the three tables back into synch. Perhaps, if you delete some of your test data, get the ids synched, you won't run into those failed attempts to enter a new record with the same primary key as another record that already exists (?)
Last edit: 2 years 2 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago - 2 years 2 months ago #5 by CprlRst
Replied by CprlRst on topic Rsform to Forum post
ok things seem to be synced back but still getting

Access Denied
You do not have permissions to access this page.

when trying to view post just wondering what tables need to be adjusted for a post work gotta be missing something simple i believe
Last edit: 2 years 2 months ago by CprlRst.

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #6 by sozzled
Replied by sozzled on topic Rsform to Forum post
HTTP 404 Not Found errors are typically unrelated to the "database" in Joomla; typically, these kinds of problems are caused by something in the menuing/routing. There must be literally thousands of references in this forum on the subject of how to properly setup your Joomla menu so that it properly references Kunena.

Without knowing anything about your website it's almost impossible to help analyse the specific cause of your problem but, in general terms, for a forum post to "work", in MVC terms, there needs to be a view and for the view to work there needs to be a menu item.

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #7 by CprlRst
Replied by CprlRst on topic Rsform to Forum post
Thanks for the input the 404 error occurs when clicking the forum post made via the above addition to the database so I'm thinking I have like half the post creation sorted but missing a key component

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #8 by sozzled
Replied by sozzled on topic Rsform to Forum post
As I wrote earlier, without knowing anything about your website, it's next-to-impossible analyse the cause of your problem. 95% of "HTTP 404 Not Found" errors in Joomla are related to the menu—I am taking a wild but educated guess. So, how have you set up your forum menu?

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #9 by CprlRst
Replied by CprlRst on topic Rsform to Forum post
The actual forum works fine if you post using the forum all is great but when trying to mimic a post from rsform using the mapping function clicking the post gives a 404 error. I will make a sample site to show the error

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #10 by CprlRst
Replied by CprlRst on topic Rsform to Forum post
ok i have setup the test location

johnmaguire.org.uk/index.php/forum/welcome-mat

there you can see test post that gives a you do not have permission to view which seems what the 404 error was being confused with by the site owner.

if you click form from the menu it will show the form thats trying to be added to the forum.

i hope this helps a little

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.122 seconds