Kunena 6.2.4 Released

The Kunena team has announce the arrival of Kunena 6.2.4 [K 6.2.4] which is now available for download as a native Joomla extension for J! 4.3.x/4.4.x/5.0.x. This version addresses most of the issues that were discovered in K 6.1 / K 6.2 and issues discovered during the last development stages of K 6.2

Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Uploading images in New Topics

More
2 months 2 weeks ago - 2 months 2 weeks ago #1 by joanddavid
Hi
I have just installed Kunena 6.2.1 and am having an issue with uploading images into new topics.
I create a new topic and try to upload an image, but I cannot use the drop files method or the +Add Files button.
The +Add Files button does not change color when hovering over it.
However if I save the topic, then edit it, I am able to upload images by either method.
The configuration is set to allow uploads after 0 posts.
I have also used the profile to make over a dozen posts.
Any pointers greatly appreciated
DavidKunena Profile InformationKunena function Kunena\Forum\Libraries\Controller\Application\Display::before(): 0.157 / 0.200 seconds (1 calls)
Kunena function Kunena\Forum\Site\Controller\Category\Topics\CategoryTopicsDisplay::execute(): 0.022 / 0.042 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\Access\KunenaAccess::getInstance(): 0.000 / 0.039 seconds (17 calls)
Kunena function Kunena\Forum\Libraries\Access\KunenaAccess::__construct(): 0.039 / 0.039 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\Forum\Category\KunenaCategoryHelper::initialize(): 0.000 / 0.014 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\Forum\Category\KunenaCategoryHelper::loadCategories(): 0.001 / 0.012 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\Forum\Category\KunenaCategoryHelper::get(): 0.010 / 0.010 seconds (50 calls)
Kunena Total Time: 0.002 / 0.008 seconds (2 calls)
Kunena function Kunena\Forum\Libraries\Forum\Topic\KunenaTopicHelper::getLatestTopics(): 0.006 / 0.006 seconds (2 calls)
Kunena function Kunena\Forum\Libraries\Factory\KunenaFactory::loadLanguage(): 0.004 / 0.004 seconds (6 calls)
Kunena render layout 'Widget/Module': 0.004 / 0.004 seconds (4 calls)
Kunena function Kunena\Forum\Libraries\Access\KunenaAccess::getAllowedCategories(): 0.002 / 0.002 seconds (6 calls)
Kunena function Kunena\Forum\Site\Controller\Category\Index\CategoryIndexDisplay::execute(): 0.001 / 0.001 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\Route\KunenaRoute::resolveAlias(): 0.001 / 0.001 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\User\KunenaUserHelper::loadUsers(): 0.001 / 0.001 seconds (2 calls)
Kunena function Kunena\Forum\Libraries\Route\KunenaRoute::_(): 0.000 / 0.001 seconds (3 calls)
Kunena function Kunena\Forum\Libraries\Layout\KunenaLayout::getCategoryLink(): 0.000 / 0.001 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\Route\KunenaRoute::setItemID(): 0.000 / 0.000 seconds (5 calls)
Kunena render layout 'Widget/Forumjump': 0.000 / 0.000 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\Route\KunenaRoute::_(t): 0.000 / 0.000 seconds (2 calls)
Kunena function Kunena\Forum\Libraries\Route\KunenaRoute::normalize(): 0.000 / 0.000 seconds (2 calls)
Kunena function Kunena\Forum\Libraries\Route\KunenaRoute::initialize(): 0.000 / 0.000 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\Route\KunenaRoute::prepare(): 0.000 / 0.000 seconds (6 calls)
Kunena function build(): 0.000 / 0.000 seconds (3 calls)
Kunena function Kunena\Forum\Libraries\Route\KunenaRoute::getItemID(): 0.000 / 0.000 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\Route\KunenaRoute::build(): 0.000 / 0.000 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\User\KunenaUserHelper::get(): 0.000 / 0.000 seconds (31 calls)
Kunena function Kunena\Forum\Libraries\Forum\Category\KunenaCategoryHelper::getCategories(): 0.000 / 0.000 seconds (5 calls)
Kunena function Kunena\Forum\Libraries\Route\KunenaRoute::getHome(): 0.000 / 0.000 seconds (22 calls)
Kunena function Kunena\Forum\Libraries\Forum\Category\KunenaCategory::getChannels(): 0.000 / 0.000 seconds (3 calls)
Kunena function Kunena\Forum\Libraries\Forum\Category\KunenaCategoryHelper::getChildren(): 0.000 / 0.000 seconds (3 calls)
Kunena function Kunena\Forum\Libraries\Forum\Category\KunenaCategoryHelper::getParents(): 0.000 / 0.000 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\Forum\Category\KunenaCategoryHelper::buildTree(): 0.000 / 0.000 seconds (1 calls)
Kunena function Kunena\Forum\Libraries\Controller\Application\Display::execute(): -0.200 / 0.000 seconds (1 calls)
Kunena render layout 'category/default': -0.044 / 0.000 seconds (1 calls)
Kunena render layout 'Category/Index': -0.008 / 0.000 seconds (1 calls)
Last edit: 2 months 2 weeks ago by joanddavid. Reason: adding the profile information

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago - 2 months 2 weeks ago #2 by Leen
Replied by Leen on topic Uploading images in New Topics
Please create a Configuration Report

L.v.d.A
Last edit: 2 months 2 weeks ago by Leen.

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #3 by joanddavid
Apologies, I attached the wrong thing.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload:

Kunena menu details:

Warning: Spoiler!

Joomla default template details : cassiopeia | author: Joomla! Project | version: 1.0 | creationdate: 2017-02

Kunena default template details : Aurelia | author: Kunena Team | version: 6.2.1 | creationdate: 2023-11-10

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.2.1 | 2023-11-10 [ Git Repository ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 2.9.0

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago - 2 months 2 weeks ago #4 by Leen
Replied by Leen on topic Uploading images in New Topics
Are you perhaps using a security extension or plugin?
and you use community builder, check if there are any settings that limit this, for example
Community Builder: Edit Configuration [CB Core] images tab or by
Community Builder: Tools synchronize users etc
 

L.v.d.A
Last edit: 2 months 2 weeks ago by Leen.

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #5 by rich
Replied by rich on topic Uploading images in New Topics
I think the Create New Topic menu item in the main menu is the problem. This should be removed, as it is not clear whether a new topic should be created in the Spanish or English forum section.
Furthermore, the two menu items Foro and Besos Forum should be fixed (see image). Links of other menus, which are linked to the forum, must be Menu Item Type = Menu Item Alias (see here) .
If you want to change the start page for the forum from New Topics to Index, this is the right way (see here) .
.
 

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #6 by joanddavid
The problem is with uploading images, not with the menus, they were working fine. However I made the changes you suggested, but the problem remains the same.
You cannot upload an image to a new topic, however after you save the topic you can edit and upload images.

On new topics The +Add Files button does not change when you hover, and you cannot drop files, or click and select.

New config file.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload:

Kunena menu details:

Warning: Spoiler!

Joomla default template details : cassiopeia | author: Joomla! Project | version: 1.0 | creationdate: 2017-02

Kunena default template details : Aurelia | author: Kunena Team | version: 6.2.1 | creationdate: 2023-11-10

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.2.1 | 2023-11-10 [ Git Repository ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 2.9.0

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago - 2 months 2 weeks ago #7 by rich
Replied by rich on topic Uploading images in New Topics

The problem is with uploading images, not with the menus, they were working fine.

I had read that the problem exists when uploading images. However, incorrectly created menu items repeatedly lead to errors. According to the configuration report, the incorrectly created menu item Create new topic is still in the main menu.
What happens if you go to a category and try to create a new topic with an image using the button?
.
 
Last edit: 2 months 2 weeks ago by rich.

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #8 by joanddavid
Firstly, thanks for your help with this.

OK.
I deleted the forum links on the main Joomla menus.
I deleted both the English and Spanish forum menus.
I emptied the trash from all menus.
In the tools section I recreated the default Kunena menu.
In the English Joomla menu I created an alias, and linked it to the Kunena menu item Forum.
Now I only get a list of recent topics, there is no Forum menu!

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload:

Kunena menu details:

Warning: Spoiler!

Joomla default template details : cassiopeia | author: Joomla! Project | version: 1.0 | creationdate: 2017-02

Kunena default template details : Aurelia | author: Kunena Team | version: 6.2.1 | creationdate: 2023-11-10

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.2.1 | 2023-11-10 [ Git Repository ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 2.9.0

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #9 by rich
Replied by rich on topic Uploading images in New Topics
I'm sorry, but you should delete the menu item Create New Topic in the main menu. You have deleted everything else and exactly this one menu item that should be gone, I see again in the configuration report and it is not an alias. You can find the menu type Alias under System Links -> Menu Item Alias.

Actually, all categories, regardless of language, should now be displayed under the newly created menu items.

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #10 by joanddavid
All the items are aliases
This is a screen shot of the Kunena menu 

Please Log in or Create an account to join the conversation.

Time to create page: 0.472 seconds