Kunena 6.2.4 Released

The Kunena team has announce the arrival of Kunena 6.2.4 [K 6.2.4] which is now available for download as a native Joomla extension for J! 4.3.x/4.4.x/5.0.x. This version addresses most of the issues that were discovered in K 6.1 / K 6.2 and issues discovered during the last development stages of K 6.2

Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question MySQL upgrade issue - Need help

More
4 months 1 day ago #1 by Indrit
Hello, I run my joomla site on Bluehost (shared hosting). Recently i noticed there is a Kunena forum upgrade which I can complete because I get the following message"MySQL 5.7.23-23 is not supported. Minimum required version is MySQL 5.7.30, but it is highly recommended to use MySQL 5.7.30 or later."

I reached out to Bluehost, and they said "Unfortunately it is not possible to update the Mysql database in the shared hosting."

Before I walk away from Kunena, is there a way to solve this even in a shared hosting provider?

Thanks, Indrit
 

Please Log in or Create an account to join the conversation.

More
4 months 17 hours ago - 4 months 17 hours ago #2 by xillibit
Hello,

MySQL 5.7.23 is pretty old it has been released in 2018-07-27. Because you are not the only one to ask, I will set the minimum version for MySQL to 5.7.23. It will be present in the next release of Kunena the 6.2.1

Ask to your hoster to update to Mysql 8 or to switch to to Mariadb 10.4 because this are the minimum requirements for Joomla ! 5.0

I don't provide support by PM, because this can be useful for someone else.
Last edit: 4 months 17 hours ago by xillibit.

Please Log in or Create an account to join the conversation.

More
4 months 1 hour ago #3 by Indrit
I try to install new updates (Kunena Forum and Kunena Language Pack" and I got the following message

This extension does not provide a checksum for validation of the integrity of the downloaded file.
Extension Update: Custom install routine failure.
Before updating ensure that the update is compatible with your Joomla! installation.
You are strongly advised to make a backup of your site's files and database before you start updating.
×
info
MySQL 5.7.23-23 is not supported. Minimum required version is MySQL 5.7.30, but it is highly recommended to use MySQL 5.7.30 or later.
×
danger
Error updating package.

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago - 3 months 2 weeks ago #4 by xillibit
Hello,

Like i had said in my previous post you need to wait the version 6.2.1 which allow the instalation from Mysql 5.7.23.  But if you don't want to wait you can use this nightly build which have the fix : update.kunena.org/nightlybuilds/pkg_kune...1-DEV_2023-11-05.zip

For the checksum error message this isn't mandatory to use so don't take attention of it

I don't provide support by PM, because this can be useful for someone else.
Last edit: 3 months 2 weeks ago by xillibit.
The following user(s) said Thank You: Marvin McDuck, Indrit

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago #5 by Indrit
Very good thank you!

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #6 by Marvin McDuck
Details if relevant (I'm in the same boat!) from BlueHost:

Database server
Server type: Percona Server
Server version: 5.7.23-23 - Percona Server (GPL), Release 23, Revision 500fcf5
Protocol version: 10

Web server
cpsrvd 11.110.0.14
Database client version: libmysql - mysqlnd 8.1.16
PHP extension: mysqli Documentation curl Documentation mbstring Documentation
PHP version: 8.1.16

The manuals you find online make it seem as if you can install MariaDB, but so far I haven't been able to. Their hosting is just confusing, layout keeps changing; it greets me with "you have no website, let's make one" as it assumes WordPress -- a few clicks later I have my partial CPanel.

Time to change hosting I guess, I'm fed up.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #7 by Indrit
I tried to install the new version and I got this message:

danger
"Unable to detect manifest file"

I think i won't try it anymore. If it is hard on installation, think about the rest.

My apologies, but this has been nothing but headaches.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago - 2 months 3 weeks ago #8 by xillibit
Hello,

The error message "Unable to detect manifest file" could mean that the xml file for the package isn't in utf8 in your system, in the zip the xml files are right in utf8. So it's weird that it has been corrupted or changed from something else than utf8 on your hosting

I don't provide support by PM, because this can be useful for someone else.
Last edit: 2 months 3 weeks ago by xillibit.

Please Log in or Create an account to join the conversation.

Time to create page: 0.330 seconds